Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Konflikte bei world update
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Mon Aug 15, 2016 8:53 pm    Post subject: Konflikte bei world update Reply with quote

Es ist 2 Monten her, als ich mein letztes -uvaDN world update gemacht habe.

Nun habe wollte ich es machen und ich bekomme:

Code:

[blocks B      ] <dev-qt/qtwebkit-4.10.4:4[gstreamer] ("<dev-qt/qtwebkit-4.10.4:4[gstreamer]" is blocking media-libs/phonon-gstreamer-4.9.0)

Total: 139 packages (109 upgrades, 3 new, 15 in new slots, 12 reinstalls), Size of downloads: 1,589,353 KiB
Fetch Restriction: 1 package
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtwebkit:4[abi_x86_32(-)] required by (net-im/skype-4.3.0.37-r5:0/0::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-base/kdelibs-4.14.20-r2:4/4.14::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (media-sound/amarok-2.8.0-r3:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtwebkit:4 required by (x11-libs/qtscriptgenerator-0.2.0:0/0::gentoo, installed)
    >=dev-qt/qtwebkit-4.8.5:4 required by (kde-apps/kdebase-kioslaves-15.12.3:4/15.12::gentoo, installed)

  (media-libs/phonon-gstreamer-4.9.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/phonon-gstreamer required by @selected


Ich habe bereits emerge -C "<dev-qt/qtwebkit-4.10.4:4[gstreamer]" ausgeführt, normalerweise löst das die Probleme, aber nicht diesesmal. Obowhl das Paket nicht mehr installiert ist, scheint es wieder zu kommen. Wenn ich es richtig verstehe, dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo wird von skype, kedlibs, amarok, usw. verwendet.

Ich hab meine package.mask angeschaut

Code:

>=x11-terms/gnome-terminal-3.8.4
>=app-i18n/ibus-1.4.99
media-video/libav #keep using ffmpeg


meiner Meinung nach nichts, was das Problem beeinflussen könnte.

Wie soll ich das lösen?


----

edit: ich bekomme keine Fehler mehr, wenn ich =media-libs/phonon-gstreamer-4.9.0:0/0::gento in package.mask hinzufüge. Mir gefällt diese Lösung nicht, für mich sieht es nur so aus, dass ich den Konflikt in die Zukunft schiebe und ich es irgendwann später wieder haben werde. Wie löst man denn solche Konflikte?
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Mon Aug 15, 2016 10:32 pm    Post subject: Reply with quote

pablo_supertux wrote:
Code:
[blocks B      ] <dev-qt/qtwebkit-4.10.4:4[gstreamer] ("<dev-qt/qtwebkit-4.10.4:4[gstreamer]" is blocking media-libs/phonon-gstreamer-4.9.0)

Hi,
damit ist ein wenig anders formuliert gemeint, das
phonon-gstreamer-4.9.0
bei dev-qt/qtwebkit aus Slot vier
bei einer kleineren Version als 4.10.4
mit USE=gstreamer blockiert wird.
Sprich, entweder <dev-qt/qtwebkit-4.10.4:4 mit USE=-gstreamer bauen, oder >=dev-qt/qtwebkit-4.10.4:4 nutzen.

Das gstreamer Useflag beim qtwebkit:4 (aus Slot vier) Paket, so wie vom stable media-libs/phonon-gstreamer-4.9.0 Paket gefordert passend setzen sollte helfen.
Code:
echo "<dev-qt/qtwebkit-4.10.4:4 -gstreamer" >> /etc/portage/package.use
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Tue Aug 16, 2016 12:34 am    Post subject: Reply with quote

Danke Josef.95,

Code:

echo "<dev-qt/qtwebkit-4.10.4:4 -gstreamer" >> /etc/portage/package.use

hat geholfen
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum