Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How change booting stage resolution?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1145

PostPosted: Thu Aug 18, 2016 11:50 am    Post subject: How change booting stage resolution? Reply with quote

I just installed ATI/Radeon driver according this wiki: https://wiki.gentoo.org/wiki/Fglrx
and everything working nice, however during booting stage there is low resolution.
I tried to follow grub wiki: https://wiki.gentoo.org/wiki/GRUB2#Using framebuffer display features display but no any change.
Please advise how to work it out and why in some drivers it is automatically setting and in others not?
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1369
Location: Montréal

PostPosted: Thu Aug 18, 2016 7:18 pm    Post subject: Reply with quote

The first question to ask is are you booting in Bios or EFI mode? Because the framebuffer drivers available are not the same in each mode. I haven't use Fglrx since long but, to have something else than Vga resolution, you need to use vesafb or uvesafb as primary framebuffer for Bios mode. In Efi mode, you have efifb. simple framebuffer may be available too.

You have to make a search about which frambuffer drivers works in Bios and Efi mode with Fglrx. You may not have the native resolution of the screen. I depend on the features of the framebuffer driver in use. There will be a time steep between Linux video framebuffer driver and Xorg fglrx driver when you switch from Xorg terminal to virtual terminal and reverse.

If I am right, only Linux frambuffers who support KMS like nouveau, radeon and i915 give synchronisation between Linux and Xorg nouveau, radeon and intel video drivers.

According with the first link you give, Uvesafb seem's good with Fglrx. There's a link to.
_________________
Paul
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1145

PostPosted: Fri Aug 19, 2016 11:48 am    Post subject: Reply with quote

Logicien,

Thanks for your nice explanation!
I am booting with Bios and followed the link in Fglrx's wiki that you mentioned: https://wiki.gentoo.org/wiki/Uvesafb
I have a problem with 'Initramfs inclusion' chapter: I guess that I have to have initramfs, in order to get right resolution - Right?
However if configure the kernel like this I get panic error during booting (BTW: the resolution is nice in this case):
Code:
General setup  --->
    [*] Initial RAM filesystem and RAM disk (initramfs/initrd) support
    (/usr/share/v86d/initramfs) Initramfs source file(s)

So I guess need to: 'Use dracut, genkernel, or another initramfs generator of choice to rebuild the initramfs.'
Please advise what tool to choose in order to rebuild initramfs? Just note that I am not using genkernel to build my kernel.
I added GRUB_CMDLINE_LINUX_DEFAULT="linux video=uvesafb:1240x1024-32,mtrr:3,ywrap" in /etc/default/grub according the wiki.

Quote:
If I am right, only Linux frambuffers who support KMS like nouveau, radeon and i915 give synchronisation between Linux and Xorg nouveau, radeon and intel video drivers.

When I used opensource radeon driver, I did not have resolution problem.
It just happened when I switched to propriety Fglrx... I thought it would be easier to work it out :(
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1369
Location: Montréal

PostPosted: Fri Aug 19, 2016 4:25 pm    Post subject: Reply with quote

Did you configure CONFIG_FB_UVESA=y in your kernel configuration? Note that you need to update the Grub2 configuration file after a modification? Something like
Code:
grub2-mkconfig -o /boot/grub2/grub.cfg

_________________
Paul
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1145

PostPosted: Fri Aug 19, 2016 6:41 pm    Post subject: Reply with quote

Logicien,

Yes I already done what you noted. Please advise if need to rebuild initramfs with genkernel as in wiki?
It is only thing that still have not done.

Thanks
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43195
Location: 56N 3W

PostPosted: Fri Aug 19, 2016 8:30 pm    Post subject: Reply with quote

pmam,

It all depends where your framebuffer support is.

If you added things that you want to work before root is mounted, you need to update the initrd.
If you don't mind waiting until root mounts to switch to framebuffer, your initrd may be OK.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1145

PostPosted: Sun Aug 21, 2016 7:08 am    Post subject: Reply with quote

AFAIK after reading this wiki: https://wiki.gentoo.org/wiki/Initramfs/Guide I do not need initrd or initramfs.
So in order to have right resolution during boot stage I followed https://wiki.gentoo.org/wiki/Uvesafb and all steps were done except initramfs rebuild.
However still there is low resolution in booting. I faced this issue since switched from Radeon opensource driver to Fglrx propriety driver.
Please advise how to debug in order to find out the exact missing factor?
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43195
Location: 56N 3W

PostPosted: Sun Aug 21, 2016 9:08 am    Post subject: Reply with quote

pmam,

Try vesafb in the kernel. The binary blob video drivers in general, do not play nicely with framebuffer consoles.
The nVidia driver emits dire warnings in dmesg. Its been a while since I used fglrx.
The problem is the same in both cases. The binary blobs assume that they have exclusive control of the Graphics chip.
When a framebuffer driver grabs it, or changes settings, things start to not work.

You need to choose a framebuffer driver that does not attempt to configure any hardware.
That doesn't leave many.

Post your grub.cfg, possibly on a pastebin. It may be that the resolution settings are not being passed to the kernel.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1369
Location: Montréal

PostPosted: Sun Aug 21, 2016 9:09 am    Post subject: Reply with quote

To be sure that it is Uvesafb who is the active framebuffer, disable any other framebuffer in the Linux kernel configuration including vga. Your kernel configuration can be helpfull.

After booting check the kernel boot parameters. Show us
Code:
cat /proc/cmdline

to be sure that the uvesafb parameters have been pass correctly to the kernel. Check if /dev/fb0 exist. In dmesg look for vga, vesa and uvesafb messages to know which driver in fact control the Linux display.

You can try Vesafb instead of Uvesafb. In Bios mode it work out of the box but can only give 4/3 resolutions. I ever use Uvesafb and I have been able to make it work with Fglrx I think.
_________________
Paul


Last edited by Logicien on Sun Aug 21, 2016 9:18 am; edited 2 times in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43195
Location: 56N 3W

PostPosted: Sun Aug 21, 2016 9:12 am    Post subject: Reply with quote

Logicien,

I had forgotten about /proc/cmdline. That's much easier.
Thank you.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1369
Location: Montréal

PostPosted: Sun Aug 21, 2016 9:17 am    Post subject: Reply with quote

It' nothing Neddy.
_________________
Paul
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1145

PostPosted: Sun Aug 21, 2016 10:02 am    Post subject: Reply with quote

Neddy & Logicien,

Thanks for your support! Your advise looks the right way to find out what is wrong..
Here my kernel configuration - Hope this is the right file (what name and where this file is located?) - I took it from /usr/src/linux > kwrite .config:
http://pastebin.com/Bdw9Hsd6
I disabled any other framebuffer in the Linux kernel configuration - still low resolution...

Code:
cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-4.4.6-gentoo root=/dev/sda4 ro linux video=uvesafb:1024x768-32,mtrr:3,ywrap

Looks the right parameter as I took from wiki: https://wiki.gentoo.org/wiki/Uvesafb but there is no /dev/fb0 as you noted.

I will check other data later on.

Thanks
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1369
Location: Montréal

PostPosted: Sun Aug 21, 2016 10:26 am    Post subject: Reply with quote

pmam wrote:

Code:
cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-4.4.6-gentoo root=/dev/sda4 ro linux video=uvesafb:1024x768-32,mtrr:3,ywrap



You have an invalid Linux parameter, linux . It should be
Code:
BOOT_IMAGE=/vmlinuz-4.4.6-gentoo root=/dev/sda4 ro video=uvesafb:1024x768-32,mtrr:3,ywrap


linux is a Grub command to specify the kernel image and the parameters that are passed to it. It is not a Linux parameter. Add this entry to the file /etc/grub.d/40_custom
Code:
menuentry "Gentoo personnal" {
set root=(hd0,4)
linux /vmlinuz-4.4.6-gentoo root=/dev/sda4 ro video=uvesafb:1024x768-32,mtrr:3,ywrap
initrd /path/to/the/initramfs
}

If you do not use an initramfs, remove the line "initrd /path/to/the/initramfs" otherwise, give the full path to the initramfs. Update the Grub2 configuration file with grub2-mkconfig and use this entry to boot next time.

Just a question: is the package sys-apps/v86d have been emerged and does the file /usr/share/v86d/initramfs exist?
_________________
Paul
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1145

PostPosted: Sun Aug 21, 2016 1:59 pm    Post subject: Reply with quote

Logicien,

Quote:
You have an invalid Linux parameter, linux .

I also had suspected this 'linux' parameter and try to omit but it did not help...
I too this line with 'linux' from wiki - need to correct it?

Anyway, I tried to add your entry to /etc/grub.d/40_custom (without initrd line) but when I use this entry it is not booting:
I get a message: "Press any key..." and it returns to boot menu.

Quote:
is the package sys-apps/v86d have been emerged and does the file /usr/share/v86d/initramfs exist?

Yes I installed it and there is initramfs file with this content:
Code:
dir /dev 0755 0 0
nod /dev/console 0600 0 0 c 5 1
nod /dev/tty1 0600 0 0 c 4 1
nod /dev/zero 0600 0 0 c 1 5
nod /dev/mem 0600 0 0 c 1 1
dir /root 0700 0 0
dir /sbin 0755 0 0
file /sbin/v86d /sbin/v86d 0755 0 0


Thanks
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1369
Location: Montréal

PostPosted: Sun Aug 21, 2016 2:17 pm    Post subject: Reply with quote

If you have an initramfs in your Grub entry it may conflict with /usr/share/v86d/initramfs in the kernel image. An alternative is to give /usr/share/v86d/initramfs as an initramfs in a Grub entry. Otherwise you can try Vesafb.

About the entry I suggest to you, the line set root=(hd0,4) may have to be ajust to the good partition where is /vmlinuz-4.4.6-gentoo .

I hope you will succeed.
_________________
Paul
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum