Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ERROR:dev-qt/qtchooser-0_p20151008::gentoo failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Waifod
n00b
n00b


Joined: 24 Aug 2016
Posts: 4

PostPosted: Wed Aug 24, 2016 6:44 pm    Post subject: ERROR:dev-qt/qtchooser-0_p20151008::gentoo failed Reply with quote

Hi guys!
I'm trying to install Gentoo for the first time on a vm and whenever i execute the command "emerge --ask --update --deep --newuse @world" i get this error: "ERROR:dev-qt/qtchooser-0_p20151008::gentoo failed (compile phase): emake failed".
I know that this step is optional since i'm trying with OpenRC, however that message bothers me since i'm not installing KDE or Plasma.
Any suggestions?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21779
Location: here

PostPosted: Wed Aug 24, 2016 6:55 pm    Post subject: Reply with quote

Can you post build.log, please?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Waifod
n00b
n00b


Joined: 24 Aug 2016
Posts: 4

PostPosted: Thu Aug 25, 2016 8:18 am    Post subject: Reply with quote

https://imageshack.com/i/plGOaGbrp

Here is the link to a screenshot (I hope it's fine).

EDIT: I managed to solve it myself. I should have just read more carefully the log. In the make.conf I made a little mistake while setting the CFLAGS (I wrote march=-native instead of -march=native).

Thanks a lot!

Any reason it would try to install that package? I'm not using any profile kde-related.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21779
Location: here

PostPosted: Thu Aug 25, 2016 8:38 am    Post subject: Reply with quote

Next time you can use wgetpaste for post error.
Code:
error: march=-native: No such file or directory

In make.conf you have "march=-native" in CFLAGS? if yes the correct is
Code:
CFLAGS="-march=native <other_cflags_you_have>"

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Waifod
n00b
n00b


Joined: 24 Aug 2016
Posts: 4

PostPosted: Thu Aug 25, 2016 8:59 am    Post subject: Reply with quote

Thanks, fixed the problem. What about the attempt to install that package? Is it actually necessary? I don't understand why it's installing something kde-related.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21779
Location: here

PostPosted: Thu Aug 25, 2016 9:19 am    Post subject: Reply with quote

Waifod wrote:
Thanks, fixed the problem. What about the attempt to install that package? Is it actually necessary? I don't understand why it's installing something kde-related.

Qt is not kde. Qt is a framework used also by kde. You can find which package need qtchoose using gentoolkit (probably you have istalled a program written in Qt)
Code:
# equery b qtchooser

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Waifod
n00b
n00b


Joined: 24 Aug 2016
Posts: 4

PostPosted: Thu Aug 25, 2016 10:07 am    Post subject: Reply with quote

Ok, now i see the dependencies.

Thanks again! Have a good day!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum