Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
world update problem
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
7887
n00b
n00b


Joined: 21 Jan 2014
Posts: 12

PostPosted: Sun Aug 28, 2016 4:40 pm    Post subject: world update problem Reply with quote

hallo zusammen,


ich habe nach langer Zeit wieder einmal probiert ein world update durchzufrühren.
Dies führte zu komplikationen und ich verstehe nicht wo das Problem liegt.
Falls jemand eine gute Seite kennt wie man diese Probleme selbst lösen kann, wäre ich für diese Seite dankbar.

Mir ist auch aufgefallen, dass meherere Leute das selbe Problem mit dem qtwebkit haben wie bei diesem thread z.b
Code:
https://forums.gentoo.org/viewtopic-t-1049868.html

ich habe das qtwebkit in der package.use liste eingetragen.dies hat aber leider nicht geholfen.
Sonst habe ich noch probiert die GstreamerSachen zu deinstallieren inkl phonon.
Nur leider wird das von KDE irgendwo verwendet und er will es immer wieder installieren.

danke für eure Hilfe

Gruß
7887

Code:

 emerge --ask --changed-use --deep @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] media-libs/faad2-2.7-r3  USE="-digitalradio -static-libs"
[ebuild   R    ] dev-qt/qtcore-4.8.6-r2  USE="icu*"
[ebuild  N     ] media-sound/cdparanoia-3.10.2-r6  USE="-static-libs"
[ebuild     U  ] dev-util/cmake-3.5.2-r1 [3.3.1-r1] USE="-qt4*"
[ebuild   R    ] app-crypt/qca-2.1.1  USE="qt5*"
[ebuild  N     ] media-libs/gstreamer-0.10.36-r2  USE="introspection nls orc {-test}"
[ebuild  N     ] media-libs/gstreamer-1.6.3  USE="caps introspection nls orc {-test}"
[ebuild  N     ] media-libs/gst-plugins-ugly-0.10.19-r1  USE="nls orc"
[ebuild  N     ] media-libs/gst-plugins-bad-0.10.23-r3  USE="nls orc"
[ebuild  NS    ] media-libs/gst-plugins-good-0.10.31-r1 [1.6.3] USE="nls orc"
[ebuild  N     ] media-plugins/gst-plugins-xvideo-0.10.36-r1
[ebuild  N     ] media-plugins/gst-plugins-x-0.10.36-r1
[ebuild  N     ] media-plugins/gst-plugins-ogg-0.10.36-r1
[ebuild  N     ] media-plugins/gst-plugins-vorbis-0.10.36-r1
[ebuild  N     ] media-plugins/gst-plugins-cdparanoia-0.10.36-r1
[ebuild  N     ] media-plugins/gst-plugins-faad-0.10.23-r2
[ebuild  N     ] media-plugins/gst-plugins-dts-0.10.23-r1  USE="orc"
[ebuild  N     ] media-plugins/gst-plugins-a52dec-0.10.19-r1  USE="orc"
[ebuild  N     ] media-plugins/gst-plugins-x264-0.10.19-r1
[ebuild  N     ] media-plugins/gst-plugins-xvid-0.10.23-r1
[ebuild  N     ] media-plugins/gst-plugins-dvdread-0.10.19-r1
[ebuild  N     ] media-plugins/gst-plugins-mad-0.10.19-r1
[ebuild  N     ] media-plugins/gst-plugins-flac-0.10.31-r1
[ebuild  N     ] media-plugins/gst-plugins-resindvd-0.10.23-r1
[ebuild   R    ] x11-libs/gtk+-2.24.30  USE="xinerama*"
[ebuild   R    ] dev-qt/designer-5.6.1  USE="declarative*"
[ebuild   R    ] app-text/ghostscript-gpl-9.15-r1  USE="-cups*"
[ebuild   R    ] dev-qt/qtwebkit-5.6.1  USE="qml*"
[ebuild   R    ] net-wireless/wpa_supplicant-2.5-r1  USE="qt5* -qt4*"
[ebuild   R    ] x11-misc/xscreensaver-5.34  USE="xinerama*"
[ebuild   R    ] dev-qt/qtgui-4.8.6-r4  USE="xinerama*"
[ebuild   R    ] dev-qt/qtwebkit-4.8.6-r1  USE="-gstreamer*"
[ebuild   R    ] media-libs/libsdl-1.2.15-r9  USE="xinerama*"
[ebuild  N     ] media-plugins/gst-plugins-pulse-0.10.31-r2
[ebuild  N     ] media-video/ffmpeg-2.8.6  USE="X aac alsa bzip2 encode gpl hardcoded-tables iconv mp3 network opengl postproc pulseaudio sdl threads truetype vorbis x264 xcb xvid zlib -aacplus (-altivec) -amr -amrenc (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bluray -bs2b -cdio -celt -cpudetection -debug -doc -examples -faac -fdk -flite -fontconfig -frei0r -fribidi -gme -gnutls -gsm -iec61883 -ieee1394 -jack -jpeg2k -ladspa -libass -libcaca (-libressl) -librtmp -libsoxr -libv4l -lzma (-mipsdspr1) (-mipsdspr2) (-mipsfpu) -modplug (-neon) -openal -openssl -opus -oss -pic -quvi -samba -schroedinger -snappy -speex -ssh -static-libs {-test} -theora -twolame -v4l -vaapi -vdpau -vpx -wavpack -webp -x265 -zvbi" CPU_FLAGS_X86="mmx mmxext sse sse2 -3dnow -3dnowext -avx -avx2 -fma3 -fma4 -sse3 -sse4_1 -sse4_2 -ssse3 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher"
[ebuild   R    ] media-video/vlc-2.2.4  USE="qt5* -qt4*"
[ebuild  N     ] media-plugins/gst-plugins-mpeg2dec-0.10.19-r1
[ebuild  N     ] virtual/ffmpeg-9-r2  USE="X encode mp3 sdl truetype x264 -gsm -jpeg2k -libav -opus -speex -theora -threads -vaapi -vdpau"
[ebuild  N     ] media-plugins/gst-plugins-meta-0.10-r10  USE="X a52 aac alsa cdda dts dvd flac mp3 mpeg ogg pulseaudio vorbis x264 xv xvid -dv -dvb -ffmpeg -http -jack -lame -libass -libvisual -mms -modplug -musepack -opus -oss -taglib -theora -v4l -vcd -vpx -wavpack"
[ebuild  N     ] dev-qt/qtphonon-4.8.6-r1  USE="dbus exceptions qt3support (-aqua) -debug -pch"
[ebuild   R    ] dev-qt/designer-4.8.6-r1  USE="declarative* phonon*"
[ebuild  N     ] media-libs/phonon-4.9.0  USE="designer pulseaudio qt4 qt5 vlc (-aqua) -debug -gstreamer (-zeitgeist)"
[ebuild     U *] www-client/google-chrome-52.0.2743.116 [45.0.2454.85_p1] L10N="am%* ar%* bg%* bn%* ca%* cs%* da%* de%* el%* en-GB%* es%* es-419%* et%* fa%* fi%* fil%* fr%* gu%* he%* hi%* hr%* hu%* id%* it%* ja%* kn%* ko%* lt%* lv%* ml%* mr%* ms%* nb%* nl%* pl%* pt-BR%* pt-PT%* ro%* ru%* sk%* sl%* sr%* sv%* sw%* ta%* te%* th%* tr%* uk%* vi%* zh-CN%* zh-TW%*"
[ebuild   R    ] kde-frameworks/knotifyconfig-5.23.0  USE="phonon*"
[ebuild   R    ] kde-apps/kio-extras-16.04.3  USE="phonon*"
[blocks B      ] dev-qt/qtphonon ("dev-qt/qtphonon" is blocking kde-base/kdelibs-4.14.20-r2)
[blocks B      ] media-libs/phonon ("media-libs/phonon" is blocking dev-qt/qtphonon-4.8.6-r1)
[blocks B      ] dev-qt/qtphonon:4 ("dev-qt/qtphonon:4" is hard blocking media-libs/phonon-4.9.0)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-qt/qtphonon-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtphonon-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (~dev-qt/qtphonon-4.8.6[-aqua,-debug,abi_x86_32(-)]) required by (dev-qt/designer-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)

  (media-libs/phonon-4.9.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/phonon[qt5] required by (kde-frameworks/khtml-5.23.0:5/5.23::gentoo, installed)
    >=media-libs/phonon-4.9.0[qt4=,qt5=] (>=media-libs/phonon-4.9.0[qt4,qt5]) required by (media-libs/phonon-vlc-0.9.0:0/0::gentoo, installed)
    media-libs/phonon[qt5] required by (kde-plasma/plasma-desktop-5.6.5:5/5::gentoo, installed)
    media-libs/phonon[qt5] required by (kde-apps/kio-extras-16.04.3:5/5::gentoo, ebuild scheduled for merge)
    media-libs/phonon[qt5] required by (kde-frameworks/knotifyconfig-5.23.0:5/5.23::gentoo, ebuild scheduled for merge)
    media-libs/phonon[qt5] required by (kde-plasma/plasma-workspace-5.6.5.1-r2:5/5::gentoo, installed)
    media-libs/phonon[qt5] required by (kde-frameworks/knotifications-5.23.0:5/5.23::gentoo, installed)
    media-libs/phonon[qt4] required by (kde-base/kdelibs-4.14.20-r2:4/4.14::gentoo, installed)

  (kde-base/kdelibs-4.14.20-r2:4/4.14::gentoo, installed) pulled in by
    <kde-base/kdelibs-4.14.22 required by (kde-base/katepart-4.14.3:4/4.14::gentoo, installed)
    <kde-base/kdelibs-4.14.22 required by (kde-base/qguiplatformplugin_kde-4.11.22:4/4.11::gentoo, installed)
    kde-base/kdelibs:4 required by (kde-plasma/breeze-5.6.5-r1:5/5::gentoo, installed)
    >=kde-base/kdelibs-4.14.3:4[aqua=,handbook] (>=kde-base/kdelibs-4.14.3:4[-aqua,handbook]) required by (kde-base/katepart-4.14.3:4/4.14::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Sun Aug 28, 2016 6:20 pm    Post subject: Reply with quote

Hi,
das Problem ist wahrscheinlich das dev-qt/qtphonon mit installiert werden soll (welches vom beim dev-qt/designer-4.8.6-r1:4 Paket gesetzten phonon Useflag mit reingezogen wird).

Vorschlag: Nimm das phonon Useflag (sofern global gesetzt) aus der make.conf raus,
oder stelle zumindest sicher dass das phonon Useflag nicht für dev-qt/designer-4.8.6-r1:4 gesetzt ist.
Damit sollte es dann keine Blocker mehr geben.

[ebuild R ] dev-qt/designer-4.8.6-r1 USE="declarative* phonon*"
Back to top
View user's profile Send private message
7887
n00b
n00b


Joined: 21 Jan 2014
Posts: 12

PostPosted: Sun Aug 28, 2016 7:33 pm    Post subject: Reply with quote

Hallo,

das ist meine make.conf
Code:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j8"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="i686-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="dbus X aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3 \
     cpu_flags_x86_mmx cpu_flags_x86_mmxext cpu_flags_x86_sse2 \
     cpu_flags_x86_sse abi_x86_32 bluetooth hal PPP ncurses sl gtk \
     -cups -kde pulseaudio -gnome -systemd alsa"
INPUT_DEVICES="evdev synaptics"
VIDEO_CARDS="intel vesa fbdev"
LINGUAS="en"


Leider bin ich was diese ganzen USE falgs angeht nicht wirklich fit und ich weiss leider nicht wie ich einem bestimmten Programm sagen kann, dass es nur ein bestimmtes use-falg benutzen soll.

kannst du mir biite nocheinmal helfen.

Vielen dank
7887
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Sun Aug 28, 2016 8:02 pm    Post subject: Reply with quote

Hm, ich würde zunächst versuchen herauszufinden wo das phonon Useflag gesetzt ist.
Da du es in deiner make.conf nicht mit drin hast bleibt fast nur noch das es global vom Profil her gesetzt wird, oder es mit in der /etc/portage/package.use gesetzt ist.

Magst du mal bitte die Ausgaben von
Code:
emerge --info
und
grep -r phonon /etc/portage/package.use
posten?
Back to top
View user's profile Send private message
7887
n00b
n00b


Joined: 21 Jan 2014
Posts: 12

PostPosted: Sun Aug 28, 2016 8:07 pm    Post subject: Reply with quote

emerge -info

Code:

emerge --info
Portage 2.2.28 (python 2.7.10-final-0, default/linux/x86/13.0/desktop/plasma, gcc-4.9.3, glibc-2.22-r4, 4.4.6-gentoo i686)
=================================================================
System uname: Linux-4.4.6-gentoo-i686-Intel-R-_Core-TM-_i7-2640M_CPU_@_2.80GHz-with-gentoo-2.2
KiB Mem:     8166716 total,   6194764 free
KiB Swap:    3906556 total,   3906556 free
Timestamp of repository gentoo: Fri, 26 Aug 2016 08:15:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r1::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync15.de.gentoo.org/gentoo-portage/
    priority: -1000

ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="PPP X a52 aac acl acpi aes alsa avx berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gpm gtk hal iconv ipv6 jpeg kipi lcms ldap libnotify mad mmx mmxext mng modules mp3 mp4 mpeg ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit popcnt ppds pulseaudio qml qt3support qt4 qt5 readline sdl seccomp semantic-desktop session sl spell sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis widgets wxwidgets x264 x86 xattr xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


grep -r phonon /etc/portage/package.use

das wird nichts gefunden

gruß
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Sun Aug 28, 2016 8:38 pm    Post subject: Reply with quote

Ah ja, ich denke nun hab ich den Zusammenhang verstanden :)

Du nutzt das default/linux/x86/13.0/desktop/plasma Profil
aus diesem werden global USE="kde phonon" gesetzt,
nun hast du aber in deiner make.conf mit USE=-kde global das kde Useflag auf -kde gesetzt,
und damit fällt dann dev-qt/designer auf die Nase... :)

Die Abhängigkeiten im designer-4.8.6-r1.ebuild schauen so aus
designer-4.8.6-r1.ebuild:
phonon? ( !kde? ( ~dev-qt/qtphonon-${PV}[aqua=,debug=,${MULTILIB_USEDEP}] ) )
Das heißt etwa, mit USE=phonon aber mit USE=-kde
dann installiere als Dep dev-qt/qtphonon was sich aber hart mit media-libs/phonon blockt, daher auch der Blocker
[blocks B ] dev-qt/qtphonon:4 ("dev-qt/qtphonon:4" is hard blocking media-libs/phonon-4.9.0)

Lösungsvorschlag:
1) Nimm das USE-kde aus deiner make.conf
oder
2) setze für das Paket dev-qt/designer
in der /etc/portage/package.use
dev-qt/designer -phonon
oder
dev-qt/designer kde

Damit sollte es dann nicht mehr zu den Blockern kommen.
Back to top
View user's profile Send private message
7887
n00b
n00b


Joined: 21 Jan 2014
Posts: 12

PostPosted: Sun Aug 28, 2016 9:08 pm    Post subject: Reply with quote

Hallo Josef.95,


vielen dank für deine Hilfe.
Ich habe deine Lösung verstanden und mir sind ein paar fehler aufgefallen, die da reingekommen sind als ich probiert habe das Problem zu lösen.

ich wollte kde komplett wegwerfen und nochmal neu installieren und hatte deswegen einiges umgestellt damit das auch "passiert".

Wenn ich noch einen Frage stellen darf

Ich hatte auf dem rechner noch eine alte version von Google-chrome.
Beim update sagte er jetzt was, dass es die falsche architecktur wäre.
kannst du mir da evtl ein letztes mnal weiterhelfen?
nach diesem Fehler werde ich mich probieren wieder selbst durchschlagen.

Code:

 env-update
>>> Regenerating /etc/ld.so.cache...
 # emerge --ask --changed-use --deep @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-qt/qtcore-4.8.6-r2  USE="icu*"
[ebuild     U  ] dev-util/cmake-3.5.2-r1 [3.3.1-r1] USE="-qt4*"
[ebuild   R    ] app-crypt/qca-2.1.1  USE="qt5*"
[ebuild  N     ] media-libs/gstreamer-0.10.36-r2  USE="introspection nls orc {-test}"
[ebuild  N     ] media-libs/gstreamer-1.6.3  USE="caps introspection nls orc {-test}"
[ebuild   R    ] x11-libs/gtk+-2.24.30  USE="xinerama*"
[ebuild   R    ] dev-qt/designer-5.6.1  USE="declarative*"
[ebuild   R    ] app-text/ghostscript-gpl-9.15-r1  USE="-cups*"
[ebuild   R    ] dev-qt/qtwebkit-5.6.1  USE="qml*"
[ebuild   R    ] net-libs/libproxy-0.4.13-r1  USE="kde*"
[ebuild   R    ] net-wireless/wpa_supplicant-2.5-r1  USE="qt5* -qt4*"
[ebuild   R    ] x11-misc/xscreensaver-5.34  USE="xinerama*"
[ebuild   R    ] dev-qt/qtgui-4.8.6-r4  USE="xinerama*"
[ebuild   R    ] dev-qt/qtwebkit-4.8.6-r1  USE="-gstreamer*"
[ebuild   R    ] dev-qt/designer-4.8.6-r1  USE="declarative* kde*"
[ebuild   R    ] media-libs/libsdl-1.2.15-r9  USE="xinerama*"
[ebuild  N     ] media-video/ffmpeg-2.8.6  USE="X aac alsa bzip2 encode gpl hardcoded-tables iconv mp3 network opengl postproc pulseaudio sdl threads truetype vorbis x264 xcb xvid zlib -aacplus (-altivec) -amr -amrenc (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bluray -bs2b -cdio -celt -cpudetection -debug -doc -examples -faac -fdk -flite -fontconfig -frei0r -fribidi -gme -gnutls -gsm -iec61883 -ieee1394 -jack -jpeg2k -ladspa -libass -libcaca (-libressl) -librtmp -libsoxr -libv4l -lzma (-mipsdspr1) (-mipsdspr2) (-mipsfpu) -modplug (-neon) -openal -openssl -opus -oss -pic -quvi -samba -schroedinger -snappy -speex -ssh -static-libs {-test} -theora -twolame -v4l -vaapi -vdpau -vpx -wavpack -webp -x265 -zvbi" CPU_FLAGS_X86="mmx mmxext sse sse2 -3dnow -3dnowext -avx -avx2 -fma3 -fma4 -sse3 -sse4_1 -sse4_2 -ssse3 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher"
[ebuild  N     ] virtual/ffmpeg-9-r2  USE="X encode mp3 sdl truetype x264 -gsm -jpeg2k -libav -opus -speex -theora -threads -vaapi -vdpau"
[ebuild  N     ] media-libs/phonon-4.9.0  USE="designer pulseaudio qt4 qt5 vlc (-aqua) -debug -gstreamer (-zeitgeist)"
[ebuild   R    ] sys-auth/polkit-0.113  USE="kde*"
[ebuild   R    ] sys-block/gparted-0.26.0  USE="kde*"
[ebuild     U *] www-client/google-chrome-52.0.2743.116 [45.0.2454.85_p1] L10N="am%* ar%* bg%* bn%* ca%* cs%* da%* de%* el%* en-GB%* es%* es-419%* et%* fa%* fi%* fil%* fr%* gu%* he%* hi%* hr%* hu%* id%* it%* ja%* kn%* ko%* lt%* lv%* ml%* mr%* ms%* nb%* nl%* pl%* pt-BR%* pt-PT%* ro%* ru%* sk%* sl%* sr%* sv%* sw%* ta%* te%* th%* tr%* uk%* vi%* zh-CN%* zh-TW%*"
[ebuild   R    ] kde-frameworks/knotifyconfig-5.23.0  USE="phonon*"
[ebuild   R    ] kde-apps/kio-extras-16.04.3  USE="phonon*"
[ebuild   R    ] media-video/vlc-2.2.4  USE="kde* qt5* -qt4*"
[ebuild   R    ] app-arch/p7zip-9.20.1-r5  USE="kde*"

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

app-crypt/pinentry:0

  (app-crypt/pinentry-0.9.5:0/0::gentoo, ebuild scheduled for merge) conflicts with
    app-crypt/pinentry[gnome-keyring] required by (gnome-base/gnome-keyring-3.18.3-r1:0/0::gentoo, installed)
                       ^^^^^^^^^^^^^


Would you like to merge these packages? [Yes/No] yes

>>> Verifying ebuild manifests
>>> Running pre-merge checks for www-client/google-chrome-52.0.2743.116
 * ERROR: www-client/google-chrome-52.0.2743.116::gentoo failed (pretend phase):
 *   google-chrome only works on amd64
 *
 * Call stack:
 *                            ebuild.sh, line 133:  Called pkg_pretend
 *   google-chrome-52.0.2743.116.ebuild, line 102:  Called die
 * The specific snippet of code:
 *      use amd64 || die "google-chrome only works on amd64"
 *
 * If you need support, post the output of `emerge --info '=www-client/google-chrome-52.0.2743.116::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=www-client/google-chrome-52.0.2743.116::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/www-client/google-chrome-52.0.2743.116/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/www-client/google-chrome-52.0.2743.116/temp/die.env'.
 * Working directory: '/usr/lib/python2.7/site-packages'
 * S: '/var/tmp/portage/www-client/google-chrome-52.0.2743.116/work'

 * Messages for package www-client/google-chrome-52.0.2743.116:

 * ERROR: www-client/google-chrome-52.0.2743.116::gentoo failed (pretend phase):
 *   google-chrome only works on amd64
 *
 * Call stack:
 *                            ebuild.sh, line 133:  Called pkg_pretend
 *   google-chrome-52.0.2743.116.ebuild, line 102:  Called die
 * The specific snippet of code:
 *      use amd64 || die "google-chrome only works on amd64"
 *
 * If you need support, post the output of `emerge --info '=www-client/google-chrome-52.0.2743.116::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=www-client/google-chrome-52.0.2743.116::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/www-client/google-chrome-52.0.2743.116/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/www-client/google-chrome-52.0.2743.116/temp/die.env'.
 * Working directory: '/usr/lib/python2.7/site-packages'
 * S: '/var/tmp/portage/www-client/google-chrome-52.0.2743.116/work'
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Sun Aug 28, 2016 9:32 pm    Post subject: Reply with quote

Hehe, ok :)

Bezüglich dem Fehler bei google-chrome:
* ERROR: www-client/google-chrome-52.0.2743.116::gentoo failed (pretend phase):
* google-chrome only works on amd64

Der chrome (binary)-Browser wird von Upstream auf x86 32 Bit Systemen nicht mehr unterstützt. Schau dazu zb auch im https://groups.google.com/a/chromium.org/forum/#!topic/chromium-dev/FoE6sL-p6oU
Für dein x86 (i686) System solltest du nun besser einen anderen Browser nutzen.
Deinstalliere die alte noch installierte Version am besten mit einem beherzten
Code:
emerge -av --depclean www-client/google-chrome


Last edited by Josef.95 on Sun Aug 28, 2016 9:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
7887
n00b
n00b


Joined: 21 Jan 2014
Posts: 12

PostPosted: Sun Aug 28, 2016 9:37 pm    Post subject: Reply with quote

ok
danke , dann weiss ich bescheid
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum