Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
fresh Gentoo installation - systemd will not start
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
cyber_sapien
n00b
n00b


Joined: 31 May 2015
Posts: 23

PostPosted: Wed Sep 07, 2016 7:25 pm    Post subject: fresh Gentoo installation - systemd will not start Reply with quote

Hi,
I installed Gentoo from scratch. I made the inKernel CMD root=/dev/sda6 ro init=/usr/lib/systemd/systemd quiet
The system ignores this and boot up with init. I read all handbooks, tutorials and FAQ but no solution in sight.
Can anybody please help.

emerge --info
Code:

Portage 2.2.28 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-4.9.3, glibc-2.22-r4, 4.4.6-gentoo x86_64)
=================================================================
System uname: Linux-4.4.6-gentoo-x86_64-Intel-R-_Core-TM-_i5-3570K_CPU_@_3.40GHz-with-gentoo-2.2
KiB Swap:    4194300 total,   4194300 free
Timestamp of repository gentoo: Wed, 07 Sep 2016 12:15:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/cmake:           3.5.2-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.21.3::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.12.6::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.at.gentoo.org/gentoo-portage
    priority: -1000

proaudio
    location: /var/lib/layman/proaudio
    sync-type: svn
    sync-uri: svn://svn.tuxfamily.org/svnroot/proaudio/proaudio/trunk/overlays/proaudio
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.lagis.at/"
LANG="de_AT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="3dnow 3dnowext X a52 aac acl acpi aes alsa amd64 avx berkdb bluray branding bzip2 cairo cdda cdr cleartype cli clutter colord corefonts cracklib crypt cups cxx dbus dri dssi dts dvd dvdr eds emboss encode evo exif fam fbcon ffmpeg firefox flac fortran freetype gdbm gif gimp git glamor gnome gnome-keyring gnome-online-accounts gphoto2 gpm gstreamer gtk iconv icu ieee1394 introspection ipv6 jack java jpeg lcms ldap libnotify libsecret lm_sensors mad matroska midi mmx mmxext mng modules mp3 mp4 mpeg mpg123 multilib nautilus ncurses nls nptl nsplugin ogg oggvorbis opengl openmp pam pango pcre pdf png policykit popcnt ppds pulseaudio qt3support readline sdl seccomp session sna source spell sse sse2 ssl startup-notification subversion svg symlink systemd tcpd theora threads tiff tracker truetype type1 udev udisks unicode upower usb vcd vim-syntax vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 ssse3 sse4_1 sse4_2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev" KERNEL="linux" L10N="de" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
GFCCAE6xF
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 266

PostPosted: Wed Sep 07, 2016 8:47 pm    Post subject: Reply with quote

Perhaps your use-case requires `real_init=` instead of `init=`
Back to top
View user's profile Send private message
cyber_sapien
n00b
n00b


Joined: 31 May 2015
Posts: 23

PostPosted: Thu Sep 08, 2016 7:44 am    Post subject: Reply with quote

thank you for the answer. I tried it with "real_init" and it makes no difference.
Back to top
View user's profile Send private message
guitou
Guru
Guru


Joined: 02 Oct 2003
Posts: 400
Location: France

PostPosted: Thu Sep 08, 2016 8:19 am    Post subject: Reply with quote

Hello.

Falling back to init means kernel fails to find /usr/lib/systemd/systemd.
Supposing you already ensured systemd is installed, maybe this is caused by your partition setup: a separate /usr for example. Then you need to set up an initrd too, in order to mount /usr, otherwise the proper init command cannot be found (and subsequently run).

++
Gi)
Back to top
View user's profile Send private message
cyber_sapien
n00b
n00b


Joined: 31 May 2015
Posts: 23

PostPosted: Thu Sep 08, 2016 9:05 am    Post subject: Reply with quote

thank you for the hint but I do not have extra partitions, it is all on root.
cat fstab
Code:

# <fs>         <mountpoint>      type>      <opts>                                                           <dump/pass>

/dev/sda4          none         swap              sw                                                               0 0
/dev/sda6           /              ext4              defaults,relatime                                                 0 1
/dev/cdrom      /mnt/cdrom      auto              noauto,ro                                                            0 0
tmpfs         /var/tmp/portage   tmpfs      size=12G,uid=portage,gid=portage,mode=775,noatime      0 0
Back to top
View user's profile Send private message
guitou
Guru
Guru


Joined: 02 Oct 2003
Posts: 400
Location: France

PostPosted: Thu Sep 08, 2016 9:31 am    Post subject: Reply with quote

Ok.
Then what may you have missed?..
-maybe simply a missing kernel option: CONFIG_GENTOO_LINUX_INIT_SYSTEMD=y
-maybe you forgot to update bootloader after changes (lilo/grub-mkconfig...)
Were I in your shoes, I would just re-run the relevant install steps.

++
Gi)
Back to top
View user's profile Send private message
cyber_sapien
n00b
n00b


Joined: 31 May 2015
Posts: 23

PostPosted: Thu Sep 08, 2016 9:45 am    Post subject: Reply with quote

Thank you guitou,
CONFIG_GENTOO_LINUX_INIT_SYSTEMD=y and CONFIG_CMDLINE_OVERRIDE=y is set.
I do not use GRUB or LILO as I have a doubleboot with Windows7 I use rEFInd.
I made everything twice.
Any other idea?
Back to top
View user's profile Send private message
cyber_sapien
n00b
n00b


Joined: 31 May 2015
Posts: 23

PostPosted: Thu Sep 08, 2016 10:44 am    Post subject: Reply with quote

I re-sorted the entries in my fstab and this made the trick.
Now the system starts with systemd.
Problem is solved - Thank you.
Back to top
View user's profile Send private message
guitou
Guru
Guru


Joined: 02 Oct 2003
Posts: 400
Location: France

PostPosted: Thu Sep 08, 2016 3:53 pm    Post subject: Reply with quote

Glad to know you sorted this out, congrats :)

++
Gi)
Back to top
View user's profile Send private message
fturco
l33t
l33t


Joined: 08 Dec 2010
Posts: 629
Location: Italy

PostPosted: Fri Sep 09, 2016 12:17 pm    Post subject: Reply with quote

@cyber_sapien: I'm glad you solved your problem, but now please add the [solved] tag to the thread title. Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum