Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
OpenSSL bindist conflict; emerge app-editors/atom::sabayon
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
usuha
n00b
n00b


Joined: 28 May 2016
Posts: 26
Location: Tokyo, Japan

PostPosted: Sun Sep 11, 2016 12:02 am    Post subject: OpenSSL bindist conflict; emerge app-editors/atom::sabayon Reply with quote

Hello.
Code:
pure@gentoo_green ~ $ sudo emerge -av app-editors/atom
--- Invalid atom in /var/lib/layman/gentoo/profiles/package.mask: >=dev-libs/openssl-1.1*

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] media-libs/libogg-1.3.1::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 398 KiB
[ebuild  N     ] net-libs/http-parser-2.6.2:0/2.6.2::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 48 KiB
[ebuild  N     ] dev-libs/re2-0_p20140304:0/0.20140110::gentoo  ABI_X86="(64) -32 (-x32)" 1,026 KiB
[ebuild  N     ] media-sound/gsm-1.0.13-r1::gentoo  ABI_X86="(64) -32 (-x32)" 64 KiB
[ebuild  N     ] media-libs/vo-aacenc-0.1.3::gentoo  USE="-examples (-neon) -static-libs" ABI_X86="(64) -32 (-x32)" 599 KiB
[ebuild  N     ] media-libs/giflib-4.1.6-r3::gentoo  USE="X -rle -static-libs" ABI_X86="(64) -32 (-x32)" 495 KiB
[ebuild  N     ] sys-libs/libcap-2.24-r2::gentoo  USE="pam -static-libs" ABI_X86="(64) -32 (-x32)" 62 KiB
[ebuild  N     ] dev-util/ctags-5.8::gentoo  USE="-ada" 469 KiB
[ebuild  N     ] dev-perl/JSON-2.900.0::gentoo  USE="{-test}" 84 KiB
[ebuild  N     ] dev-libs/dotconf-1.3::gentoo  326 KiB
[ebuild   R    ] sys-libs/zlib-1.2.8-r1::gentoo  USE="minizip* -static-libs" ABI_X86="(64) -32 (-x32)" 558 KiB
[ebuild  N     ] dev-libs/oniguruma-5.9.5::gentoo  USE="-combination-explosion-check -crnl-as-line-terminator -static-libs" ABI_X86="(64) -32 (-x32)" 575 KiB
[ebuild  N     ] sys-libs/libcap-ng-0.7.7::gentoo  USE="-python -static-libs" PYTHON_TARGETS="python2_7 python3_4 -python3_3" 411 KiB
[ebuild  N     ] media-libs/libmad-0.15.1b-r8::gentoo  USE="-debug -static-libs" ABI_X86="(64) -32 (-x32)" 491 KiB
[ebuild  N     ] media-libs/opus-1.1::gentoo  USE="-custom-modes -doc -static-libs" ABI_X86="(64) -32 (-x32)" 831 KiB
[ebuild   R    ] dev-libs/openssl-1.0.2h-r2::gentoo  USE="asm sslv3 tls-heartbeat zlib -bindist* -gmp -kerberos -rfc3779 -sctp -sslv2 -static-libs {-test} -vanilla" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(sse2)" 5,151 KiB
[ebuild  N     ] net-libs/libssh2-1.7.0::gentoo  USE="zlib -gcrypt (-libressl) -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 793 KiB
[ebuild  N     ] dev-python/beautifulsoup-4.3.2:4::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3" 140 KiB
[ebuild  N     ] dev-python/beautifulsoup-3.2.1-r1:python-2::gentoo  PYTHON_TARGETS="python2_7 (-pypy)" 31 KiB
[ebuild  N     ] dev-python/pyxdg-0.25-r1::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) -python3_3 (-python3_5)" 48 KiB
[ebuild  N     ] dev-python/six-1.10.0::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)" 29 KiB
[ebuild  N     ] dev-lang/yasm-1.2.0-r1::gentoo  USE="nls -python" PYTHON_TARGETS="python2_7" 1,413 KiB
[ebuild  N     ] dev-python/simplejson-3.8.1::gentoo  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)" 75 KiB
[ebuild  N     ] dev-python/html5lib-0.9999999::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)" 869 KiB
[ebuild  N     ] dev-python/jsmin-2.1.1::gentoo  PYTHON_TARGETS="python2_7 python3_4 (-pypy) -python3_3" 10 KiB
[ebuild  N     ] dev-python/ply-3.6-r1::gentoo  USE="-examples" PYTHON_TARGETS="python2_7 python3_4 (-pypy) -python3_3" 276 KiB
[ebuild  N     ] dev-libs/elfutils-0.166::gentoo  USE="bzip2 nls utils -lzma -static-libs {-test} (-threads)" ABI_X86="(64) -32 (-x32)" 6,344 KiB
[ebuild  N     ] dev-python/markupsafe-0.23::gentoo  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)" 14 KiB
[ebuild  N     ] dev-python/jinja-2.8::gentoo  USE="-doc -examples" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)" 349 KiB
[ebuild  N     ] media-libs/xvid-1.3.3::gentoo  USE="threads -examples -pic" ABI_X86="(64) -32 (-x32)" 679 KiB
[ebuild  N     ] media-libs/x264-0.0.20140308:0/142::gentoo  USE="interlaced threads -10bit -opencl -pic -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse" 611 KiB
[ebuild  N     ] media-libs/libvpx-1.5.0:0/3::gentoo  USE="postproc threads -doc -static-libs -svc {-test}" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmx sse sse2 -avx -avx2 -sse3 -sse4_1 -ssse3" 1,862 KiB
[ebuild  N     ] media-libs/flac-1.3.1-r1::gentoo  USE="cxx ogg (-altivec) -debug -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse" 920 KiB
[ebuild  N     ] media-libs/libvorbis-1.3.4::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 1,066 KiB
[ebuild  N    ~] dev-libs/libuv-1.9.1-r1:0/1::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 1,036 KiB
[ebuild  N     ] media-sound/lame-3.99.5-r1::gentoo  USE="frontend -debug -mp3rtp -sndfile -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(-mmx)" 1,412 KiB
[ebuild  N     ] media-libs/speex-1.2_rc1-r2::gentoo  USE="ogg -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse" 1,037 KiB
[ebuild  N     ] media-libs/libexif-0.6.21-r1::gentoo  USE="nls -doc -static-libs" ABI_X86="(64) -32 (-x32)" 1,337 KiB
[ebuild  N     ] dev-libs/nss-3.23::gentoo  USE="cacert nss-pem -utils" ABI_X86="(64) -32 (-x32)" 7,321 KiB
[ebuild  N     ] dev-libs/libgit2-0.23.4:0/23::gentoo  USE="ssh -examples -gssapi (-libressl) {-test} -threads -trace" 3,971 KiB
[ebuild  N    ~] net-libs/nodejs-6.4.0::gentoo  USE="npm snapshot ssl -debug -doc -icu {-test}" CPU_FLAGS_X86="sse2" PYTHON_TARGETS="python2_7" 15,037 KiB
[ebuild  N     ] dev-libs/jsoncpp-0.10.2-r1::gentoo  USE="-doc {-test}" 193 KiB
[ebuild  N     ] media-libs/libsndfile-1.0.26::gentoo  USE="alsa -minimal -sqlite -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 1,056 KiB
[ebuild  N     ] media-sound/sox-14.4.2::gentoo  USE="alsa encode flac mad ogg openmp png -amr -ao -debug -id3tag -ladspa -opus -oss -pulseaudio -sndfile -static-libs -twolame -wavpack" 1,108 KiB
[ebuild  N     ] media-libs/audiofile-0.3.6-r1:0/1::gentoo  USE="flac -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 519 KiB
[ebuild  N     ] app-accessibility/espeak-1.47.11-r1::gentoo  USE="-portaudio -pulseaudio" 2,748 KiB
[ebuild  N     ] app-accessibility/speech-dispatcher-0.8.1::gentoo  USE="alsa espeak -ao -flite -nas -pulseaudio -python -static-libs" PYTHON_TARGETS="python3_4 -python3_3 (-python3_5)" 1,280 KiB
[ebuild  N     ] media-libs/glu-9.0.0-r1::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 482 KiB
[ebuild  N     ] virtual/glu-9.0-r1::gentoo  ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] media-libs/libsdl-1.2.15-r9::gentoo  USE="X alsa joystick opengl sound video xv -aalib -custom-cflags -dga -fbcon -libcaca -nas -oss -pulseaudio -static-libs -tslib -xinerama" ABI_X86="(64) -32 (-x32)" 3,829 KiB
[ebuild  N     ] media-libs/freeglut-3.0.0::gentoo  USE="-debug -static-libs" ABI_X86="(64) -32 (-x32)" 410 KiB
[ebuild  N     ] media-libs/libwebp-0.4.0:0/5::gentoo  USE="gif jpeg opengl png tiff -experimental -static-libs -swap-16bit-csp" ABI_X86="(64) -32 (-x32)" 868 KiB
[ebuild  N     ] media-video/ffmpeg-2.8.6:0/54.56.56::gentoo  USE="X aac alsa bzip2 encode gpl hardcoded-tables iconv mp3 network opengl opus postproc sdl threads truetype vorbis vpx x264 xcb xvid zlib -aacplus (-altivec) -amr -amrenc (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bluray -bs2b -cdio -celt -cpudetection -debug -doc -examples -faac -fdk -flite -fontconfig -frei0r -fribidi -gme -gnutls -gsm -iec61883 -ieee1394 -jack -jpeg2k -ladspa -libass -libcaca (-libressl) -librtmp -libsoxr -libv4l -lzma (-mipsdspr1) (-mipsdspr2) (-mipsfpu) -modplug (-neon) -openal -openssl -oss -pic -pulseaudio -quvi -samba -schroedinger -snappy -speex -ssh -static-libs {-test} -theora -twolame -v4l -vaapi -vdpau -wavpack -webp -x265 -zvbi" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmx mmxext sse sse2 -3dnow -3dnowext -avx -avx2 -fma3 -fma4 -sse3 -sse4_1 -sse4_2 -ssse3 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher" 8,382 KiB
[ebuild  N     ] app-crypt/libsecret-0.18.5::gentoo  USE="crypt introspection -debug {-test} -vala" 497 KiB
[ebuild  N     ] gnome-base/gnome-keyring-3.18.3-r1::gentoo  USE="caps filecaps pam ssh-agent -debug (-selinux) {-test}" 1,177 KiB
[ebuild   R    ] app-crypt/pinentry-0.9.5::gentoo  USE="gnome-keyring* gtk ncurses qt4 -caps -clipboard -emacs -static" 503 KiB
[ebuild  N     ] gnome-base/libgnome-keyring-3.12.0::gentoo  USE="introspection -debug {-test} -vala" 425 KiB
[ebuild  N    ~] dev-util/electron-0.36.12-r3:0/36::gentoo  USE="cups gnome-keyring proprietary-codecs system-ffmpeg tcmalloc -custom-cflags -gnome -hidpi -kerberos -lto (-neon) -pic -pulseaudio (-selinux) {-test}" LINGUAS="ja -am -ar -bg -bn -ca -cs -da -de -el -en_GB -es -es_419 -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -it -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh_CN -zh_TW" 425,581 KiB
[ebuild  N    ~] app-editors/atom-1.8.0::sabayon-tools  76,998 KiB

Total: 59 packages (56 new, 3 reinstalls), Size of downloads: 584,298 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2h-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.2g:0=[-bindist] required by (dev-util/electron-0.36.12-r3:0/36::gentoo, ebuild scheduled for merge)
                                                                                                                                                         
    >=dev-libs/openssl-1.0.2g:0=[-bindist] required by (net-libs/nodejs-6.4.0:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                               

  (dev-libs/openssl-1.0.2h-r2:0/0::gentoo, installed) pulled in by
    >=dev-libs/openssl-0.9.8f:0[bindist=] required by (net-misc/openssh-7.2_p2-r1:0/0::gentoo, installed)
                                                                                                                                 
    dev-libs/openssl:0[bindist=] required by (dev-qt/qtnetwork-5.6.1:5/5.6::gentoo, installed)
                                                                                                                       


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

Please give me advice.

[Moderator edit: Changed title to try to attract relevant answers. Original title was emerge app-editors/atom. -Hu]
Back to top
View user's profile Send private message
jburns
Veteran
Veteran


Joined: 18 Jan 2007
Posts: 1039
Location: Massachusetts USA

PostPosted: Sun Sep 11, 2016 5:55 am    Post subject: Reply with quote

dev-util/electron and net-libs/nodejs require dev-libs/openssl built with the bindist USE flag disabled. You have net-misc/openssh and dev-qt/qtnetwork built with the bindist USE flag enabled which requires dev-libs/openssl built with the bindist USE flag enabled. To find what is pulling in dev-util/electron and net-libs/nodejs use the --tree option with your emerge command.
Back to top
View user's profile Send private message
usuha
n00b
n00b


Joined: 28 May 2016
Posts: 26
Location: Tokyo, Japan

PostPosted: Sun Sep 11, 2016 8:26 am    Post subject: Reply with quote

Thanks a lot jburns.

Hello.
Thank you for the advice.
However, "in this time of issue high degree of difficulty, solve it is difficult to" and I thought.
Code:
user $ sudo emerge --ask app-poratge/flaggie
user $ sudo flaggie –bindist openssh

Many thanks.
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3661
Location: Hamburg

PostPosted: Sun Sep 11, 2016 9:00 am    Post subject: Reply with quote

BTW:
Quote:
Code:
--- Invalid atom in /var/lib/layman/gentoo/profiles/package.mask: >=dev-libs/openssl-1.1*
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Sun Sep 11, 2016 10:09 am    Post subject: Reply with quote

You will run into issues all the time if you switch bindist per-package. Either you distribute binary packages or not, so switch it off in make.conf and make sure to rebuild affected packages for the use flag change with -N.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3661
Location: Hamburg

PostPosted: Sun Sep 11, 2016 10:17 am    Post subject: Reply with quote

asturm wrote:
make sure to rebuild affected packages for the use flag change with -N.
-U or ?
Back to top
View user's profile Send private message
usuha
n00b
n00b


Joined: 28 May 2016
Posts: 26
Location: Tokyo, Japan

PostPosted: Sun Sep 11, 2016 11:01 am    Post subject: Reply with quote

Thanks a lot toralf.
Thanks a lot asturm.

Many thanks.
Back to top
View user's profile Send private message
michi-monster
Apprentice
Apprentice


Joined: 16 Aug 2016
Posts: 175
Location: Germany

PostPosted: Wed Feb 01, 2017 10:44 am    Post subject: Reply with quote

its the same of me. Unfortunately I can not go any further.

The error:
Code:
Total: 108 packages (103 new, 1 in new slot, 4 reinstalls), Size of downloads: 918065 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2k:0/0::gentoo, installed) pulled in by
    >=dev-libs/openssl-0.9.8f:0[bindist=] required by (net-misc/openssh-7.3_p1-r7:0/0::gentoo, installed)
                                ^^^^^^^^                                                                                                     

  (dev-libs/openssl-1.0.2k:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.2g:0=[-bindist] required by (dev-util/electron-1.3.6:1.3/1.3::gentoo, ebuild scheduled for merge)
                                 ^^^^^^^^                                                                                                                       


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also


Code:

less /etc/portage/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="X -kde alsa bindist mmx sse sse2 -cups smb-client"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
LINGUAS="de"


Code:
less /etc/portage/package.mask
dev-libs/openssl


Code:
less /etc/portage/package.use ( a part of)[ebuild  N    ~] app-eselect/eselect-electron-1.0.0::gentoo  10 KiB
[ebuild  N     ] app-eselect/eselect-pinentry-0.6::gentoo  0 KiB
[ebuild  N     ] app-eselect/eselect-notify-send-0.1::gentoo  0 KiB
[ebuild  N     ] dev-perl/JSON-2.900.0::gentoo  USE="{-test}" 84 KiB
[ebuild  N     ] dev-libs/dotconf-1.3::gentoo  326 KiB
[ebuild   R    ] sys-libs/zlib-1.2.11::gentoo  USE="minizip* -static-libs" ABI_X86="(64) -32 (-x32)" 594 KiB
[ebuild  N     ] dev-perl/File-BaseDir-0.30.0-r1::gentoo  USE="{-test}" 6 KiB
[ebuild  N     ] dev-libs/oniguruma-5.9.5::gentoo  USE="-combination-explosion-check -crnl-as-line-terminator -static-libs" ABI_X86="(64) -32 (-x32)" 575 KiB
[ebuild  N     ] sys-libs/libcap-ng-0.7.8::gentoo  USE="-python -static-libs" PYTHON_TARGETS="python2_7 python3_4 (-python3_5)" 438 KiB
[ebuild  N     ] dev-libs/nettle-3.2-r1:0/6::gentoo  USE="gmp -doc (-neon) -static-libs {-test}" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="-aes" 1836 KiB
[ebuild  N     ] app-arch/snappy-1.1.3-r1::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 1474 KiB
[ebuild  N     ] media-libs/libmad-0.15.1b-r8::gentoo  USE="-debug -static-libs" ABI_X86="(64) -32 (-x32)" 491 KiB
[ebuild  N     ] dev-libs/json-c-0.12::gentoo  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 490 KiB
[ebuild  N     ] media-libs/tiff-4.0.7::gentoo  USE="cxx jpeg zlib -jbig -lzma -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 2028 KiB
[ebuild   R   #] dev-libs/openssl-1.0.2k::gentoo  USE="asm sslv3 tls-heartbeat zlib -bindist* -gmp -kerberos -rfc3779 -sctp -sslv2 -static-libs {-test} -vanilla" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(sse2)" 5185 KiB
[ebuild  N     ] dev-perl/File-DesktopEntry-0.40.0-r1::gentoo  USE="{-test}" 14 KiB
[ebuild  N     ] media-libs/lcms-2.6-r1:2::gentoo  USE="jpeg threads tiff zlib -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 4476 KiB
[ebuild  N     ] net-libs/libssh2-1.7.0::gentoo  USE="zlib -gcrypt (-libressl) -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 793 KiB
[ebuild  N     ] dev-libs/libevent-2.0.22::gentoo  USE="ssl threads -debug -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 835 KiB
[ebuild  N     ] media-libs/libmng-2.0.2-r1:0/2::gentoo  USE="lcms -static-libs" ABI_X86="(64) -32 (-x32)" 930 KiB
[ebuild  N     ] dev-python/beautifulsoup-3.2.1-r1:python-2::gentoo  PYTHON_TARGETS="python2_7 (-pypy)" 31 KiB
[ebuild  N     ] dev-python/pyxdg-0.25-r1::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-python3_5)" 48 KiB
[ebuild  N     ] dev-python/html5lib-0.9999999::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5)" 869 KiB
[ebuild  N     ] dev-python/pygments-2.1.1::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5)" 2065 KiB
[ebuild  N     ] dev-python/simplejson-3.10.0::gentoo  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5)" 77 KiB
[ebuild  N     ] dev-python/jsmin-2.2.1::gentoo  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-python3_5)" 13 KiB
[ebuild  N     ] dev-python/ply-3.9::gentoo  USE="-examples" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5)" 148 KiB
[ebuild  N     ] dev-python/markupsafe-0.23::gentoo  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5)" 14 KiB
[ebuild  N     ] media-libs/glu-9.0.0-r1::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 482 KiB
[ebuild  N     ] virtual/glu-9.0-r1::gentoo  ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] dev-python/docutils-0.12::gentoo  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5)" 1581 KiB
[ebuild  N     ] dev-python/jinja-2.8::gentoo  USE="-doc -examples" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5)" 349 KiB
[ebuild   R    ] dev-libs/libxml2-2.9.4-r1:2::gentoo  USE="icu* ipv6 python readline -debug -examples -lzma -static-libs {-test}" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_4 (-python3_5)" 0 KiB
[ebuild  N     ] media-libs/speex-1.2_rc1-r2::gentoo  USE="ogg -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse" 1037 KiB

_________________
www.edv-bildung.de
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21687
Location: here

PostPosted: Wed Feb 01, 2017 11:25 am    Post subject: Reply with quote

@michi-monster: Probably the simplest solution is disable globally bindist use flag in make.conf and update (for recompile package using this use flag) with emerge -DU @world
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Helena
Veteran
Veteran


Joined: 02 Apr 2003
Posts: 1067
Location: Den Dolder, The Netherlands

PostPosted: Wed Feb 01, 2017 7:56 pm    Post subject: Bindist is enabled by install scripts Reply with quote

I had a new install yesterday and also stumbled upon this apparent blocker (alas, not for the first time...). In my case, it only happened after I already had installed xorg-x11 and plasma 5, when I tried to install kde-apps-meta.

It seems to me that this blocker is almost always caused by the following line in /etc/portage/make.conf:
Code:
USE=bindist
whereas most of the time you simply don't need bindist. The solution is to delete this line, as has been said in many forum posts.

Now what puzzles me is why the Gentoo install media (in my case the minimal CD) leave the user with this USE flag set. As the initial make.conf suggests, it was used to compile the stage 3 tarball. But afterwards, it can simply be unset. Or, a warning could be added advising the user to delete that line.

Now, some time seems to be wasted. :(
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13745

PostPosted: Thu Feb 02, 2017 2:39 am    Post subject: Reply with quote

Setting USE=bindist is the safe default for legal reasons. Assuming it is implemented correctly, it suppresses use of any code that is legally encumbered, allowing the user to distribute binaries built with that enabled. This is presumably why the stage3 tarballs are built with it, since they are intended to be distributed to a variety of jurisdictions.
Back to top
View user's profile Send private message
NathanZachary
Moderator
Moderator


Joined: 30 Jan 2007
Posts: 2460
Location: /home/zach

PostPosted: Thu Mar 30, 2017 1:59 am    Post subject: Reply with quote

This blocker also appears with >=www-client/chromium-58 (because net-libs/nodejs requires OpenSSL to have it unset). As others have said, it seems that the only true way around it is to globally unset the bindist USE flag. :(
_________________
“Truth, like infinity, is to be forever approached but never reached.” --Jean Ayres (1972)
---avatar cropped from =AimanStudio---
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Tue Oct 10, 2017 4:50 pm    Post subject: Reply with quote

I know I'm kinda necrmancing this thread, but -OBVIOUSLY- something needs to be fixed here. What about people that want to distribute a Plasma desktop LiveUSB? In that case bindist is an absolutely required use flag, but yet at the same time because of this conflict that is currently -impossible- to do. Something is plainly and clearly wrong.
Back to top
View user's profile Send private message
kkinkouu
Tux's lil' helper
Tux's lil' helper


Joined: 17 Aug 2015
Posts: 89
Location: United Kingdom

PostPosted: Thu Oct 12, 2017 7:10 pm    Post subject: Reply with quote

remove "bindist" in make.conf, cause of so many prerequisite problems. Had a similar problem with openssl and tor integration..... on a "vanilla" system
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Thu Oct 12, 2017 7:26 pm    Post subject: Reply with quote

kkinkouu wrote:
remove "bindist" in make.conf, cause of so many prerequisite problems. Had a similar problem with openssl and tor integration..... on a "vanilla" system


Actually I already got it resolved. The thing is, if you use openssl you can't use bindist, so in that sense it is a valid blocker. But here's the problem, if you are intending to redistribute a premade gentoo system, then you -must- use bindist it's an absolute requirement. There is a solution though, you -can- use bindist with libressl, although it's still possible to run into this same blocker and that's the situation I found myself in.

Here is a link the the thread where the solution was found. Careful though, this solution is -only- valid when using libressl.
https://forums.gentoo.org/viewtopic-t-1070370-highlight-.html
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 17857

PostPosted: Thu Oct 12, 2017 8:49 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Unsupported Software as this is using Sabayon.
_________________

Believing I had supernatural powers I slammed into a brick wall.
I said hey, is this my problem? Is this my fault?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum