Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Enlightenment .v21
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Rossy65
n00b
n00b


Joined: 14 Sep 2016
Posts: 27

PostPosted: Thu Sep 15, 2016 2:27 pm    Post subject: Enlightenment .v21 Reply with quote

I'm an ancient Enlightenment user, new to Gentoo.
I'm looking to see what the status is of the .v21 version of Enlightenment is.
In the old days... Managing the dependancies beyond v16 became a nightmare...there were so many and conflicts with the "standard" Gnome/KDE window managers, I just gave up >12 years ago.

It seems to be the case wth E today...lots of dependancies...

But I'm still interested in having a go at trying the latest v21 Enlightenment and if it's not hopeless breathing new life into what was once my favorite desktop environment.

It doesn't look like much is happening...maybe we can fix this, or maybe it's hopeless. I'm thinking it's worth digging into.

It seems like overlays are the way to go...I'm reading up on layman, but it seems like a mess. What happened to the old days of just untaring, configure, build...<sigh>.

Tips on how to generate a sane overlay environment for a newbie (links examples) would be helpful.

THANKS :)
_________________
Remember, Wherever you go, there you are. --Buckaroo Banzai
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5733

PostPosted: Thu Sep 15, 2016 3:40 pm    Post subject: Reply with quote

0.17 was good. I used that for a few years no problem. Use that one if you can find it.

The versions after it are so unbearably broken I gave up on it entirely and went back to *box WMs.
Back to top
View user's profile Send private message
Rossy65
n00b
n00b


Joined: 14 Sep 2016
Posts: 27

PostPosted: Thu Sep 15, 2016 10:21 pm    Post subject: :( Reply with quote

Thats sad.. but it seemed to be the case. It looks like they went down the Wayland path (I think Wayland is the spelling). I'm not convinced that was a great idea. It seemed better to fix what exists in X11, then once Wayland is stable... then port. There are just too many loose ends.

I'm working on getting a local ebuild working for e v.21 but it appears that its more involved than the ebuild "Hello World" wiki paints. I have the hello world ebuild working fine, but trying to do any ebuild of enlightenment in /usr/local/portage/x11-wm/enlightenment-
I'm getting a Repository "x-portage" is missing message, so there is homework to do.

I plan to try and build v21 and watch it crash and burn before I abandon the later flavor's of 'E'. This may include getting Wayland to work... but I will probably give up before I have to cross that bridge myself.

Thanks for the feedback.
_________________
Remember, Wherever you go, there you are. --Buckaroo Banzai
Back to top
View user's profile Send private message
Rossy65
n00b
n00b


Joined: 14 Sep 2016
Posts: 27

PostPosted: Thu Sep 22, 2016 9:00 pm    Post subject: enlightenment-live up and running Reply with quote

Somehow... (not exactly sure)
I was able to get enlightenment-live to install today 9/22/16.

The following links were helpful:
https://wiki.gentoo.org/wiki/Enlightenment#Enlightenment_live_ebuilds_.28future_0.20_release.29
The above page appears updated since my earlier post.

https://wiki.gentoo.org/wiki/Layman
I had installed layman but the earlier wiki page on using layman wasn't working for me.

ALso I found the command:
layman -L to be very useful.

At this point I have the LATEST Enlightenment 0.21.99.21665 (from RMB "About Enlighenment") installed and running.

I did have to do a manual install of one of the supporting libraries as I recall... not sure why.

I will strive to keep better notes moving forward, and as I actually learn what the h*** I'm doing with layman/emerge and these live builds I hope to document it for the next person.
What I'd like to do (ultimately) is switch between the LAST stable Enlightment and the live version... and publish a step by stem guide on how to do that.
_________________
Remember, Wherever you go, there you are. --Buckaroo Banzai
Back to top
View user's profile Send private message
Rossy65
n00b
n00b


Joined: 14 Sep 2016
Posts: 27

PostPosted: Tue Sep 27, 2016 3:21 pm    Post subject: enlightenment-live 9999 Reply with quote

I am running Enlightenment live build under gentoo now. It's a bit buggy, but thats to be expected. I don't have my debugger configured to start diagnosing crashes.
Loading Themes seems to occasionally give it problems, and having the "ABOUT" window up for any length of time causes it to hang.

This morning I'm running version 0.21.99.21667.
I'm having some issues with emerging "Terminology"[sp?" The eolian-js.pc file is NOT getting installed properly by the efl-9999 ebuild files (I believe this is the issue).
During the build the file is expanded to /var/tmp/portage/dev-libs/efl-9999/work/efl-9999/pc/eolian-js.pc
but after the emerge is completed, there is no such file left on the system "super clean".

This is leading me down the path of "How is it supposed to work"

1) Where does Enlightenment expect the file?
2) What is missing from the efl-9999.ebuild file to put it there.

Could be I have overlooked something... so I'm digging into that now.
_________________
Remember, Wherever you go, there you are. --Buckaroo Banzai
Back to top
View user's profile Send private message
Rossy65
n00b
n00b


Joined: 14 Sep 2016
Posts: 27

PostPosted: Tue Sep 27, 2016 7:36 pm    Post subject: Elf-9999 if dbus is selected, dbus must be running *DOH* Reply with quote

Code:

/eldbus_core.c:1021 _connection_get() Error connecting to bus of type 2. e
rror name: org.freedesktop.DBus.Error.FileNotFound error message: Failed to conn
ect to socket /var/run/dbus/system_bus_socket: No such file or directory
dev-libs:efl-9999:20160923-213459.log:ERR<22797>:eldbus lib/eldbus


If you get the above error, make sure you have "USE=dbus" in your global use flags to emerge sys-apps/dbus
see: https://wiki.gentoo.org/wiki/D-Bus
*AND* you need to enable this service

as root:
Quote:
root #rc-update add dbus default


I emerged a desktop system but the dbus service did not get setup to run. (I'm not running systemd).

This gets me pass the connection_get() errors with elf
_________________
Remember, Wherever you go, there you are. --Buckaroo Banzai
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum