Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Systemd und cups beim Booten (nur manuell gehts)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
strangerthandreams
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2008
Posts: 128

PostPosted: Tue Sep 20, 2016 9:39 am    Post subject: Systemd und cups beim Booten (nur manuell gehts) Reply with quote

Hi@all,

ich habe hier ein Problem mit systemd im Zusammenspiel mit cups.

Cups kommt beim booten nicht hoch und das ist gerade bei unserem Druckserver nicht gerade erfrischend. :roll:
Manuell über "systemctl start cups" kann ich ihn aber starten.

Wenn ich einen Link manuell in
Code:
/etc/systemd/system/multi-user.target.wants
auf
Code:
/usr/lib/systemd/system/cups.service
anlege, startet cups beim Booten. Aber nach einem Update oder "systemctl reenable cups" wird der Link ja wieder gelöscht.

"systemctl enable cups" legt von sich aus einen Link in
Code:
/etc/systemd/system/printer.target.wants
an. Muss das so sein?


Ich hoffe das war soweit verständlich gerade, was ich geschrieben habe.

Hat jemand eine Idee?
_________________
Hier könnte Ihre Werbung stehen!
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1559
Location: Schweiz

PostPosted: Tue Sep 20, 2016 10:03 am    Post subject: Reply with quote

Als erstes will ich mal folgendes dazu sagen:
Von Hand irgendwelche symlinks zu erstellen gehört zu den miesesten Ideen welche man in solchen Fällen haben kann also mach es lieber so wie es auch gedacht ist, das gibt auch am wenigsten Probleme.

Zum Thema:
In welchem Target ein Service-Unit eingerichtet wird entscheidet derjenige der das Service-Unit geschrieben hat und im Fall von CUPS ist es wohl das Printer-Target:
/usr/lib/systemd/system/cups.service:
...
[Install]
Also=cups.socket cups.path
WantedBy=printer.target

Aber gerade bei CUPS würde ich persönlich eher dazu raten den Service erst dann von systemd (mit "systemctl enable cups.socket") starten zu lassen wenn er auch wirklich gebraucht wird.
_________________
GPG: 0x3FC78AEE51E5FB95
Back to top
View user's profile Send private message
strangerthandreams
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2008
Posts: 128

PostPosted: Tue Sep 20, 2016 10:40 am    Post subject: Reply with quote

schmidicom wrote:
Als erstes will ich mal folgendes dazu sagen:
Von Hand irgendwelche symlinks zu erstellen gehört zu den miesesten Ideen welche man in solchen Fällen haben kann, also bitte mach es so wie es auch gedacht ist, das gibt auch am wenigsten Probleme.


Zum Testen in meinen Augen ein probates Mittel. Wie ich ja oben bereits ausgeführt habe, funktioniert es eben gerade nicht wie es gedacht war. Um das Problem einzugrenzen fand ich die Idee gar nicht schlecht. Das Dateisystem gibt es her, also nutze ich es zum Testen. Du kannst mir sicher sagen, wie ich es sonst hätte besser machen können.

Bisher lief das übrigens sei knapp zwei Jahren ohne Probleme (ich meine natürlich ohne einen eigenen Symlink). Das Einzige was ich verändert hatte war eine neue PPD für einen bereits installierten Drucker, sonst nichts (oder es muss schon länger her sein). Es muss auch immer zwingend möglich sein, die Warteschlange zu bearbeiten, so dass cups.service zu laufen hat.

So und nun? Ohne Symlink meinerseits startet cups nicht mehr selbst beim Hochfahren. Ist das ein Feature? Kann man sicher beheben, aber ich weiß nicht wie.
_________________
Hier könnte Ihre Werbung stehen!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum