Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mkfs funktioniert nicht
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
xilinx
n00b
n00b


Joined: 29 Dec 2015
Posts: 11

PostPosted: Thu Sep 22, 2016 5:40 pm    Post subject: mkfs funktioniert nicht Reply with quote

Hi,

ich brauche mal wieder eure Hilfe, da ich wieder kurz vor einem Nerverzusammenbruch stehe :(

Ganze Geschichte...(Lange geschichte)
Ich möchte eine bootfähigen USB erstellen. Dazu habe ich mir die .iso heruntergeladen und dann mit dd das image draufgeschrieben.
Code:
dd if=tails-i386-2.6.iso of=/dev/sdb

sorry jetzt bin ich mir nicht mehr sicher, ob ich /dev/sdb oder /dev/sdb1 geschrieben habe. Ich glaube Ersteres (ist das richtig? In der iso sind doch auch infos über zu erstellende partitionen und dateisystem enthalten?)
Naja booten konnte ich den USB anschließend nicht, da die partition deffekt war (hat fdisk gesagt)
Dann hab ich mit fdisk ein neues GPT partitionslabel draufgepackt (ist ein GPT für kleine USBs(4GB) überhaupt sinnvoll?)
Nun hab ich mit mkfs.vfat /dev/sdb1 ein Dateisystem draufschreiben wollen, wo ich dann folgende Fehlermeldung bekam:

Code:

root:// # mkfs.vfat /dev/sdb1                                                                                                                                     
zsh: command not found: mkfs.vfat
root:// # 

Kann sein das die zsh Schuld daran ist? (Der Gedanke kommt mir erst jetzt...)
Welches package muss ich installieren, um diesen Befehl verwenden zu können?
Gibt's Alternativen um ein filesystem zu schreiben.

Vielen Dank im Voraus für jegliche Hilfe :)
Back to top
View user's profile Send private message
mike155
Veteran
Veteran


Joined: 17 Sep 2010
Posts: 1303
Location: Frankfurt, Germany

PostPosted: Thu Sep 22, 2016 9:07 pm    Post subject: Reply with quote

/usr/sbin/mkfs.vfat ist enthalten im Paket sys-fs/dosfstools
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Fri Sep 23, 2016 11:12 am    Post subject: Reply with quote

Und falls dosfstools installiert ist, dann überprüfen, ob der Pfad /usr/sbin in der zsh gesetzt ist.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum