Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Update Blocks
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Wed Sep 28, 2016 8:57 am    Post subject: Update Blocks Reply with quote

Hallo,

habe ein paar Update Probleme...

könnte mir da jemand einen Tipp geben woran es hängt?

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.22.2:0/5.22::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.22.2* required by (virtual/perl-File-Spec-3.560.100:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^^                                                                                                                                             
    (and 35 more with the same problem)

  (dev-lang/perl-5.20.2:0/5.20::gentoo, installed) pulled in by
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/Geo-IP-1.450.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                           
    (and 113 more with the same problem)

dev-libs/gmp:0

  (dev-libs/gmp-6.1.0:0/10.4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/gmp-6.0.0a:0/0::gentoo, installed) pulled in by
    >=dev-libs/gmp-5:0/0= required by (dev-lang/ghc-7.10.3:0/7.10.3::gentoo, installed)
                    ^^^^^                                                                                                 
    (and 1 more with the same problem)

x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
    x11-libs/libxcb:0/1.11.1=[abi_x86_64(-)] required by (x11-libs/xcb-util-keysyms-0.4.0:0/0::gentoo, installed)
                   ^^^^^^^^^^                                                                                                                       
    (and 5 more with the same problem)


Danke
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Wed Sep 28, 2016 3:06 pm    Post subject: Reply with quote

Hi Tinitus,

haste schon mal

Code:
perl-cleaner --reallyall


drauf los gelassen und geschaut wieviel danach noch an Problemen übrig bleibt.
Danach ggf. noch mal mit emerge -DuvatN @ world --backtrace=300 o.ä. versuchen und im Zweifel dann dessen Ausgabe posten, dann sehen wir mal weiter.

Waaas, ich hab da gerade so'n piepen im Ohr... :lol:

Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Sat Oct 01, 2016 11:01 pm    Post subject: Reply with quote

Tinitus wrote:
könnte mir da jemand einen Tipp geben woran es hängt?
Ich bin mir sicher das in der kompletten emerge Ausgabe schon ein Tipp mit dabei ist - du müsstest ihn nur lesen :)
Zudem machst du es uns auch schwierig, da die verwendeten emerge Optionen (zu diesem Teilausschnitt) nicht bekannt sind.

Schaut aus als wenn portage die Subslot-Deps so noch nicht mit aufgelöst bekommt.
Versuche ein
Code:
emerge -avuDN @world --with-bdeps=y --backtrack=300 --verbose-conflicts
(wenn das nicht klappt, dann stelle bitte die komplette Ausgabe via Pastebin-Service bereit :))
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3686
Location: Hamburg

PostPosted: Fri Oct 07, 2016 9:14 pm    Post subject: Reply with quote

Habe seit 1-2 Tagen auf der Tinderbox ähnliche Probleme, vllt. ein Versuch wert:
Code:

echo "=sys-libs/ncurses-6.0-r1" >> /etc/portage/package.mask/setup_blocker
echo "=dev-lang/perl-5.24.0-r1" >> /etc/portage/package.mask/setup_blocker
echo ">=dev-libs/gmp-6.1.0" >> /etc/portage/package.mask/setup_blocker
?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Sat Oct 08, 2016 11:50 am    Post subject: Reply with quote

Naja, mit dem Schnipsel (den er selbst, verständlicher weise, nicht versteht) ist nichts anzufangen - damit wird wahrscheinlich niemand weiterhelfen können.
Poste doch bitte mal die komplette Fehlermeldung :)
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2225
Location: Germany

PostPosted: Mon Oct 10, 2016 8:57 pm    Post subject: Reply with quote

Also beim letzten mal hatte ich immer Probleme mit dem perl-cleaner, geholfen hatt dann folgende Kombination:

1. emerge -avu10 =dev-lang/perl-5.22.2
2. perl-cleaner --reallyall
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Mon Oct 17, 2016 8:09 am    Post subject: Reply with quote

Aloah,

zwischenzeitlich hab ich auf einer älteren und weniger gut bzw. regelmäßig gepflegten stabilen Gentoo USB-Stick Version auch ganz schön mit perl updates zu kämpfen gehabt, Stichwort subslot hell.
Hilfe und funktionierende Lösungsansätze fand ich dann in folgendem Thread, bseonders zum Ende hin.

https://forums.gentoo.org/viewtopic-t-996680-highlight-perl.html

Gruß und viel Erfolg damit,

Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Mon Oct 17, 2016 9:16 am    Post subject: Reply with quote

Randy Andy wrote:
Stichwort subslot hell
Der Trick ist meist (besonders beim Perl Update)
--with-bdeps=y und einen hohen --backtrack=Wert zu kombinieren.

Bei Perl sind meist ne menge build time Deps mit bei, die beim normalen @world Update nicht mit berücksichtigt werden (sofern nicht im ebuild, oder via --with-bdeps=y Option mit angegeben) - was dann mitunter zu schwer bis gar nicht auflösen führt.
Der Vorschlag aus meinem vorletzten Post sollte eigentlich funktionieren :)
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Sat Oct 22, 2016 8:17 pm    Post subject: Reply with quote

@Tinitus,
darf man mal fragen was draus geworden ist?
Oder besteht kein Interesse mehr?
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Tue Nov 01, 2016 6:27 pm    Post subject: Reply with quote

Ich habe exakt dasselbe Problem

Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.22.2:0/5.22::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.22* required by (virtual/perl-Scalar-List-Utils-1.410.0:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                   
    (and 42 more with the same problem)

  (dev-lang/perl-5.20.2:0/5.20::gentoo, installed) pulled in by
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/Authen-SASL-2.160.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                   
    (and 51 more with the same problem)

x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
    >=x11-libs/libxcb-1.9.1:0/1.11.1=[abi_x86_32(-),abi_x86_64(-)] required by (x11-libs/xcb-util-0.4.0:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                             
    (and 5 more with the same problem)

x11-base/xorg-server:0

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-server-1.18[udev] required by (x11-drivers/xf86-input-evdev-2.10.3:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^                                                                                                                                                       

  (x11-base/xorg-server-1.17.4:0/1.17.4::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.17.4= required by (x11-drivers/xf86-input-mouse-1.9.1:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                           
    (and 5 more with the same problem)



Ich habe perl-cleaner --reallyall ausgeführt, es wurden viele Pakete neu installiert, die Ausgabe am Ende war

Code:

*
 * It seems like perl-cleaner had to rebuild some packages.
 *
 * If you have just updated your major Perl version (e.g. from 5.20.2 to 5.22.0),
 * and have run perl-cleaner _after_ that update, then this means most likely
 * that these packages are buggy. Please file a bug on http://bugs.gentoo.org/ and
 * report that perl-cleaner needed to reinstall the following list:
 *    dev-vcs/git:0 perl-core/Data-Dumper:0 virtual/perl-Data-Dumper:0 perl-core/JSON-PP:0 virtual/perl-JSON-PP:0 perl-core/File-Temp:0 virtual/perl-File-Temp:0 perl-core/Module-Metadata:0 virtual/perl-Module-Metadata:0 perl-core/Test-Simple:0 virtual/perl-Test-Simple:0 perl-core/CPAN-Meta:0 virtual/perl-CPAN-Meta:0 perl-core/libnet:0 virtual/perl-libnet:0 sys-apps/texinfo:0 dev-perl/PlRPC:0 dev-perl/Module-Build:0 dev-perl/Error:0 dev-perl/HTML-Tagset:0 dev-perl/XML-Parser:0 dev-perl/XML-Simple:0 dev-perl/Digest-Perl-MD5:0 dev-perl/Archive-Zip:0 dev-perl/LWP-MediaTypes:0 dev-perl/URI:0 dev-perl/File-MimeInfo:0 dev-perl/Jcode:0 dev-perl/XML-NamespaceSupport:0 dev-perl/HTTP-Daemon:0 dev-perl/Net-SMTP-SSL:0 dev-perl/XML-LibXML:0 dev-perl/LWP-Protocol-https:0 dev-perl/Authen-SASL:0 dev-perl/XML-SAX:0 dev-perl/Spreadsheet-ParseExcel:0 dev-perl/OLE-StorageLite:0 dev-perl/HTTP-Cookies:0 dev-perl/IO-HTML:0 dev-perl/Unicode-Map:0 dev-perl/WWW-RobotRules:0 dev-perl/DBD-mysql:0 dev-perl/libxml-perl:0 dev-perl/HTTP-Negotiate:0 dev-perl/Encode-Locale:0 dev-perl/Digest-HMAC:0 dev-perl/File-BaseDir:0 dev-perl/DBI:0 dev-perl/IO-Socket-SSL:0 dev-perl/Text-CSV_XS:0 dev-perl/Net-Daemon:0 dev-perl/Text-Unidecode:0 dev-perl/XML-SAX-Base:0 dev-perl/File-Listing:0 dev-perl/Net-SSLeay:0 dev-perl/HTTP-Date:0 dev-perl/Net-HTTP:0 dev-perl/File-DesktopEntry:0 dev-perl/libintl-perl:0 dev-perl/Locale-gettext:0 dev-perl/Unicode-EastAsianWidth:0 dev-perl/libwww-perl:0 dev-perl/Crypt-RC4:0 dev-perl/HTML-Parser:0 dev-perl/IO-stringy:0 dev-perl/HTTP-Message:0 dev-perl/Test-Deep:0


Aber das Problem wurde behoben. Dann habe ich mir die Troubleshooting Seite angeschaut, da habe ich versucht

Code:

emerge --ask --oneshot =dev-lang/perl-5.22.2:0/5.22::gentoo --backtrack=300 --with-bdeps=y


aber ich bekomme dasselbe wie beim world update.

Ich habe dann "emerge -uvaDN world --backtrack=300 --with-bdeps=y" ausgeführt und dieses Mal liefert mir

Code:

dev-perl/Module-Build:0

  (dev-perl/Module-Build-0.421.600:0/0::gentoo, ebuild scheduled for merge) conflicts with
    ~dev-perl/Module-Build-0.420.500 required by (virtual/perl-Module-Build-0.420.500-r1:0/0::gentoo, installed)
    ^                      ^^^^^^^^^


The following packages are causing rebuilds:

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-libs/xcb-util-renderutil-0.3.9-r1:0/0::gentoo, ebuild scheduled for merge)
    (x11-libs/xcb-util-wm-0.4.1-r1:0/0::gentoo, ebuild scheduled for merge)
    (x11-libs/xcb-util-image-0.4.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-libs/xcb-util-0.4.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-libs/xcb-util-keysyms-0.4.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-qt/qtgui-5.6.1:5/5.6::gentoo, ebuild scheduled for merge)
  (dev-lang/perl-5.22.2:0/5.22::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (dev-perl/Jcode-2.70.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-stringy-2.111.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-SAX-Base-1.80.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/URI-1.710.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/libwww-perl-6.150.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Cookies-6.10.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Message-6.110.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Date-6.20.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-SMTP-SSL-1.30.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/DBD-mysql-4.37.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Daemon-6.10.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Spreadsheet-ParseExcel-0.650.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Unicode-EastAsianWidth-1.330.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/LWP-Protocol-https-6.60.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/WWW-RobotRules-6.20.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-LibXML-2.12.100:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Digest-HMAC-1.30.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Module-Build-0.420.500:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-HTML-1.1.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-vcs/git-2.7.3-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/File-BaseDir-0.30.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTML-Tagset-3.200.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/libxml-perl-0.80.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/libintl-perl-1.240.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-Daemon-0.480.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/DBI-1.634.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/File-MimeInfo-0.270.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Unicode-Map-0.112.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-Simple-2.200.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-NamespaceSupport-1.110.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/LWP-MediaTypes-6.20.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-Unidecode-1.270.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Digest-Perl-MD5-1.900.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-Socket-SSL-2.24.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/File-DesktopEntry-0.40.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Locale-gettext-1.50.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/PlRPC-0.202.0-r2:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Negotiate-6.10.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-Parser-2.410.0-r2:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-SAX-0.990.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/File-Listing-6.40.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-CSV_XS-1.230.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Crypt-RC4-2.020.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (sys-apps/texinfo-6.1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-HTTP-6.90.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Error-0.170.240:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Encode-Locale-1.30.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Archive-Zip-1.530.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTML-Parser-3.710.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-SSLeay-1.720.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/OLE-StorageLite-0.190.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/File-Temp-0.230.400-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Authen-SASL-2.160.0-r1:0/0::gentoo, ebuild scheduled for merge)
  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-drivers/xf86-input-keyboard-1.8.1:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-fbdev-0.4.4:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-vesa-2.3.4:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-mouse-1.9.1:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-nv-2.1.20-r1:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/nvidia-drivers-361.28:0/361::gentoo, ebuild scheduled for merge)


aber es ist nicht mit einer Fehlermeldung abgebrochen.

Was genau sind diese time dependencies und wieso hilft da --backtrack=300? Ich hab die man page gelesen, aber ich bin nicht wirklich schlau daraus geworden.
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum