Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wacom Penabled Screen Not Working - Thinkpad X201 Tablet
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Cation
n00b
n00b


Joined: 02 Oct 2016
Posts: 1

PostPosted: Tue Oct 04, 2016 10:02 pm    Post subject: Wacom Penabled Screen Not Working - Thinkpad X201 Tablet Reply with quote

I recently installed Gentoo for the first time on my X201t and have been enjoying the amount of documentation and help available. Unfortunately there doesn't seem to be much of any for the specific situations around my laptop so it's time for my first post in the community.

The problem I'm focusing on at the moment is that I'm not sure how to get the laptop's touch screen to work. I included what I think to be the appropriate driver as part of the kernel, but I haven't had any luck.

These are the related settings I enabled in menuconfig

Device Drivers --->
Input device support --->
[*]Tablets --->
<*> Wacom protocol 4 serial tablet support

Touchscreens ---->
<*>Wacom W8001 penabled serial touchscreen
<*>Wacom Tablet support (I2C)

Was there something I missed? Maybe I should have made them modular?
Yes I checked to see if I was r

Also there's another problem I feel might be related.
My trackpad (even though I don't use it over trackpoint) hasn't been behaving right.
It's mapped the screen like a drawing tablet is. When I touch somewhere on it the cursor jumps to the equivalent spot on the screen.
Is there some kind of oddity having it be seen as the touch screen or is that unrelated?
Back to top
View user's profile Send private message
szatox
Veteran
Veteran


Joined: 27 Aug 2013
Posts: 1777

PostPosted: Wed Oct 05, 2016 7:36 pm    Post subject: Reply with quote

Support for wacom is a bit confusing at the first glance. When you get the kernel modules, you are likely to see it "sort of work" but not really the way you like.
Then you set INPUT_DEVICES="evdev wacom" and rebuild x11-base/xorg-drivers and.... Wow, it works!
Well, I had to apply xorg.conf to fix the aspect ratio, though with a touch screen I'd expect it to be handled on hardware level.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum