Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Certs Error During Make
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
AlphaXeos
n00b
n00b


Joined: 02 Aug 2016
Posts: 28

PostPosted: Wed Oct 05, 2016 10:46 pm    Post subject: [SOLVED] Certs Error During Make Reply with quote

When im compiling my kernel with make it gives me a certs signing key error. See image for details

http://m.imgur.com/59y2yVF


Last edited by AlphaXeos on Fri Oct 07, 2016 7:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21765
Location: here

PostPosted: Thu Oct 06, 2016 5:36 am    Post subject: Reply with quote

You have activate "Module signature verification" in kernel?
Post output of
Code:
$ grep MODULE_SIG /usr/src/linux/.config

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
AlphaXeos
n00b
n00b


Joined: 02 Aug 2016
Posts: 28

PostPosted: Thu Oct 06, 2016 10:21 pm    Post subject: Reply with quote

Code:
#
# GCOV-based kernel profiling
#
# CONFIG_GCOV_KERNEL is not set
CONFIG_ARCH_HAS_GCOV_PROFILE_ALL=y
# CONFIG_HAVE_GENERIC_DMA_COHERENT is not set
CONFIG_SLABINFO=y
CONFIG_RT_MUTEXES=y
CONFIG_BASE_SMALL=0
CONFIG_MODULES=y
CONFIG_MODULE_FORCE_LOAD=y
CONFIG_MODULE_UNLOAD=y
# CONFIG_MODULE_FORCE_UNLOAD is not set
CONFIG_MODVERSIONS=y
CONFIG_MODULE_SRCVERSION_ALL=y
CONFIG_MODULE_SIG=y
# CONFIG_MODULE_SIG_FORCE is not set
CONFIG_MODULE_SIG_ALL=y
CONFIG_MODULE_SIG_SHA1=y
# CONFIG_MODULE_SIG_SHA224 is not set
# CONFIG_MODULE_SIG_SHA256 is not set
# CONFIG_MODULE_SIG_SHA384 is not set
# CONFIG_MODULE_SIG_SHA512 is not set
CONFIG_MODULE_SIG_HASH="sha1"
# CONFIG_MODULE_COMPRESS is not set
CONFIG_MODULES_TREE_LOOKUP=y
CONFIG_BLOCK=y
CONFIG_BLK_DEV_BSG=y
CONFIG_BLK_DEV_BSGLIB=y
CONFIG_BLK_DEV_INTEGRITY=y
CONFIG_BLK_DEV_THROTTLING=y
# CONFIG_BLK_CMDLINE_PARSER is not set
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5761

PostPosted: Fri Oct 07, 2016 12:33 am    Post subject: Reply with quote

I assume you know what you're doing and have the required amount of crypto expertise, which is in effect what you've declared by turning on that non-default config option.

Here's your required reading material, good luck:
- The help text for CONFIG_MODULE_SIG
- linux/Documentation/module-signing.txt
- https://wiki.gentoo.org/wiki/Signed_kernel_module_support
Back to top
View user's profile Send private message
AlphaXeos
n00b
n00b


Joined: 02 Aug 2016
Posts: 28

PostPosted: Fri Oct 07, 2016 1:42 am    Post subject: Reply with quote

Ant P. wrote:
I assume you know what you're doing and have the required amount of crypto expertise, which is in effect what you've declared by turning on that non-default config option.

Here's your required reading material, good luck:
- The help text for CONFIG_MODULE_SIG
- linux/Documentation/module-signing.txt
- https://wiki.gentoo.org/wiki/Signed_kernel_module_support


I wasn't aware that i had a non-default config option set. Could you point me in the right direction? thanks
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3076
Location: Illinois, USA

PostPosted: Fri Oct 07, 2016 2:33 am    Post subject: Reply with quote

AlphaXeos wrote:
I wasn't aware that i had a non-default config option set. Could you point me in the right direction? thanks

Code:
X3 ~ #  grep MODULE_SIG /usr/src/linux/.config
# CONFIG_MODULE_SIG is not set
Never had a problem. Just run "make menuconfig" and turn that option off. To do that:
1. enable loadable module support (on the first screen)
2. press enter to follow the arrow.
3. disable "Module signature verification"

I got this by typing "/config_module_sig" while in menuconfig. Yes, it's case insensitive and the "config_" isn't really necessary. "/module_sig" works as well.
I learned that from this forum.
Back to top
View user's profile Send private message
AlphaXeos
n00b
n00b


Joined: 02 Aug 2016
Posts: 28

PostPosted: Fri Oct 07, 2016 7:26 pm    Post subject: Reply with quote

Tony0945 wrote:
AlphaXeos wrote:
I wasn't aware that i had a non-default config option set. Could you point me in the right direction? thanks

Code:
X3 ~ #  grep MODULE_SIG /usr/src/linux/.config
# CONFIG_MODULE_SIG is not set
Never had a problem. Just run "make menuconfig" and turn that option off. To do that:
1. enable loadable module support (on the first screen)
2. press enter to follow the arrow.
3. disable "Module signature verification"

I got this by typing "/config_module_sig" while in menuconfig. Yes, it's case insensitive and the "config_" isn't really necessary. "/module_sig" works as well.
I learned that from this forum.


Thanks for the help!

Got it working successfully
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum