Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel 4.4.21 dell module problem[solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 933

PostPosted: Thu Oct 06, 2016 3:39 am    Post subject: Kernel 4.4.21 dell module problem[solved] Reply with quote

Hi All:

Have a look a the output below:
Code:

jserink@jserinki7 ~ $ uname -a
Linux jserinki7 4.4.21-gentoo #1 SMP PREEMPT Wed Oct 5 15:09:59 SGT 2016 x86_64 Intel(R) Core(TM) i7-2720QM CPU @ 2.20GHz GenuineIntel GNU/Linux
jserink@jserinki7 ~ $ cat /proc/i8k
1.0 A16 -1 60 1 1 3416 3003 -1 -22
jserink@jserinki7 ~ $ uname -a
Linux jserinki7 4.4.6-gentoo #6 SMP PREEMPT Wed Jun 1 04:58:45 EST 2016 x86_64 Intel(R) Core(TM) i7-2720QM CPU @ 2.20GHz GenuineIntel GNU/Linux
jserink@jserinki7 ~ $ cat /proc/i8k
1.0 A16 7C8TLQ1 57 1 1 3413 3001 -1 -22


When running kernel 4.4.21, my dell serial number comes out as "-1", when running kernel 4.4.6, its "7C8TLQ1".

A bug perhaps?
Code:

jserinki7 jserink # lsmod | grep dell
dell_rbtn               4668  0
dell_wmi                2562  0
sparse_keymap           4050  1 dell_wmi
dell_laptop            16460  0
dcdbas                  5703  1 dell_laptop
dell_smm_hwmon          7609  0
rfkill                 17475  6 cfg80211,dell_rbtn,bluetooth,dell_laptop
wmi                     9378  1 dell_wmi
video                  29160  2 dell_wmi,dell_laptop
dell_smo8800            3654  0
led_class               4423  4 sdhci,iwldvm,dell_laptop,input_leds


Thing is, smbios-sys-info returns the correct values:
Code:

jserinki7 jserink # /usr/sbin/smbios-sys-info
Libsmbios version:      2.2.28
Product Name:           Precision M4600
Vendor:                 Dell Inc.
BIOS Version:           A16
System ID:              0x04A3
Service Tag:            7C8TLQ1
Express Service Code:   15977888569
Asset Tag:             
Property Ownership Tag:



Anyone have a quick work around for this?
My conky is using the i8k_serial which is curretly putting up a "-i" rather than the correct value.

Cheers,
John

[Moderator edit: added [code] tags to preserve output layout. -Hu]


Last edited by jserink on Thu Dec 01, 2016 3:53 am; edited 1 time in total
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Thu Oct 06, 2016 9:12 am    Post subject: Reply with quote

You may try with a recent kernel, not antique ones => kernel.org stable ones of course
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 933

PostPosted: Thu Oct 06, 2016 9:42 am    Post subject: Reply with quote

Antique?
Emerge just pulled it in last week!
:)
John
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13836

PostPosted: Fri Oct 07, 2016 1:39 am    Post subject: Reply with quote

v4.4.21 is relatively new, but it is a stable-series kernel based off v4.4, which was released in January. Sometimes useful fixes do not get included in stable kernels because no one asks for it to happen. Thus, for a relatively obscure issue like this, you should look at the release date of the series, not the specific stable kernel. I think Roman wants you to try v4.8, which was released October 2.
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 933

PostPosted: Fri Oct 07, 2016 2:34 am    Post subject: Reply with quote

Hu wrote:
v4.4.21 is relatively new, but it is a stable-series kernel based off v4.4, which was released in January. Sometimes useful fixes do not get included in stable kernels because no one asks for it to happen. Thus, for a relatively obscure issue like this, you should look at the release date of the series, not the specific stable kernel. I think Roman wants you to try v4.8, which was released October 2.


Have umasked and emerged 4.76. Will give this a go.
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 933

PostPosted: Sat Oct 08, 2016 6:50 am    Post subject: Reply with quote

Hi Guys:

Code:
jserink@jserinki7 ~ $ uname -a
Linux jserinki7 4.7.6-gentoo #4 SMP PREEMPT Sat Oct 8 14:29:10 SGT 2016 x86_64 Intel(R) Core(TM) i7-2720QM CPU @ 2.20GHz GenuineIntel GNU/Linux
jserink@jserinki7 ~ $ cat /proc/i8k
1.0 A16 -1 61 1 1 3372 2997 -1 -22

jserinki7 jserink # /usr/sbin/smbios-sys-info
Libsmbios version:      2.2.28
Product Name:           Precision M4600
Vendor:                 Dell Inc.
BIOS Version:           A16
System ID:              0x04A3
Service Tag:            7C8TLQ1
Express Service Code:   15977888569
Asset Tag:             
Property Ownership Tag:


Appears the bug is also in 4.7.6.

Cheers,
John

[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sat Oct 08, 2016 11:42 am    Post subject: Reply with quote

you may open a bug at kernel.org ... When it's a bug
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13836

PostPosted: Sat Oct 08, 2016 3:50 pm    Post subject: Reply with quote

Please use [code] tags on your own. I have added them to all of your recent posts where I am active, which brings me to four of your posts in the last hour.

On the subject at hand:
Since it worked in an earlier series of stable kernel, and broke sometime in the 4.4.x stable line, this should be relatively easy to bisect. I suggest you use git bisect to identify the specific patch that broke it. If you provide that to upstream, it will be much easier for them to determine why you now get the wrong output.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum