Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Blocks & Slots
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1167
Location: Eppingen, Germany

PostPosted: Thu Nov 10, 2016 9:53 pm    Post subject: Reply with quote

Sorry, ich war im Urlaub und bin jetzt im "Aufarbeitsstress". Außerdem muss ich die fast 1.000 Bilder verschlagworten.

Ja, das lqxt-meta-Problem hat sich erledigt, aber folgende Abbrüche habe ich immer noch:

Code:
>>> Installing (2 of 14) sci-geosciences/routino-3.1.1::gentoo
 * checking 61 files for package collisions
 * This package will overwrite one or more files that may belong to other
 * packages (see list below). You can use a command such as `portageq
 * owners / <filename>` to identify the installed package that owns a
 * file. If portageq reports that only one package owns a file then do
 * NOT file a bug report. A bug report is only useful if it identifies at
 * least two or more packages that are known to install the same file(s).
 * If a collision occurs and you can not explain where the file came from
 * then you should simply ignore the collision since there is not enough
 * information to determine if a real problem exists. Please do NOT file
 * a bug report at http://bugs.gentoo.org unless you report exactly which
 * two packages install the same file(s). See
 * http://wiki.gentoo.org/wiki/Knowledge_Base:Blockers for tips on how to
 * solve the problem. And once again, please do NOT file a bug report
 * unless you have completely understood the above message.
 *
 * Detected file collision(s):
 *
 *      /usr/lib/debug/usr/bin/planetsplitter.debug
 *      /usr/bin/planetsplitter
 *
 * Searching all installed packages for file collisions...
 *
 * Press Ctrl-C to Stop
 *
 * sci-geosciences/qmapshack-1.3.0:0::gentoo
 *      /usr/bin/planetsplitter
 *      /usr/lib/debug/usr/bin/planetsplitter.debug
 *
 * Package 'sci-geosciences/routino-3.1.1' NOT merged due to file
 * collisions. If necessary, refer to your elog messages for the whole
 * content of the above message.

>>> Failed to install sci-geosciences/routino-3.1.1, Log file:

>>>  '/var/tmp/portage/sci-geosciences/routino-3.1.1/temp/build.log'


Code:
make[2]: Entering directory '/var/tmp/portage/net-dns/avahi-0.6.32-r1/work/avahi-0.6.32-abi_x86_64.amd64'
sed -e 's,@prefix\@,/usr,g' \
    -e 's,@libdir\@,/usr/lib64,g' \
    -e 's,@HOWL_COMPAT_VERSION\@,0.9.8,g' \
    -e 's,@PACKAGE_VERSION\@,0.6.32,g' avahi-core.pc.in > avahi-core.pc
sed -e 's,@prefix\@,/usr,g' \
    -e 's,@libdir\@,/usr/lib64,g' \
    -e 's,@HOWL_COMPAT_VERSION\@,0.9.8,g' \
    -e 's,@PACKAGE_VERSION\@,0.6.32,g' avahi-client.pc.in > avahi-client.pc
sed -e 's,@prefix\@,/usr,g' \
    -e 's,@libdir\@,/usr/lib64,g' \
    -e 's,@HOWL_COMPAT_VERSION\@,0.9.8,g' \
    -e 's,@PACKAGE_VERSION\@,0.6.32,g' avahi-glib.pc.in > avahi-glib.pc
sed -e 's,@prefix\@,/usr,g' \
    -e 's,@libdir\@,/usr/lib64,g' \
    -e 's,@HOWL_COMPAT_VERSION\@,0.9.8,g' \
    -e 's,@PACKAGE_VERSION\@,0.6.32,g' avahi-gobject.pc.in > avahi-gobject.pc
sed -e 's,@prefix\@,/usr,g' \
    -e 's,@libdir\@,/usr/lib64,g' \
    -e 's,@HOWL_COMPAT_VERSION\@,0.9.8,g' \
    -e 's,@PACKAGE_VERSION\@,0.6.32,g' avahi-ui.pc.in > avahi-ui.pc
sed -e 's,@prefix\@,/usr,g' \
    -e 's,@libdir\@,/usr/lib64,g' \
    -e 's,@HOWL_COMPAT_VERSION\@,0.9.8,g' \
    -e 's,@PACKAGE_VERSION\@,0.6.32,g' avahi-ui-gtk3.pc.in > avahi-ui-gtk3.pc
sed -e 's,@prefix\@,/usr,g' \
    -e 's,@libdir\@,/usr/lib64,g' \
    -e 's,@HOWL_COMPAT_VERSION\@,0.9.8,g' \
    -e 's,@PACKAGE_VERSION\@,0.6.32,g' avahi-qt4.pc.in > avahi-qt4.pc
make[2]: Leaving directory '/var/tmp/portage/net-dns/avahi-0.6.32-r1/work/avahi-0.6.32-abi_x86_64.amd64'
make[1]: Leaving directory '/var/tmp/portage/net-dns/avahi-0.6.32-r1/work/avahi-0.6.32-abi_x86_64.amd64'
>>> Source compiled.
 * --------------------------- ACCESS VIOLATION SUMMARY ---------------------------
 * LOG FILE: "/var/log/sandbox/sandbox-26544.log"
 *
VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: mkdir
S: deny
P: /home/uhai/.cache/g-ir-scanner
A: /home/uhai/.cache/g-ir-scanner
R: /home/uhai/.cache/g-ir-scanner
C: /usr/bin/python2.7 /usr/bin/g-ir-scanner --add-include-path=. --namespace=Avahi --nsversion=0.6 --libtool=/bin/sh ../libtool --include=GObject-2.0 --include=AvahiCore-0.6 --library=libavahi-gobject.la --strip-prefix=Ga --cflags-begin -I.. -DDEBUG_TRAP=__asm__("int ") -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include --cflags-end ga-client.c ga-client.h ga-entry-group.c ga-entry-group.h ga-enums.h ga-error.c ga-error.h ga-record-browser.c ga-record-browser.h ga-service-browser.c ga-service-browser.h ga-service-resolver.c ga-service-resolver.h signals-marshal.list signals-marshal.h signals-marshal.c ga-client-enumtypes.h ga-client-enumtypes.c ga-entry-group-enumtypes.h ga-entry-group-enumtypes.c ga-enums-enumtypes.h ga-enums-enumtypes.c libavahi-gobject.la --output Avahi-0.6.gir
 * --------------------------------------------------------------------------------

>>> Failed to emerge net-dns/avahi-0.6.32-r1, Log file:

>>>  '/var/tmp/portage/net-dns/avahi-0.6.32-r1/temp/build.log'


Das scheint der selbe Bug, oder?

Code:
make[1]: Leaving directory '/var/tmp/portage/app-misc/geoclue-2.4.4/work/geoclue-2.4.4'
>>> Source compiled.
 * --------------------------- ACCESS VIOLATION SUMMARY ---------------------------
 * LOG FILE: "/var/log/sandbox/sandbox-16517.log"
 *
VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: mkdir
S: deny
P: /home/uhai/.cache/g-ir-scanner
A: /home/uhai/.cache/g-ir-scanner
R: /home/uhai/.cache/g-ir-scanner
C: /usr/bin/python2.7 /usr/bin/g-ir-scanner -v --warn-all --namespace Geoclue --identifier-prefix=GClue --symbol-prefix=gclue --nsversion=2.0 --include=Gio-2.0 --library=libgeoclue-2.la --output Geoclue-2.0.gir --pkg=glib-2.0 --pkg=gobject-2.0 --pkg=gio-2.0 --pkg-export=libgeoclue-2.0 --libtool=/bin/sh ../libtool -I. -I../public-api -I../public-api --c-include=geoclue.h gclue-client.c gclue-location.c gclue-manager.c gclue-helpers.c gclue-simple.c geoclue.h gclue-client.h gclue-location.h gclue-manager.h gclue-helpers.h gclue-simple.h libgeoclue-2.la /usr/bin/g-ir-scanner Makefile.am ../public-api/gclue-enums.h
 * --------------------------------------------------------------------------------

>>> Failed to emerge app-misc/geoclue-2.4.4, Log file:

>>>  '/var/tmp/portage/app-misc/geoclue-2.4.4/temp/build.log'


Das scheint auch der selbe Bug, oder? Beide sind übrigens vom gleichen user gemeldet....?! Hat wohl eine ähnliche Konstellation wie ich....

Code:
* ECM (required version >= 5.28.0) , Extra CMake Modules. , <https://projects.kde.org/projects/kdesupport/extra-cmake-modules>

CMake Error at /usr/share/cmake/Modules/FeatureSummary.cmake:556 (message):
  feature_summary() Error: REQUIRED package(s) are missing, aborting CMake
  run.
Call Stack (most recent call first):
  CMakeLists.txt:8 (feature_summary)


-- Configuring incomplete, errors occurred!
See also "/var/tmp/portage/kde-frameworks/frameworkintegration-9999/work/frameworkintegration-9999_build/CMakeFiles/CMakeOutput.log".
 * ERROR: kde-frameworks/frameworkintegration-9999::kde failed (configure phase):
 *   cmake failed
 *
 * Call stack:
 *     ebuild.sh, line  115:  Called src_configure
 *   environment, line 4414:  Called kde5_src_configure
 *   environment, line 3429:  Called cmake-utils_src_configure
 *   environment, line 1318:  Called _cmake_execute_optionally 'src_configure'
 *   environment, line  514:  Called enable_cmake-utils_src_configure
 *   environment, line 1746:  Called die
 * The specific snippet of code:
 *       "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
 *
 * If you need support, post the output of `emerge --info '=kde-frameworks/frameworkintegration-9999::kde'`,
 * the complete build log and the output of `emerge -pqv '=kde-frameworks/frameworkintegration-9999::kde'`.
 * The complete build log is located at '/var/tmp/portage/kde-frameworks/frameworkintegration-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-frameworks/frameworkintegration-9999/temp/environment'.
 * Working directory: '/var/tmp/portage/kde-frameworks/frameworkintegration-9999/work/frameworkintegration-9999_build'
 * S: '/var/tmp/portage/kde-frameworks/frameworkintegration-9999/work/frameworkintegration-9999'

>>> Failed to emerge kde-frameworks/frameworkintegration-9999, Log file:

>>>  '/var/tmp/portage/kde-frameworks/frameworkintegration-9999/temp/build.log'


Code:
Compiling user interface files ...

Installing eric5 ...
Could not install './default.e4k'.
Could not install './default_Mac.e4k'.
An internal error occured.  Please report all the output of the program,
including the following traceback, to eric-bugs@eric-ide.python-projects.org.

Traceback (most recent call last):
  File "install.py", line 1421, in <module>
    main(sys.argv)
  File "install.py", line 1400, in main
    res = installEric()
  File "install.py", line 757, in installEric
    os.path.join(dst, "eric5" + marker + ".png"))
  File "install.py", line 562, in shutilCopy
    shutil.copy(src, dst)
  File "/usr/lib64/python2.7/shutil.py", line 119, in copy
    copyfile(src, dst)
  File "/usr/lib64/python2.7/shutil.py", line 82, in copyfile
    with open(src, 'rb') as fsrc:
IOError: [Errno 2] No such file or directory: u'./icons/default/eric5.png'
 * ERROR: dev-util/eric-5.5.2::gentoo failed (install phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line 115:  Called src_install
 *   environment, line 3013:  Called die
 * The specific snippet of code:
 *       "${PYTHON}" install.py -b "${EPREFIX}/usr/bin" -d "$(python_get_sitedir)" -i "${D}" -c -z || die;
 *
 * If you need support, post the output of `emerge --info '=dev-util/eric-5.5.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/eric-5.5.2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-util/eric-5.5.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/eric-5.5.2/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-util/eric-5.5.2/work/eric5-5.5.2'
 * S: '/var/tmp/portage/dev-util/eric-5.5.2/work/eric5-5.5.2'

>>> Failed to emerge dev-util/eric-5.5.2, Log file:

>>>  '/var/tmp/portage/dev-util/eric-5.5.2/temp/build.log'


Code:
akefile:850: recipe for target 'swig-pl' failed
make: *** [swig-pl] Error 2
 * ERROR: dev-vcs/subversion-1.9.4::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=dev-vcs/subversion-1.9.4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-vcs/subversion-1.9.4::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-vcs/subversion-1.9.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-vcs/subversion-1.9.4/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-vcs/subversion-1.9.4/work/subversion-1.9.4'
 * S: '/var/tmp/portage/dev-vcs/subversion-1.9.4/work/subversion-1.9.4'
!!! When you file a bug report, please include the following information:
GENTOO_VM=icedtea-7  CLASSPATH="" JAVA_HOME="/usr/lib64/icedtea7"
JAVACFLAGS="-source 1.5 -target 1.5" COMPILER=""
and of course, the output of emerge --info =subversion-1.9.4

>>> Failed to emerge dev-vcs/subversion-1.9.4, Log file:

>>>  '/var/tmp/portage/dev-vcs/subversion-1.9.4/temp/build.log'

_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1167
Location: Eppingen, Germany

PostPosted: Sun Nov 27, 2016 5:31 pm    Post subject: Reply with quote

..und ein neues:

Code:
Calculating dependencies... done!
 * Invalid resume list:
 *
 *   ('ebuild', '/', 'kde-base/kdelibs-4.14.24', 'merge')
 *   ('ebuild', '/', 'kde-misc/krusader-2.5.0', 'merge')
 *   ('ebuild', '/', 'media-sound/clementine-1.2.3', 'merge')
 *   ('ebuild', '/', 'dev-vcs/subversion-1.9.4', 'merge')
 *   ('ebuild', '/', 'app-text/calibre-1.20', 'merge')
 *   ('ebuild', '/', 'dev-util/eric-5.5.2', 'merge')
 *   ('ebuild', '/', 'kde-apps/libkface-16.08.3', 'merge')
 *   ('ebuild', '/', 'dev-dotnet/libgdiplus-4.2-r2', 'merge')
 *
 * One or more packages are either masked or have missing dependencies:
 *
 *   media-libs/giflib:0/0= pulled in by:
 *     (kde-frameworks/khtml-9999:5/9999::kde, installed)
 *
 * The resume list contains packages that are either masked or have
 * unsatisfied dependencies. Please restart/continue the operation
 * manually, or use --skipfirst to skip the first package in the list and
 * any other packages that may be masked or have missing dependencies.


Wie kann ich die Meldung weiter eingrenzen? Die genannten Versionen sind nicht masked und größtenteils hier schon installiert....

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1167
Location: Eppingen, Germany

PostPosted: Fri Dec 16, 2016 10:10 am    Post subject: Reply with quote

Bin weitergekommen :-)

kdeframeworks habe ich wieder maskiert. Warum ich das mal freigeschaltet habe, weiss ich nicht mehr. Läuft auch ohne... avahi habe ich auch im Griff, war ebenfalls "gekeywordet". Ich werde mir angewöhnen, solche Veränderungen künftig in den package.use/mask etc. zu kommentieren.

In Sachen eric habe ich diesen patch gefunden und in /etc/portage/patches/dev-util/eric-5.5.2 abgelegt. Aber irgendetwas stimmt nicht:

Code:
 * Applying user patches from /etc/portage/patches//dev-util/eric-5.5.2 ...
 *   eric-5.install.patch ...

 * Failed Patch: eric-5.install.patch !
 *  ( /etc/portage/patches//dev-util/eric-5.5.2/eric-5.install.patch )
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/dev-util/eric-5.5.2/temp/eric-5.install.patch.out

 * ERROR: dev-util/eric-5.5.2::gentoo failed (prepare phase):
 *   Failed Patch: eric-5.install.patch!


Irgendwie taucht in der 4. Zeile im Pfad ein doppelter "/" auf. Wo kommt das her? Der Pfad in der Shell ist ok.... Ich verwende portage-2.3.0.

Kann mir da bitte jemand weiterhelfen?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum