Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Firefox-bin flash plugin [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
lesnik
n00b
n00b


Joined: 04 Oct 2016
Posts: 17

PostPosted: Tue Oct 18, 2016 5:46 pm    Post subject: Firefox-bin flash plugin [SOLVED] Reply with quote

I have a following problem with firefox + flash. I have installed www-plugins/adobe-flash and www-client/firefox-bin but still firefox complains that necessary plugin is not installed when I try to visit some site which streams video using flash.

Each of these packages does not have too many use flags, nothing like 'flash' among those several which they do have.

I checked what files are installed by adobe-flash package:

Code:

glorx540 portage # equery f www-plugins/adobe-flash
 * Searching for adobe-flash in www-plugins ...
 * Contents of www-plugins/adobe-flash-23.0.0.185:
/etc
/etc/chromium
/etc/chromium/pepper-flash
/usr
/usr/lib64
/usr/lib64/chromium-browser
/usr/lib64/chromium-browser/PepperFlash
/usr/lib64/chromium-browser/PepperFlash/libpepflashplayer.so
/usr/lib64/chromium-browser/PepperFlash/manifest.json


very strange, all the installed files go into chromium directories!

One more strange thing is in the output of firefox's emerge:

Code:

 * QA Notice: Symbolic link /opt/firefox/browser/plugins points to /usr/lib64/nsbrowser/plugins which does not exist.
>>> /opt/firefox/browser/plugins -> /usr/lib64/nsbrowser/plugins


Does it mean that from now on only chromium supports adobe-flash?


Last edited by lesnik on Wed Oct 19, 2016 7:27 am; edited 1 time in total
Back to top
View user's profile Send private message
jburns
Veteran
Veteran


Joined: 18 Jan 2007
Posts: 1048
Location: Massachusetts USA

PostPosted: Tue Oct 18, 2016 6:28 pm    Post subject: Reply with quote

For the version of adobe-flash that you are using you also need www-plugins/freshplayerplugin which allows firefox to use the chrome version of adobe-flash.

Or you could use www-plugins/adobe-flash:0 which works with firefox.
Back to top
View user's profile Send private message
lesnik
n00b
n00b


Joined: 04 Oct 2016
Posts: 17

PostPosted: Tue Oct 18, 2016 6:51 pm    Post subject: Reply with quote

jburns wrote:
For the version of adobe-flash that you are using you also need www-plugins/freshplayerplugin which allows firefox to use the chrome version of adobe-flash.


yes! That worked for me.

Just for the record: www-plugins/freshplayerplugin conflicted with adobe-flash because it brings some other packages with binary chromium plugins (if I understood him correctly). So I unmerged adobe-flash, freshplayerplugin installed without problems and now everything works.

Thank you very much!
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7131
Location: almost Mile High in the USA

PostPosted: Tue Oct 18, 2016 10:39 pm    Post subject: Reply with quote

Thanks, never knew about freshplayerplugin, those sneaky people finding a way to work around binary only software...thanks!

BTW, my dirty mind first read it was fleshplayer... which probably may even be 99% of the usage of flashplayer nowadays...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum