Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unbootable software RAID [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
knirirr
n00b
n00b


Joined: 20 Jan 2010
Posts: 33

PostPosted: Mon Oct 24, 2016 7:24 am    Post subject: Unbootable software RAID [SOLVED] Reply with quote

An old machine I've been trying to update from GRUB 0.97 to >= GRUB 2 has ended up in a state where it won't boot. The reason for the initial failure was not having configured the initramfs properly, but after booting with a rescue disk and chrooting I'm not able to rebuild it or to run grub-install. The problem seems to be an inability to write to the relevant block device, e.g.

Code:

livecd src # grub-install /dev/sda
Installing for i386-pc platform.
mdadm: cannot open /dev/md0: Operation not permitted
grub-install: error: cannot open `/dev/md0': Operation not permitted.


genkernel is similar:

Code:

DEPMOD  4.4.21-gentoo
*         >> Generating module dependency data...
* Copying config for successful build to /etc/kernels/kernel-config-x86_64-4.4.21-gentoo
* busybox: >> Using cache
* initramfs: >> Initializing...
*         >> Appending base_layout cpio data...
* Gentoo Linux Genkernel; Version 3.4.52.4
* Running with options: --oldconfig --install --disklabel --mdadm --mdadm-config=/etc/mdadm.conf all
* Using genkernel.conf from /etc/genkernel.conf
* Sourcing arch-specific config.sh from /usr/share/genkernel/arch/x86_64/config.sh ..
* Sourcing arch-specific modules_load from /usr/share/genkernel/arch/x86_64/modules_load ..

* ERROR: failed to mknod
*
* -- Grepping log... --
*
*
* -- End log... --


The setup of the system is as follows:

Code:

/dev/md0 => / (/dev/sda2, /dev/sdb2)
/dev/md1 => /home (/dev/sda4, /dev/sdb4)


...there's no separate boot partition.

If anyone has any suggestions as to how to proceed I'd be grateful for them.


Last edited by knirirr on Mon Oct 24, 2016 11:52 am; edited 1 time in total
Back to top
View user's profile Send private message
knirirr
n00b
n00b


Joined: 20 Jan 2010
Posts: 33

PostPosted: Mon Oct 24, 2016 11:52 am    Post subject: Reply with quote

I finally got this to work - it seems that the boot CD I was using was a bit too old and replacing it with a newer one fixed the problem writing to /dev/md0.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum