Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge fails for Plymouth on fresh install (nomultilib)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Unb0rn
n00b
n00b


Joined: 12 Jun 2012
Posts: 63

PostPosted: Fri Oct 28, 2016 12:24 pm    Post subject: Emerge fails for Plymouth on fresh install (nomultilib) Reply with quote

Hello! I'm trying to emerge Plymouth (using Sakaki's guide) using nomultilib tarball and portage profile, only using systemd, udev (as in system'd profile) and wayland as global USE flags. Emerge of Plymouth fails with
/var/tmp/portage/sys-boot/plymouth-0.9.2/work/plymouth-0.9.2/src/plugins/renderers/x11/plugin.c:51:22: fatal error gdk/gdkx.h: No such file or directory #include <gdk/gdkx.h> compilation terminated.
Also, according to guide I'm trying to emerge plymouth with gdm local flag(if this info helps)
GTK+3.20 emerged normally.
Any ideas? Thanks!
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Fri Oct 28, 2016 8:09 pm    Post subject: Reply with quote

Which guide are you using? url to the guide please => reference is missing
how do you install it? instructions are missing. Where is the ebuild from ? from an overlay? official portage tree? ...
Back to top
View user's profile Send private message
Unb0rn
n00b
n00b


Joined: 12 Jun 2012
Posts: 63

PostPosted: Fri Oct 28, 2016 8:58 pm    Post subject: Reply with quote

I am using thisguide and trying to compile Plymouth from official Gentoo portage tree. Tried to do it exactly as it is described in the guide-added USE flags to package.use (gdm to plymouth, libkms to libdrm and cryptsetup, gpg and plymouth to genkernel-next), and then tried to emerge listed packages via "emerge --ask --verbose sys-kernel/buildkernel app-crypt/efitools", buildkernel here is a script from sakaki's git overlay, which, in turn relies on genkernel-next.
Everything was good until plymouth emerge in queue-it faild with an error from my first post.
Back to top
View user's profile Send private message
Unb0rn
n00b
n00b


Joined: 12 Jun 2012
Posts: 63

PostPosted: Wed Nov 02, 2016 5:50 pm    Post subject: Reply with quote

The problem was in missing X use flag. It installed successfully with it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum