Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
no modules after install [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Efo
Guru
Guru


Joined: 23 Jun 2005
Posts: 420

PostPosted: Sat Oct 29, 2016 1:30 am    Post subject: no modules after install [SOLVED] Reply with quote

Hi guys,

I got a new laptop and I followed the manual instructions (EFI). The machine boots fine, but I have no usb device (/dev/sdb) nor ethernet nor wifi cards.

ifconfig -a gives my "lo" and "sit0"

I believe the modules are not present/loaded; did I miss something during installation?

In boot I have initramfs. kernel, and system (along with EFI and grub directories); I used genkernel to generate all of them.

last piece of info: systemrescuecd was able to load all of the above (not the graphic card though, but this is the next step).

As usual any help is immensly welcome.

Thanks,

Efo


Last edited by Efo on Sat Oct 29, 2016 2:58 am; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7132
Location: almost Mile High in the USA

PostPosted: Sat Oct 29, 2016 1:50 am    Post subject: Reply with quote

Is the directory /lib/modules/(your_kernel) populated from make modules_install ?
You could try modprobe <module you want> and see if that works.

Make sure you followed this step if it did not get installed:

https://wiki.gentoo.org/wiki/Handbook:AMD64/Full/Installation#Compiling_and_installing
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Efo
Guru
Guru


Joined: 23 Jun 2005
Posts: 420

PostPosted: Sat Oct 29, 2016 1:55 am    Post subject: Reply with quote

Hi eccerr0r,

Thank you for the prompt reply.
I followed those steps... btw, now I got ethernet working (enabled the right module in the kernel :)

I am still puzzled about /dev/sdb ... could it be a missing module too?
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7132
Location: almost Mile High in the USA

PostPosted: Sat Oct 29, 2016 1:58 am    Post subject: Reply with quote

To get your USB mass storage devices working you'll need the usb mass storage (usb-storage) and scsi (sd_mod) -- but sd_mod is needed for libata drivers so likely you already have them compiled. You'll also need your USB host adapter driver compiled - this depends on your USB implementation. What hardware do you have?

How much of the USB is working? any other USB devices working?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Efo
Guru
Guru


Joined: 23 Jun 2005
Posts: 420

PostPosted: Sat Oct 29, 2016 2:12 am    Post subject: Reply with quote

USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)

grep -i usb .config | grep y

Code:
CONFIG_USB_NET_DRIVERS=y
CONFIG_SND_USB=y
CONFIG_USB_HID=y
CONFIG_USB_HIDDEV=y
CONFIG_USB_OHCI_LITTLE_ENDIAN=y
CONFIG_USB_SUPPORT=y
CONFIG_USB_COMMON=y
CONFIG_USB_ARCH_HAS_HDC=y
CONFIG_USB=y
CONFIG_USB_ANNOUNCE_NEW_DEVICES=y
CONFIG_USB_DEFAULT_PERSIST=y
CONFIG_USB_MON=y
CONFIG_USB_EHCI_HCD=y
CONFIG_USB_EHCI_TT_NEWSCHED=y
CONFIG_USB_EHCI_PCI=y
CONFIG_USB_OHCI_HCD=y
CONFIG_USB_OHCI_HCD_PCI=y
CONFIG_USB_UHCI_HCD=y
CONFIG_USB_PRINTER=y
CONFIG_USB_STORAGE=y


There may be typos since I have copied the above from a screen :)

Not sure how much USB is working, just working in console right now..
Back to top
View user's profile Send private message
Efo
Guru
Guru


Joined: 23 Jun 2005
Posts: 420

PostPosted: Sat Oct 29, 2016 2:49 am    Post subject: Reply with quote

USB is up, I didnt have USB 3 enabled in the kernel
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum