Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Conflict resolution not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
pixel27
n00b
n00b


Joined: 10 May 2016
Posts: 4

PostPosted: Wed Nov 09, 2016 1:15 am    Post subject: Conflict resolution not working Reply with quote

I have app-editors/atom installed and am trying to install dev-vcs/gitg and I get:

Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libgit2:0

  (dev-libs/libgit2-0.23.4:0/23::gentoo, installed) pulled in by
    =dev-libs/libgit2-0.23*:0/23=[ssh] required by (app-editors/atom-1.10.2:0/0::gentoo, installed)
    ^                 ^^^^^^^^^^^                                                                                                                                           
    (and 1 more with the same problem)

  (dev-libs/libgit2-0.24.2:0/24::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libgit2-0.24.0:0/24[ssh?] required by (dev-libs/libgit2-glib-0.24.4:0/0::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^^^^^                                                                                                                                       


According to https://wiki.gentoo.org/wiki/Troubleshooting#Dependency_graph_slot_conflicts I need to one shot libgit2...so I do:

Code:
emerge --ask --oneshot =dev-libs/libgit2-0.24.2


But then I get:

Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libgit2:0

  (dev-libs/libgit2-0.24.2:0/24::gentoo, ebuild scheduled for merge) pulled in by
    =dev-libs/libgit2-0.24.2 (Argument)

  (dev-libs/libgit2-0.23.4:0/23::gentoo, installed) pulled in by
    =dev-libs/libgit2-0.23*:0/23=[ssh] required by (app-editors/atom-1.10.2:0/0::gentoo, installed)
    ^                 ^^^^^^^^^^^                                                                                                                                       


Which is basically the same error...so I'm guessing that's not right? Any clues at what I need to do?
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13845

PostPosted: Wed Nov 09, 2016 2:11 am    Post subject: Reply with quote

I interpret that output to mean that, in order to fulfill your request to install dev-vcs/gitg, Portage needs to install supporting package dev-libs/libgit2-glib. That package requires >=dev-libs/libgit2-0.24.0, but your currently installed app-editors/atom can only handle libgit2-0.23*. You should upgrade app-editors/atom to a newer version which supports >=dev-libs/libgit2-0.24.0 or, if no such atom exists, uninstall it.
Back to top
View user's profile Send private message
pixel27
n00b
n00b


Joined: 10 May 2016
Posts: 4

PostPosted: Wed Nov 09, 2016 12:51 pm    Post subject: Reply with quote

I see so what you are saying is there is no conflict resolution, if you want to install two packages that depend on different versions of a library, you are just out of luck. Not the answer I was hoping for...does this happen often to people?
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Wed Nov 09, 2016 1:33 pm    Post subject: Reply with quote

I do get the same on ~amd64.

Only advise:

You may try to create your own ebuild for app-editors/atom-1.10.2:0/0::gentoo and rise the dependencies to >=dev-libs/libgit2-0.24.0:0/24[ssh?] and see if the editor still is functional.
Back to top
View user's profile Send private message
guitou
Guru
Guru


Joined: 02 Oct 2003
Posts: 400
Location: France

PostPosted: Wed Nov 09, 2016 1:43 pm    Post subject: Reply with quote

Hello.

I may be wrong, but I think this is not a dependency conflict but a flag requirement. gitg wants libgit to be built with ssl use flag.

++
Gi)
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13845

PostPosted: Thu Nov 10, 2016 2:20 am    Post subject: Reply with quote

pixel27 wrote:
I see so what you are saying is there is no conflict resolution, if you want to install two packages that depend on different versions of a library, you are just out of luck. Not the answer I was hoping for...does this happen often to people?
No, usually upstream is pretty good about updating their code to work with newer libraries. The atom developers seem quite proud of themselves that they built a desktop application using browser technologies (thus making it "more portable"), so it seems quite strange that they would then use dev-libs/libgit2 in a way that pins them to specific versions.

See app-editors/atom-1.10.2: dev-libs/libgit2 dependency locked to a specific version and causing update blockers for discussion and possible workarounds.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5761

PostPosted: Thu Nov 10, 2016 5:50 am    Post subject: Reply with quote

Nasty, hacky solution but worth a try:
  • Copy the .so files from libgit2 to /usr/lib/atom/
  • Put that exact version (dev-libs/libgit2-0.23.4:0/23) in package.provided
  • Quickpkg libgit2, uninstall it and verify atom still runs
  • You should be able to install gitg now and have both at the same time
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum