Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Stuck at grub screen with nvidia-drivers
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
yyt16384
n00b
n00b


Joined: 21 Jun 2015
Posts: 9

PostPosted: Sat Nov 12, 2016 3:38 pm    Post subject: [Solved] Stuck at grub screen with nvidia-drivers Reply with quote

I'm trying to move from nouveau to nvidia-drivers today, and when I reboot, nothing is displayed after the "Loading initial ramdisk" screen. That is, nothing else will display no matter what I do. The system still boots properly, as I can ssh into it just fine.

I've disabled nouveau in kernel and tried with DRM either enabled or disabled.

There are no errors in dmesg, and lspci -k shows that the nvidia kernel driver is being used.


Last edited by yyt16384 on Sun Nov 13, 2016 5:01 am; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7133
Location: almost Mile High in the USA

PostPosted: Sat Nov 12, 2016 4:59 pm    Post subject: Reply with quote

You probably disabled the VGA console options when building a new kernel. It's still needed to get to text mode.

CONFIG_VGA_CONSOLE=y
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
yyt16384
n00b
n00b


Joined: 21 Jun 2015
Posts: 9

PostPosted: Sat Nov 12, 2016 5:26 pm    Post subject: Reply with quote

eccerr0r wrote:
You probably disabled the VGA console options when building a new kernel. It's still needed to get to text mode.

CONFIG_VGA_CONSOLE=y


It is already enabled in the new kernel.
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7133
Location: almost Mile High in the USA

PostPosted: Sat Nov 12, 2016 5:55 pm    Post subject: Reply with quote

Is CONFIG_VT_CONSOLE=y still the case?
Do you have a EFI machine?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
yyt16384
n00b
n00b


Joined: 21 Jun 2015
Posts: 9

PostPosted: Sat Nov 12, 2016 6:45 pm    Post subject: Reply with quote

eccerr0r wrote:
Is CONFIG_VT_CONSOLE=y still the case?
Do you have a EFI machine?


CONFIG_VT_CONSOLE is also enabled, and yes, this is an EFI machine.
Back to top
View user's profile Send private message
yyt16384
n00b
n00b


Joined: 21 Jun 2015
Posts: 9

PostPosted: Sat Nov 12, 2016 6:47 pm    Post subject: Reply with quote

eccerr0r wrote:
Is CONFIG_VT_CONSOLE=y still the case?
Do you have a EFI machine?


CONFIG_VT_CONSOLE is also enabled, and yes, this is an EFI machine.
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7133
Location: almost Mile High in the USA

PostPosted: Sat Nov 12, 2016 6:50 pm    Post subject: Reply with quote

Ah EFI may be a problem.

Then you need the EFI initial framebuffer options enabled, not VGA.

However I think you may be stuck with it like this, I don't know if the EFI framebuffer will conflict with nvidia-drivers.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
yyt16384
n00b
n00b


Joined: 21 Jun 2015
Posts: 9

PostPosted: Sun Nov 13, 2016 5:00 am    Post subject: Reply with quote

eccerr0r wrote:
Ah EFI may be a problem.

Then you need the EFI initial framebuffer options enabled, not VGA.

However I think you may be stuck with it like this, I don't know if the EFI framebuffer will conflict with nvidia-drivers.


Enableing CONFIG_FB_EFI solves the problem. Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum