Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
r600_dri.so missing [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
mgnut57
Apprentice
Apprentice


Joined: 12 Jan 2008
Posts: 190

PostPosted: Mon Nov 14, 2016 1:02 am    Post subject: r600_dri.so missing [Solved] Reply with quote

After getting help a little while ago which initially resulted in blocking xorg-1.18, I decided to do away with the closed-source ATI drivers and use the open-source Radeon driver. However, a few issues came up:

1. In order to get a usable display, I had to force the display resolution. It appeared that the screen extended to the left of the physical screen and because of this, I could not access the menus, etc.. So I forced a Monitor/Screen size in the xorg.conf.d directory. I thought that this should not be necessary today?

2. On starting X, the Xorg.0.log file shows this error:
Code:
[    36.355] (EE) AIGLX error: dlopen of /usr/lib64/dri/r600_dri.so failed (/usr/lib64/dri/r600_dri.so: cannot open shared object file: No such file or directory)

glxinfo shows a similar issue:
Code:
# glxinfo | more
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
name of display: :0
display: :0  screen: 0
direct rendering: Yes


Direct rendering appears to be active (see above). Is the missing r600_dri.so file a real issue and if so, how do I to fix it?


Last edited by mgnut57 on Tue Nov 15, 2016 6:04 am; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7134
Location: almost Mile High in the USA

PostPosted: Mon Nov 14, 2016 6:02 am    Post subject: Reply with quote

You'll need to make sure your VIDEO_CARDS is updated with r600 and re-emerge media-libs/mesa

And dangit I need another pcie machine that I can play wit the new radeon oss driver...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
mgnut57
Apprentice
Apprentice


Joined: 12 Jan 2008
Posts: 190

PostPosted: Mon Nov 14, 2016 6:22 am    Post subject: Reply with quote

Thanks. re-emerging mesa now.

Problem solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum