Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge corruption (komodo)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
qu3st
n00b
n00b


Joined: 25 Nov 2016
Posts: 3
Location: BTM

PostPosted: Fri Nov 25, 2016 1:11 pm    Post subject: emerge corruption (komodo) Reply with quote

Hi all,

I always found solution to problems with Gentoo but now after few days of searching I give up...
Week ago I installed Gentoo on new machine and when I try to install komodo-edit-bin from overlay sabayon-tools i get error masked by corruption. On other machine(with similar configuration) there are no problems with installation(or re-installation 'cause it was installed long time ago) from this overlay. I have no idea what is wrong. I tried eix-sync, emerge --sync, layman -S, re-adding overlay, re-install layman, etc... and nothing helped. Also if I try install older versions from different overlays (in ex. spike) it gives same results...


Code:

# emerge -pv komodo-edit-bin

These are the packages that would be merged, in order:

Calculating dependencies | * ERROR: app-editors/komodo-edit-bin-10.0.0::sabayon-tools failed (depend phase):
 *   use() calls are not allowed in global scope
 *
 * Call stack:
 *                       ebuild.sh, line 606:  Called source '/var/lib/layman/sabayon-tools/app-editors/komodo-edit-bin/komodo-edit-bin-10.0.0.ebuild'
 *   komodo-edit-bin-10.0.0.ebuild, line  29:  Called use 'amd64'
 *                       ebuild.sh, line  78:  Called die
 * The specific snippet of code:
 *              eval "${x}() { die \"\${FUNCNAME}() calls are not allowed in global scope\"; }"
 *
 * If you need support, post the output of `emerge --info '=app-editors/komodo-edit-bin-10.0.0::sabayon-tools'`,
 * the complete build log and the output of `emerge -pqv '=app-editors/komodo-edit-bin-10.0.0::sabayon-tools'`.
 * Working directory: '/usr/lib64/python3.4/site-packages'
 * S: '/var/tmp/portage/app-editors/komodo-edit-bin-10.0.0/work/komodo-edit-bin-10.0.0'
... done!

!!! All ebuilds that could satisfy "komodo-edit-bin" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-editors/komodo-edit-bin-10.0.0::sabayon-tools (masked by: corruption)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


and emerge --info:
Code:

Portage 2.3.0 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-4.9.3, glibc-2.22-r4, 4.4.26-gentoo x86_64)
=================================================================
System uname: Linux-4.4.26-gentoo-x86_64-Intel-R-_Core-TM-_i5-6200U_CPU_@_2.30GHz-with-gentoo-2.2
KiB Mem:     3898608 total,   1480484 free
KiB Swap:   10239996 total,   9371180 free
Timestamp of repository gentoo: Fri, 25 Nov 2016 12:00:01 +0000
sh bash 4.3_p48
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.3_p48::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.22.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/cmake:           3.5.2-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.21.7::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

sabayon-tools
    location: /var/lib/layman/sabayon-tools
    masters: gentoo
    priority: 0

vayerx
    location: /var/lib/layman/vayerx
    masters: gentoo
    priority: 1

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-11.x"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=broadwell -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=broadwell -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="rsync://gentoo.prz.rzeszow.pl/gentoo http://gentoo.prz.rzeszow.pl http://gentoo.po.opole.pl rsync://ftp.vectranet.pl/gentoo/ http://gentoo.mirror.pw.edu.pl/"
LANG="pl_PL.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 apache2 avi berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative divx4linux dri dts dvd dvdr emboss encode exif fam firefox flac fortran ftp gd gdbm gif glamor glx gpm gstreamer gtk hddtemp iconv ipv6 jpeg kde kipi lcms ldap libnotify lm_sensors mad mmx mmxext mng modules mp3 mp4 mpeg mplayer multilib mysql ncurses networkmanager nls nptl ogg opengl openmp pam pango pcre pdf pdo phonon plasma png policykit ppds qml qt3support qt4 qt5 quicktime readline samba sdl seccomp semantic-desktop session soap sound spell sse sse2 sse3 ssl sslstartup-notification ssse3 startup-notification svg tcpd tiff timidity truetype udev udisks unicode upower usb vorbis widgets wifi wxwidgets x264 xattr xcb xcomposite xine xinerama xinetd xml xscreensaver xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="pl" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pl" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON



Anyone have some ideas?

Thanks for your help.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7962
Location: ~Brussels - Belgique

PostPosted: Fri Nov 25, 2016 1:15 pm    Post subject: Reply with quote

Hi!,

This overlay (sabayon) is not related to Gentoo. Please contact the sabayon support team.

You can try to resync your orverlays and see if it goes better.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
qu3st
n00b
n00b


Joined: 25 Nov 2016
Posts: 3
Location: BTM

PostPosted: Fri Nov 25, 2016 1:23 pm    Post subject: Reply with quote

And it is no related to Gentoo configuration but to overlay that the same package from the same overlay works and installs perfectly on my another machine with the same system??? I tried resync overlays as I wrote above
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7962
Location: ~Brussels - Belgique

PostPosted: Fri Nov 25, 2016 1:26 pm    Post subject: Reply with quote

The ebuild is corrupted, this is why it is masked. You have to contact the maintainer of sabayon-tools, which depends on Sabayon (not Gentoo)

EDIT: this overlay is not related to sabayon, but an independant user: https://github.com/fusion809/sabayon-tools

I suggest you to remove this overlay and use the official portage tree.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum