Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201612-13 ] nghttp2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2189

PostPosted: Mon Dec 05, 2016 3:26 am    Post subject: [ GLSA 201612-13 ] nghttp2 Reply with quote

Gentoo Linux Security Advisory

Title: nghttp2: Denial of Service (GLSA 201612-13)
Severity: normal
Exploitable: remote
Date: December 05, 2016
Bug(s): #574780
ID: 201612-13

Synopsis

Nghttp2 is vulnerable to a Denial of Service attack.

Background

Nghttp2 is an implementation of HTTP/2 and its header compression
algorithm HPACK in C.


Affected Packages

Package: net-libs/nghttp2
Vulnerable: < 1.7.1
Unaffected: >= 1.7.1
Architectures: All supported architectures


Description

Nghttpd, nghttp, and libnghttp2_asio applications do not limit the
memory usage for the incoming HTTP header field. If a peer sends a
specially crafted HTTP/2 HEADERS frame and CONTINUATION frame, they will
crash with an out of memory error.


Impact

A remote attacker could possibly cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All nghttp2 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-libs/nghttp2-1.7.1"
   


References

CVE-2016-1544
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum