Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Calibre] Fusion fichiers impossible (bug)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 744
Location: S.O. France

PostPosted: Tue Dec 13, 2016 1:00 pm    Post subject: [Calibre] Fusion fichiers impossible (bug) Reply with quote

Bonjour,

J'ai ouvert un bug car j'ai un problème de fusion de fichier dans l'édition d'un epub.
Ce bug, je ne l'ai que sur ma session plasma. Sous gnome ça fonctionne.

En mettant les emerge --info sur le bug, et après un emerge -e @world sous plasma je me suis rendu compte que ma version active de python sous gnome est la 3.4.5 alors que sous plasma c'est la 2.7.12.

Donc sous plasma un petit eselect python pour basculer sous python 3.4.5 par défaut.
Par contre python-updater n'existe plus et emerge -uDNvp @world ne veut rien changer (d'après le wiki rien de plus à faire).

Y'a moyen de recompiler tout les paquets qui dépendent de python hormis le emerge -e @world?
Est-ce que mon problème peut venir de là sachant que sur les 2 machines j'ai les 2 versions de python?
J'ai du mal à saisir l'utilité du "python défaut" puisque à priori les paquets sont compilés avec les 2 versions.

Sinon quelqu'un sous plasma peut-il me dire si sa marche?

Merci


Last edited by sebB on Thu Dec 15, 2016 3:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1699
Location: 127.0.0.1

PostPosted: Tue Dec 13, 2016 1:57 pm    Post subject: Re: [Python] Recompiler paquets suite changement de version Reply with quote

Salut,

sebB wrote:

Y'a moyen de recompiler tout les paquets qui dépendent de python hormis le emerge -e @world?

Code:

$ emerge -pv1 /usr/lib*/python*

Quote:

J'ai du mal à saisir l'utilité du "python défaut" puisque à priori les paquets sont compilés avec les 2 versions.

De nos jours oui. À l'époque : beaucoup de progs python avaient un shebang « #!/usr/bin/env python », ce qui doit être relativement rare aujourd'hui.
Pour le reste, aucune idée.
Back to top
View user's profile Send private message
brokenHeart
n00b
n00b


Joined: 15 May 2013
Posts: 35
Location: versailles

PostPosted: Wed Dec 14, 2016 9:41 am    Post subject: Reply with quote

Hello,

j'ai eu pas mal de problèmes de compilation de python que je n'arrivais pas à contourner jusqu'à ce que je lise dans les news :

Code:
2015-12-16-python-abiflags-rebuild-needed
  Title                     Python ABIFLAGS rebuild needed
  Author                    Mike Gilbert <floppym@gentoo.org>
  Posted                    2015-12-16
  Revision                  5

For several years, Gentoo has been patching python3 in a way that is
incompatible with PEP 3149 [1]. Gentoo has been enabling the PyMalloc feature,
but our python packages have not carried the appropriate ABI flag.

We have removed this patch from the most recent dev-lang/python ebuilds at
the time of this writing. One result of this is that any packages which
install python extension modules must be rebuilt.

You may experience build failures in related packages until this rebuild has
been completed.

You can rebuild affected packages using the following commands.

emerge -1v $(find /usr/lib*/python3* -name '*cpython-3[3-5].so')
emerge -1v /usr/include/python3.{3,4,5}

It is possible that these commands will do nothing (or display a syntax error)
if all affected packages have already been rebuilt, causing the relevent files
to no longer exist.

References:
[1] https://www.python.org/dev/peps/pep-3149/


Est-ce que cela peut aider ?
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 744
Location: S.O. France

PostPosted: Wed Dec 14, 2016 5:50 pm    Post subject: Reply with quote

Merci à vous deux
Code:
emerge -pv1 /usr/lib*/python*

Ca m'a recompilé tous les paquets qui dépendent de python, cependant ca n'a rien changé à mon problème sous calibre.

J'ai fouillé du coté des USE entre les 2 profils sur les dépendances de calibre.
Y'a 2 ou 3 diff mais mais si je les virent, je pete plasma.

Edit: Je viens de tester sous arch et meme probleme. Je relance mon bug.
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 366
Location: LENS

PostPosted: Thu Dec 15, 2016 2:13 pm    Post subject: Re: [Python] Recompiler paquets suite changement de version Reply with quote

sebB wrote:
En mettant les emerge --info sur le bug, et après un emerge -e @world sous plasma je me suis rendu compte que ma version active de python sous gnome est la 3.4.5 alors que sous plasma c'est la 2.7.12.


Je te propose de vérifier s'il n'y a pas une 3e version de python car chez moi, gentoo m'avais laissé une version fantome de python-3.3.5-r2 qui m'avait causé de nombreux soucis.

Par exemple fait un
Code:
# emerge -C =dev-lang/python-3.3.5-r2


Enfin pour recompiler les dépendances
Code:
# emerge @preserved-rebuild

_________________
Gentoo rocks
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 744
Location: S.O. France

PostPosted: Thu Dec 15, 2016 3:18 pm    Post subject: Reply with quote

Je n'ai que 2 versions de python.
En fait le bug calibre n'existe que sous plasma. Sous gnome et lxqt je n'ai pas ce soucis.
Sous archlinux c'est la même chose.

Je suis même plus sur que ce soit un problème avec python...

Je change le titre
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum