Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kernel-4.9.0] Seltsame Meldung im Kernellog
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Sun Dec 18, 2016 11:38 am    Post subject: [kernel-4.9.0] Seltsame Meldung im Kernellog Reply with quote

Hallo Zusammen,

seit dem Update auf kernel-4.9.0 habe ich im Kernellog folgende Meldung stehen:

Code:
[    6.887503] ------------[ cut here ]------------
[    6.887508] WARNING: CPU: 0 PID: 383 at drivers/usb/core/hcd.c:1584 usb_hcd_map_urb_for_dma+0x345/0x489
[    6.887508] transfer buffer not dma capable
[    6.887508] Modules linked in: udl udlfb btusb btrtl btbcm btintel bluetooth rfkill joydev cdc_acm fingervu(O) snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic mxm_wmi nvidia_drm(PO) nvidia_modeset(PO) nvidia(PO) coretemp x86_pkg_temp_thermal ddbridge(O) cxd2099(O) lnbp21(O) kvm_intel kvm stv0367dd(O) irqbypass tda18212dd(O) stv090x(O) drm_kms_helper stv6110x(O) aesni_intel mxl5xx(O) stv6111(O) drxk(O) aes_x86_64 drm glue_helper stv0910(O) lrw gf128mul lnbh25(O) i2c_i801 cxd2843(O) fb_sys_fops ablk_helper syscopyarea cryptd sysfillrect snd_pcsp i2c_smbus sysimgblt dvb_core(O) snd_hda_intel snd_hda_codec snd_hda_core e1000e snd_pcm snd_timer tpm_infineon ptp tpm pps_core wmi video xhci_pci acpi_pad nct6775 hwmon_vid hwmon xhci_hcd
[    6.887536] CPU: 0 PID: 383 Comm: kworker/0:1 Tainted: P           O    4.9.0-gentoo #1
[    6.887536] Hardware name: ASUS All Series/Z97-PRO(Wi-Fi ac), BIOS 2205 02/12/2015
[    6.887539] Workqueue: events dlfb_init_framebuffer_work [udlfb]
[    6.887540]  ffffc90000a6bba0 ffffffff813ce4af ffffc90000a6bbf0 0000000000000000
[    6.887542]  ffffc90000a6bbe0 ffffffff81043004 0000063000a6bc58 ffff88042c9bb780
[    6.887543]  ffff88042913c000 0000000000000001 0000000002400000 0000000000000000
[    6.887545] Call Trace:
[    6.887549]  [<ffffffff813ce4af>] dump_stack+0x4d/0x63
[    6.887552]  [<ffffffff81043004>] __warn+0xc0/0xdb
[    6.887554]  [<ffffffff81043065>] warn_slowpath_fmt+0x46/0x4e
[    6.887556]  [<ffffffff810f58eb>] ? alloc_vmap_area.isra.30+0x1fc/0x2c4
[    6.887558]  [<ffffffff8154fee8>] usb_hcd_map_urb_for_dma+0x345/0x489
[    6.887560]  [<ffffffff81550aa3>] usb_hcd_submit_urb+0x153/0x20f
[    6.887562]  [<ffffffff815518b1>] usb_submit_urb+0x433/0x448
[    6.887564]  [<ffffffff81551dbc>] usb_start_wait_urb+0x59/0xc9
[    6.887566]  [<ffffffffa0177a1c>] ? dlfb_setup_modes+0x487/0x4e0 [udlfb]
[    6.887568]  [<ffffffff81551ef2>] usb_control_msg+0xc6/0xeb
[    6.887570]  [<ffffffffa0178113>] dlfb_init_framebuffer_work+0x18f/0x26d [udlfb]
[    6.887573]  [<ffffffff810557b5>] process_one_work+0x195/0x29a
[    6.887575]  [<ffffffff81055e10>] worker_thread+0x27d/0x369
[    6.887577]  [<ffffffff81055b93>] ? rescuer_thread+0x2ab/0x2ab
[    6.887579]  [<ffffffff81052ad9>] ? call_usermodehelper_exec_async+0x11f/0x128
[    6.887580]  [<ffffffff81059ac0>] kthread+0xce/0xd6
[    6.887582]  [<ffffffff810599f2>] ? kthread_park+0x55/0x55
[    6.887583]  [<ffffffff810529ba>] ? umh_complete+0x20/0x20
[    6.887585]  [<ffffffff816b08b2>] ret_from_fork+0x22/0x30
[    6.887587] ---[ end trace bfb1a475daddb4e4 ]---


Ich konnte bisher allerdings nicht feststellen, dass etwas nicht funktionieren würde.

Hat Jemand eine Idee, woher das kommt, oder besser noch, wie man das fixt?
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2225
Location: Germany

PostPosted: Tue Dec 20, 2016 10:36 pm    Post subject: Reply with quote

Schaut seltsam aus. Aber ich bin heute in Knobel-Stimmung!

Zuerst dachte ich auch an eine Fehlermeldung, du hast du da ja oben eine von deinem USB-Subsystem das wohl eine USB-Hardware oder dein Kernel kein DMA kann (transfer buffer not dma capable).

Dann steht da in diesem Error-Trace auch genau welches Kernel-Modul das verursacht!

Quote:
[ 6.887536] CPU: 0 PID: 383 Comm: kworker/0:1 Tainted: P O 4.9.0-gentoo #1
[ 6.887536] Hardware name: ASUS All Series/Z97-PRO(Wi-Fi ac), BIOS 2205 02/12/2015
[ 6.887539] Workqueue: events dlfb_init_framebuffer_work [udlfb]
[ 6.887540] ffffc90000a6bba0 ffffffff813ce4af ffffc90000a6bbf0 0000000000000000
[ 6.887542] ffffc90000a6bbe0 ffffffff81043004 0000063000a6bc58 ffff88042c9bb780


Weil ich natürlich nicht wusste was udlfb für ein Modul ist, habe ich die Suchmaschine benutzt und die sagte was das ist...

ich muss mir angewähnen das direkt in den Kernel-Quellen zu suchen immerhin haben wir die ja immer installiert!

Da ist die Datei: /usr/src/linux/drivers/video/fbdev/udlfb.c da steht das drin:
Code:
Framebuffer driver for DisplayLink USB controller


Schlussfolgerung: Entweder unterstützt dein USB-Display-Adapter das nicht, oder du brauchst das Ding vielleicht gar nicht und kannst das dann einfach heraus werfen... ;)

Na ich meine du wirst schon wissen warum du das Einsetzt und benutzt. Vielleicht sind es aber auch Alterserscheingung des Adapters, oder das war schon immer so aber der Kernel war bei den Fehlermeldungen nicht so gesprächig. Aber es beruhigt ja schon ungemein wenn man das halbwegs zuordnen kann.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum