Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
TeX Live 2016 installer
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
mkdong
n00b
n00b


Joined: 15 Jan 2017
Posts: 3

PostPosted: Sun Jan 15, 2017 11:30 am    Post subject: TeX Live 2016 installer Reply with quote

Hi everyone :)

I want to install the latest version of TeX Live package (2016 version).
However the latest version available in official portage tree is 2015-r1 :(

I then tried to write a simple ebuild file which will invoke the TeX Live installer provided by tug.org, but I got confused how to set TEXDIR.
And I am also curious why ebuild doesn't use `chroot`(like in Arch) which can prevent a lot of path configuration.

Anyone has good idea how to get the latest TeX Live package using portage?

Thanks in advance :)
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2601

PostPosted: Sun Jan 15, 2017 11:57 am    Post subject: Re: TeX Live 2016 installer Reply with quote

mkdong wrote:
Anyone has good idea how to get the latest TeX Live package using portage?
What happens if you simply versionbump the ebuild(s) you need?
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6279

PostPosted: Sun Jan 15, 2017 4:27 pm    Post subject: Re: TeX Live 2016 installer Reply with quote

mkdong wrote:
Anyone has good idea how to get the latest TeX Live package using portage?

The state of TeX in gentoo is really a mess: There is an open bug, but despite people offered help, the Gentoo TeX maintainers didn't give any comment for almost a year.
Perhaps the gentoo TeX team is just one person, and this person is de facto retired?
I decided to give it another few months, but if the situation does not change, it seems one has to declare gentoo maintenance as dead and has to look for another distribution...

To your particular question: I would not recommend rolling your own ebuild. There is a lot of work to do this correctly, in particular:
Quote:
why ebuild doesn't use `chroot`

Because it is not the correct way to use an external installer which throws a huge bulk of bundled libs on the disk instead of using the installed ones. This is not only inefficient concerning duplication of libs (on disk as well as in memory at runtime). It also can cause all sort of subtle bugs when mixing various versions of the same lib at runtime. Last but not least, it also is a security issue unless all installed libs are audited by the texlive maintainers in the same scrupulous manner and speed as it is done (or should be done, at least) for the whole gentoo linux distribution (where a lot of maintainers care about the libs). In addition, the bundles libs might use things which you had particularly decided to not install of your system (e.g. dbus might be such an example), because USE-flags are not respected by bundled libs.
The correct (Gentoo) way of installing is to debundle all libs and adapt all paths to your true system's paths: This gives something which is not only running "by accident" in a sandbox but which integrates smoothly into the wohle system.
Back to top
View user's profile Send private message
mkdong
n00b
n00b


Joined: 15 Jan 2017
Posts: 3

PostPosted: Mon Jan 16, 2017 4:34 am    Post subject: Re: TeX Live 2016 installer Reply with quote

charles17 wrote:
mkdong wrote:
Anyone has good idea how to get the latest TeX Live package using portage?
What happens if you simply versionbump the ebuild(s) you need?

There are too many related packages and update them one by one is really a lot of work. :(
Back to top
View user's profile Send private message
mkdong
n00b
n00b


Joined: 15 Jan 2017
Posts: 3

PostPosted: Mon Jan 16, 2017 4:38 am    Post subject: Re: TeX Live 2016 installer Reply with quote

@mv. Thank you for your reply. And maybe I should stick with the 2015 for now.
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1695

PostPosted: Mon Jan 16, 2017 5:25 am    Post subject: Reply with quote

I suspect 2017 will be released in a couple months, so I wouldn't worry too much more on 2016 version....
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6279

PostPosted: Mon Jan 16, 2017 7:29 pm    Post subject: Reply with quote

ct85711 wrote:
I suspect 2017 will be released in a couple months, so I wouldn't worry too much more on 2016 version....

Given the reaction so far, I'd be surprised if 2017 will end up in the tree ever. As mentioned: It seems that gentoo maintenance is abandoned.
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1695

PostPosted: Mon Jan 16, 2017 7:53 pm    Post subject: Reply with quote

oh, I agree mv in my doubts if 2017 will even see any more activity than 2016 did. I've been noticing that general maintenance has been going down hill for a while on packages, with the exception for systemd related ones. Anymore, this is more discouraging than anything else that devs are not bothering to care anymore. Maybe after 2017 I'll decide if I will install that version out of portage or make a ebuild to install it (it's not going to use the typical of unbundling dependencies and stuff, more of everything in one).
Back to top
View user's profile Send private message
Wallsandfences
Guru
Guru


Joined: 29 Mar 2010
Posts: 354

PostPosted: Tue Jan 17, 2017 10:20 pm    Post subject: Reply with quote

This is a pity because tex is one of the strongest arguments for using linux and the coolest program ever written (or is there another prgram that is no longer worked on because 'it's finished' and still up to date?) from a programmer with style, attitude and humanity. Please those of you who are capable don't let it slip away!
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1695

PostPosted: Tue Jan 17, 2017 11:48 pm    Post subject: Reply with quote

Oh, texlive isn't dieing off as upstream is still working on it and still quite active. Right now, it is more of the devs here either lost interest or don't have time to work on remaking the ebuilds. Now there is several packages that can be classified on not being worked on because it works; though TexLive is not one. Going through the release notes, there isn't too big of changed for the 2016 version, except on the LuaTex side and a little on the PdfTex end.
Back to top
View user's profile Send private message
Wallsandfences
Guru
Guru


Joined: 29 Mar 2010
Posts: 354

PostPosted: Wed Jan 18, 2017 7:48 am    Post subject: Reply with quote

Yes, I'm aware the ball is in our field. But since gentoo is my favorite way bundling gnu/linux (by a big margin) ....
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6279

PostPosted: Wed Jan 18, 2017 8:01 am    Post subject: Reply with quote

ct85711 wrote:
Oh, texlive isn't dieing off as upstream is still working on it and still quite active.

I was referring to the gentoo maintenance. I consider this a really serious issue; therefore I opened a discussion on this maintenance topic.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10211
Location: Somewhere over Atlanta, Georgia

PostPosted: Tue Jan 24, 2017 7:34 pm    Post subject: Reply with quote

Well, what do you know: texlive-2015 just went stable and texlive-2016 is in the tree in testing branch. :D

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1177
Location: Stuttgart, Germany

PostPosted: Tue Jan 24, 2017 9:49 pm    Post subject: Reply with quote

It did! And I get a bunch of bizarre blockers:

Code:
## emerge -pu texlive

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/ptexenc-1.3.4_p20160523 [1.3.3_p20150521]
[ebuild     U  ] app-text/dvipsk-5.996_p20160523 [5.995_p20150521]
[ebuild     U  ] dev-tex/bibtexu-3.71_p20160523 [3.71_p20150521]
[ebuild     U  ] app-text/ps2pkm-1.8_p20160523 [1.7_p20150521]
[ebuild     U  ] app-text/texlive-core-2016 [2015-r1]
[ebuild     U  ] dev-texlive/texlive-basic-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-genericrecommended-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-fontutils-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-langgerman-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-fontsrecommended-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-latex-2016 [2015]
[ebuild  N     ] dev-texlive/texlive-mathscience-2016  USE="-doc -source"
[ebuild     U  ] dev-texlive/texlive-xetex-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-latexrecommended-2016 [2015-r1]
[ebuild     U  ] app-text/texlive-2016 [2015]
[blocks B      ] <dev-texlive/texlive-langgreek-2016 ("<dev-texlive/texlive-langgreek-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-langenglish-2016 ("<dev-texlive/texlive-langenglish-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-langfrench-2016 ("<dev-texlive/texlive-langfrench-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-langgerman-2016 ("<dev-texlive/texlive-langgerman-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-basic-2016 ("<dev-texlive/texlive-basic-2016" is blocking dev-texlive/texlive-langgerman-2016)
[blocks B      ] <dev-texlive/texlive-basic-2016 ("<dev-texlive/texlive-basic-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] dev-texlive/texlive-science ("dev-texlive/texlive-science" is blocking dev-texlive/texlive-mathscience-2016)
[blocks B      ] <dev-texlive/texlive-langcjk-2016 ("<dev-texlive/texlive-langcjk-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-langarabic-2016 ("<dev-texlive/texlive-langarabic-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-latex-2016 ("<dev-texlive/texlive-latex-2016" is hard blocking dev-texlive/texlive-latex-2016)
[blocks B      ] dev-texlive/texlive-mathextra ("dev-texlive/texlive-mathextra" is blocking dev-texlive/texlive-mathscience-2016, dev-texlive/texlive-latexrecommended-2016)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-texlive/texlive-langgreek-2015:0/0::gentoo, installed) pulled in by
    dev-texlive/texlive-langgreek required by @selected

  (dev-texlive/texlive-langarabic-2015:0/0::gentoo, installed) pulled in by
    dev-texlive/texlive-langarabic required by @selected

  (dev-texlive/texlive-langenglish-2015:0/0::gentoo, installed) pulled in by
    dev-texlive/texlive-langenglish required by @selected

  (dev-texlive/texlive-langcjk-2015:0/0::gentoo, installed) pulled in by
    dev-texlive/texlive-langcjk required by @selected

  (dev-texlive/texlive-basic-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-xetex-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2012 required by (dev-texlive/texlive-langhebrew-2012:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2016 required by (app-text/texlive-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2015 required by (dev-texlive/texlive-genericextra-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2015 required by (dev-texlive/texlive-pstricks-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2015 required by (dev-texlive/texlive-luatex-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-fontsrecommended-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2012 required by (dev-texlive/texlive-langlatin-2012:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-fontutils-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2015 required by (dev-texlive/texlive-metapost-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-genericrecommended-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2015 required by (dev-texlive/texlive-fontsextra-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2015 required by (dev-texlive/texlive-pictures-2015-r2:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2012 required by (dev-texlive/texlive-langdutch-2012:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2015 required by (dev-texlive/texlive-langarabic-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2015 required by (dev-texlive/texlive-langfrench-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-latex-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2015 required by (dev-texlive/texlive-langgreek-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2015 required by (dev-texlive/texlive-langenglish-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2015 required by (dev-texlive/texlive-langcjk-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-langgerman-2016:0/0::gentoo, ebuild scheduled for merge)

  (dev-texlive/texlive-langfrench-2015:0/0::gentoo, installed) pulled in by
    dev-texlive/texlive-langfrench required by @selected

  (dev-texlive/texlive-langgerman-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-texlive/texlive-langgerman required by @selected
    >=dev-texlive/texlive-langgerman-2016 required by (app-text/texlive-2016:0/0::gentoo, ebuild scheduled for merge)

  (dev-texlive/texlive-latex-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-texlive/texlive-latex-2015 required by (dev-texlive/texlive-bibtexextra-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-latex-2015 required by (dev-texlive/texlive-humanities-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-latex-2016 required by (app-text/texlive-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-latex-2015 required by (dev-texlive/texlive-music-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-latex-2015 required by (dev-texlive/texlive-publishers-2015:0/0::gentoo, installed)
    dev-texlive/texlive-latex required by (dev-tex/xcolor-2.11:0/0::gentoo, installed)
    >=dev-texlive/texlive-latex-2011 required by (dev-texlive/texlive-langcjk-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-latex-2016 required by (dev-texlive/texlive-mathscience-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-latex-2016 required by (dev-texlive/texlive-latexrecommended-2016:0/0::gentoo, ebuild scheduled for merge)

  (dev-texlive/texlive-mathscience-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-texlive/texlive-mathscience required by (dev-texlive/texlive-xetex-2016:0/0::gentoo, ebuild scheduled for merge)
    dev-texlive/texlive-mathscience required by (app-office/lyx-2.2.2:0/0::gentoo, installed)

  (dev-texlive/texlive-latexrecommended-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-texlive/texlive-latexrecommended-2015 required by (dev-texlive/texlive-latexextra-2015-r1:0/0::gentoo, installed)
    >=dev-texlive/texlive-latexrecommended-2016 required by (app-text/texlive-2016:0/0::gentoo, ebuild scheduled for merge)
    dev-texlive/texlive-latexrecommended required by (virtual/latex-base-1.0:0/0::gentoo, installed)
    dev-texlive/texlive-latexrecommended required by (dev-tex/pgf-3.0.1:0/0::gentoo, installed)


I'm not sure how to resolve this, other than by removing all of my texlive packages and remerging them. That seems not exactly what one normally thinks of as an "upgrade" though.

So what am I missing here? Why are packages that are obviously about to be updated causing hard blocks on other updates?

Cheers,

EE
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10211
Location: Somewhere over Atlanta, Georgia

PostPosted: Tue Jan 24, 2017 10:05 pm    Post subject: Reply with quote

Portage is a little bit broken regarding some types of dependency resolution right now. Try adding --backtrack=30 to your emerge command line.

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1177
Location: Stuttgart, Germany

PostPosted: Wed Jan 25, 2017 6:54 am    Post subject: Reply with quote

No joy. Tried a very specific merge of texlive packages, got this:

Code:
 # emerge -puD --backtrack=100 texlive-langfrench texlive-langcjk texlive-langenglish texlive-langgerman texlive-langgreek texlive-langarabic texlive-xetex texlive-langdutch texlive-langhebrew texlive-langlatin texlive-music texlive-humanities texlive texlive-basic texlive-metapost texlive-luatex

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/kpathsea-6.2.2_p20160523 [6.2.1_p20150521-r2]
[ebuild     U  ] virtual/ttf-fonts-1-r1 [1]
[ebuild     U  ] dev-libs/ptexenc-1.3.4_p20160523 [1.3.3_p20150521]
[ebuild     U  ] app-shells/bash-4.4_p11 [4.4_p5-r1]
[ebuild     U  ] sys-libs/zlib-1.2.11 [1.2.10]
[ebuild     U  ] dev-libs/libgcrypt-1.7.5-r1 [1.7.5]
[ebuild     U  ] sys-apps/ed-1.14.1 [1.13]
[ebuild     U  ] media-libs/freetype-2.7.1-r1 [2.7.1]
[ebuild     U  ] x11-libs/libICE-1.0.9-r1 [1.0.9]
[ebuild     U  ] x11-libs/libxkbcommon-0.7.1 [0.7.0]
[ebuild     U  ] app-text/dvipsk-5.996_p20160523 [5.995_p20150521]
[ebuild     U  ] dev-tex/bibtexu-3.71_p20160523 [3.71_p20150521]
[ebuild     U  ] app-text/ps2pkm-1.8_p20160523 [1.7_p20150521]
[ebuild     U  ] dev-libs/libuv-1.10.2 [1.10.0]
[ebuild     U  ] app-text/ttf2pk2-2.0_p20160523 [2.0_p20150521]
[ebuild     U  ] dev-util/ninja-1.7.2 [1.7.1]
[ebuild     U  ] dev-python/setuptools-33.1.1 [30.4.0]
[ebuild     U  ] media-libs/harfbuzz-1.4.2 [1.4.1]
[ebuild     U  ] app-eselect/eselect-mesa-0.0.10-r1 [0.0.10]
[ebuild     U  ] sys-apps/sed-4.3-r1 [4.3]
[ebuild     U  ] app-arch/tar-1.29-r3 [1.29-r2]
[ebuild     U  ] x11-themes/gtk-engines-adwaita-3.22.2 [3.20.2]
[ebuild     U  ] dev-libs/libtasn1-4.10 [4.9-r1] USE="-valgrind%"
[ebuild    fU  ] dev-java/oracle-jdk-bin-1.8.0.121 [1.8.0.112] USE="-commercial%"
[ebuild     U  ] dev-util/cmake-3.7.2 [3.7.1]
[ebuild     U  ] app-text/mupdf-1.10a [1.9a] USE="javascript%*"
[ebuild     U  ] app-text/texlive-core-2016 [2015-r1]
[ebuild     U  ] kde-frameworks/extra-cmake-modules-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kcoreaddons-5.30.1 [5.29.0]
[ebuild     U  ] kde-frameworks/kconfig-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/ki18n-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kwidgetsaddons-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kwindowsystem-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kdbusaddons-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/karchive-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kcodecs-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kitemviews-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kguiaddons-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kcrash-5.30.0 [5.29.0]
[ebuild     U  ] sys-devel/llvm-3.9.1-r1 [3.9.1]
[ebuild     U  ] sys-apps/util-linux-2.29.1 [2.29]
[ebuild     U  ] kde-frameworks/kdoctools-5.30.0 [5.29.0]
[ebuild     U  ] net-print/cups-2.2.2-r1 [2.2.1]
[ebuild     U  ] net-print/cups-filters-1.13.3 [1.13.2]
[ebuild     U  ] sys-auth/polkit-0.113-r2 [0.113-r1] USE="(-elogind)"
[ebuild     U  ] kde-frameworks/kauth-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kconfigwidgets-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kiconthemes-5.30.0 [5.29.0]
[ebuild     U  ] dev-texlive/texlive-basic-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-genericrecommended-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-fontutils-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-langgerman-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-pictures-2016 [2015-r2]
[ebuild     U  ] dev-texlive/texlive-langfrench-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-langenglish-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-langgreek-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-metapost-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-fontsrecommended-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-pstricks-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-langarabic-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-luatex-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-langcjk-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-latex-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-latexrecommended-2016 [2015-r1]
[ebuild     U  ] dev-texlive/texlive-music-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-humanities-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-latexextra-2016 [2015-r1]
[ebuild  N     ] dev-texlive/texlive-mathscience-2016  USE="-doc -source"
[uninstall     ] dev-texlive/texlive-science-2015
[blocks b      ] dev-texlive/texlive-science ("dev-texlive/texlive-science" is blocking dev-texlive/texlive-mathscience-2016)
[ebuild     U  ] dev-texlive/texlive-xetex-2016 [2015]
[ebuild     U  ] app-text/texlive-2016 [2015]
[blocks B      ] dev-texlive/texlive-mathextra ("dev-texlive/texlive-mathextra" is blocking dev-texlive/texlive-latexrecommended-2016, dev-texlive/texlive-mathscience-2016)
[blocks B      ] <dev-texlive/texlive-basic-2016 ("<dev-texlive/texlive-basic-2016" is blocking dev-texlive/texlive-langfrench-2016, dev-texlive/texlive-langgerman-2016, dev-texlive/texlive-langarabic-2016, dev-texlive/texlive-langenglish-2016, dev-texlive/texlive-langgreek-2016, dev-texlive/texlive-langcjk-2016)
[blocks B      ] <dev-texlive/texlive-basic-2016 ("<dev-texlive/texlive-basic-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-xetex-2016 ("<dev-texlive/texlive-xetex-2016" is blocking dev-texlive/texlive-latexrecommended-2016, dev-texlive/texlive-langarabic-2016)
[blocks B      ] <dev-texlive/texlive-langgreek-2016 ("<dev-texlive/texlive-langgreek-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-langgerman-2016 ("<dev-texlive/texlive-langgerman-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-langarabic-2016 ("<dev-texlive/texlive-langarabic-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-langfrench-2016 ("<dev-texlive/texlive-langfrench-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-langenglish-2016 ("<dev-texlive/texlive-langenglish-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-langcjk-2016 ("<dev-texlive/texlive-langcjk-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-latex-2016 ("<dev-texlive/texlive-latex-2016" is hard blocking dev-texlive/texlive-latex-2016)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-texlive/texlive-basic-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-texlive/texlive-basic-2016 required by (app-text/texlive-2016:0/0::gentoo, ebuild scheduled for merge)
    texlive-basic
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-xetex-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2015 required by (dev-texlive/texlive-fontsextra-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-genericrecommended-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-fontsrecommended-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-fontutils-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-pictures-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-pstricks-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-luatex-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2012 required by (dev-texlive/texlive-langhebrew-2012:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2015 required by (dev-texlive/texlive-genericextra-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-metapost-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2012 required by (dev-texlive/texlive-langdutch-2012:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2012 required by (dev-texlive/texlive-langlatin-2012:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-langenglish-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-langgerman-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-langcjk-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-langarabic-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-latex-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-langgreek-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-langfrench-2016:0/0::gentoo, ebuild scheduled for merge)

  (dev-texlive/texlive-latexrecommended-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-texlive/texlive-latexrecommended required by (dev-tex/pgf-3.0.1:0/0::gentoo, installed)
    >=dev-texlive/texlive-latexrecommended-2016 required by (app-text/texlive-2016:0/0::gentoo, ebuild scheduled for merge)
    dev-texlive/texlive-latexrecommended required by (virtual/latex-base-1.0:0/0::gentoo, installed)
    >=dev-texlive/texlive-latexrecommended-2016 required by (dev-texlive/texlive-latexextra-2016:0/0::gentoo, ebuild scheduled for merge)

  (dev-texlive/texlive-langcjk-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-texlive/texlive-langcjk required by @selected
    texlive-langcjk

  (dev-texlive/texlive-latex-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-texlive/texlive-latex-2016 required by (dev-texlive/texlive-music-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-latex-2016 required by (app-text/texlive-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-latex-2015 required by (dev-texlive/texlive-bibtexextra-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-latex-2015 required by (dev-texlive/texlive-publishers-2015:0/0::gentoo, installed)
    dev-texlive/texlive-latex required by (dev-tex/xcolor-2.11:0/0::gentoo, installed)
    >=dev-texlive/texlive-latex-2016 required by (dev-texlive/texlive-humanities-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-latex-2016 required by (dev-texlive/texlive-latexrecommended-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-latex-2011 required by (dev-texlive/texlive-langcjk-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-latex-2016 required by (dev-texlive/texlive-mathscience-2016:0/0::gentoo, ebuild scheduled for merge)

  (dev-texlive/texlive-langgreek-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-texlive/texlive-langgreek required by @selected
    texlive-langgreek

  (dev-texlive/texlive-langarabic-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    texlive-langarabic
    dev-texlive/texlive-langarabic required by @selected

  (dev-texlive/texlive-langfrench-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    texlive-langfrench
    dev-texlive/texlive-langfrench required by @selected

  (dev-texlive/texlive-mathscience-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-texlive/texlive-mathscience required by (dev-texlive/texlive-xetex-2016:0/0::gentoo, ebuild scheduled for merge)
    dev-texlive/texlive-mathscience required by (app-office/lyx-2.2.2:0/0::gentoo, installed)

  (dev-texlive/texlive-langenglish-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    texlive-langenglish
    dev-texlive/texlive-langenglish required by @selected

  (dev-texlive/texlive-langgerman-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    texlive-langgerman
    >=dev-texlive/texlive-langgerman-2016 required by (app-text/texlive-2016:0/0::gentoo, ebuild scheduled for merge)
    dev-texlive/texlive-langgerman required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


Is there something I'm missing here? Is there a way to force an emerge to proceed regardless?

Cheers,

EE
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1695

PostPosted: Wed Jan 25, 2017 7:31 am    Post subject: Reply with quote

it appears, texlive-mathextra is holding you up, and appears that that package either hasn't been updated or something. So try removing that package and try again.
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1177
Location: Stuttgart, Germany

PostPosted: Wed Jan 25, 2017 10:32 am    Post subject: Reply with quote

nope :(

Code:
 # emerge -puD --backtrack=100 texlive-langfrench texlive-langcjk texlive-langenglish texlive-langgerman texlive-langgreek texlive-langarabic texlive-xetex texlive-langdutch texlive-langhebrew texlive-langlatin texlive-music texlive-humanities texlive texlive-basic texlive-metapost texlive-luatex

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/kpathsea-6.2.2_p20160523 [6.2.1_p20150521-r2]
[ebuild     U  ] virtual/ttf-fonts-1-r1 [1]
[ebuild     U  ] dev-libs/ptexenc-1.3.4_p20160523 [1.3.3_p20150521]
[ebuild     U  ] app-shells/bash-4.4_p11 [4.4_p5-r1]
[ebuild     U  ] sys-libs/zlib-1.2.11 [1.2.10]
[ebuild     U  ] dev-libs/libgcrypt-1.7.5-r1 [1.7.5]
[ebuild     U  ] sys-apps/ed-1.14.1 [1.13]
[ebuild     U  ] media-libs/freetype-2.7.1-r1 [2.7.1]
[ebuild     U  ] x11-libs/libICE-1.0.9-r1 [1.0.9]
[ebuild     U  ] x11-libs/libxkbcommon-0.7.1 [0.7.0]
[ebuild     U  ] app-text/ps2pkm-1.8_p20160523 [1.7_p20150521]
[ebuild     U  ] app-text/dvipsk-5.996_p20160523 [5.995_p20150521]
[ebuild     U  ] dev-tex/bibtexu-3.71_p20160523 [3.71_p20150521]
[ebuild     U  ] dev-libs/libuv-1.10.2 [1.10.0]
[ebuild     U  ] app-text/ttf2pk2-2.0_p20160523 [2.0_p20150521]
[ebuild     U  ] dev-python/appdirs-1.4.0-r1 [1.4.0]
[ebuild     U  ] dev-util/ninja-1.7.2 [1.7.1]
[ebuild     U  ] app-misc/pax-utils-1.2.2 [1.1.7]
[ebuild  N     ] dev-python/packaging-16.8  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5 -pypy -pypy3 -python3_4"
[ebuild  N     ] dev-python/pyparsing-2.1.10  USE="-doc -examples" PYTHON_TARGETS="python2_7 python3_5 -pypy -pypy3 -python3_4"
[ebuild     U  ] dev-python/setuptools-34.0.2-r1 [30.4.0]
[ebuild     U  ] media-libs/harfbuzz-1.4.2 [1.4.1]
[ebuild     U  ] app-eselect/eselect-mesa-0.0.10-r1 [0.0.10]
[ebuild     U  ] sys-apps/sed-4.3-r1 [4.3]
[ebuild     U  ] app-arch/tar-1.29-r3 [1.29-r2]
[ebuild     U  ] x11-themes/gtk-engines-adwaita-3.22.2 [3.20.2]
[ebuild     U  ] dev-libs/libtasn1-4.10 [4.9-r1] USE="-valgrind%"
[ebuild    fU  ] dev-java/oracle-jdk-bin-1.8.0.121 [1.8.0.112] USE="-commercial%"
[ebuild     U  ] dev-util/cmake-3.7.2 [3.7.1]
[ebuild     U  ] app-text/mupdf-1.10a [1.9a] USE="javascript%*"
[ebuild     U  ] app-text/texlive-core-2016 [2015-r1]
[ebuild     U  ] kde-frameworks/extra-cmake-modules-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kcoreaddons-5.30.1 [5.29.0]
[ebuild     U  ] kde-frameworks/kconfig-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/ki18n-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kwidgetsaddons-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kwindowsystem-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kdbusaddons-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/karchive-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kcodecs-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kitemviews-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kguiaddons-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kcrash-5.30.0 [5.29.0]
[ebuild     U  ] sys-devel/llvm-3.9.1-r1 [3.9.1]
[ebuild     U  ] sys-apps/util-linux-2.29.1 [2.29]
[ebuild     U  ] kde-frameworks/kdoctools-5.30.0 [5.29.0]
[ebuild     U  ] net-print/cups-2.2.2-r1 [2.2.1]
[ebuild     U  ] net-print/cups-filters-1.13.3 [1.13.2]
[ebuild     U  ] sys-auth/polkit-0.113-r2 [0.113-r1] USE="(-elogind)"
[ebuild     U  ] kde-frameworks/kauth-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kconfigwidgets-5.30.0 [5.29.0]
[ebuild     U  ] kde-frameworks/kiconthemes-5.30.0 [5.29.0]
[ebuild     U  ] dev-texlive/texlive-basic-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-genericrecommended-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-fontutils-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-langgerman-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-pictures-2016 [2015-r2]
[ebuild     U  ] dev-texlive/texlive-langfrench-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-langenglish-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-langgreek-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-metapost-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-fontsrecommended-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-pstricks-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-langarabic-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-luatex-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-langcjk-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-latex-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-latexrecommended-2016 [2015-r1]
[ebuild     U  ] dev-texlive/texlive-music-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-humanities-2016 [2015]
[ebuild     U  ] dev-texlive/texlive-latexextra-2016 [2015-r1]
[ebuild  N     ] dev-texlive/texlive-mathscience-2016  USE="-doc -source"
[uninstall     ] dev-texlive/texlive-science-2015
[blocks b      ] dev-texlive/texlive-science ("dev-texlive/texlive-science" is blocking dev-texlive/texlive-mathscience-2016)
[ebuild     U  ] dev-texlive/texlive-xetex-2016 [2015]
[ebuild     U  ] app-text/texlive-2016 [2015]
[blocks B      ] <dev-texlive/texlive-langarabic-2016 ("<dev-texlive/texlive-langarabic-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-basic-2016 ("<dev-texlive/texlive-basic-2016" is blocking dev-texlive/texlive-langcjk-2016, dev-texlive/texlive-langgerman-2016, dev-texlive/texlive-langgreek-2016, dev-texlive/texlive-langarabic-2016, dev-texlive/texlive-langenglish-2016, dev-texlive/texlive-langfrench-2016)
[blocks B      ] <dev-texlive/texlive-basic-2016 ("<dev-texlive/texlive-basic-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-langgerman-2016 ("<dev-texlive/texlive-langgerman-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-langcjk-2016 ("<dev-texlive/texlive-langcjk-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-xetex-2016 ("<dev-texlive/texlive-xetex-2016" is blocking dev-texlive/texlive-latexrecommended-2016, dev-texlive/texlive-langarabic-2016)
[blocks B      ] <dev-texlive/texlive-langgreek-2016 ("<dev-texlive/texlive-langgreek-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-latex-2016 ("<dev-texlive/texlive-latex-2016" is hard blocking dev-texlive/texlive-latex-2016)
[blocks B      ] <dev-texlive/texlive-langenglish-2016 ("<dev-texlive/texlive-langenglish-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-langfrench-2016 ("<dev-texlive/texlive-langfrench-2016" is hard blocking dev-texlive/texlive-basic-2016)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-texlive/texlive-langarabic-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-texlive/texlive-langarabic required by @selected
    texlive-langarabic

  (dev-texlive/texlive-langgreek-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    texlive-langgreek
    dev-texlive/texlive-langgreek required by @selected

  (dev-texlive/texlive-basic-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-metapost-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2012 required by (dev-texlive/texlive-langlatin-2012:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-pstricks-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-genericrecommended-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2015 required by (dev-texlive/texlive-genericextra-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-xetex-2016:0/0::gentoo, ebuild scheduled for merge)
    texlive-basic
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-fontutils-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2015 required by (dev-texlive/texlive-fontsextra-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2016 required by (app-text/texlive-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-luatex-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2012 required by (dev-texlive/texlive-langdutch-2012:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-pictures-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2012 required by (dev-texlive/texlive-langhebrew-2012:0/0::gentoo, installed)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-fontsrecommended-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-langgreek-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-langgerman-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-langcjk-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-langenglish-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-langfrench-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-latex-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-langarabic-2016:0/0::gentoo, ebuild scheduled for merge)

  (dev-texlive/texlive-langcjk-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    texlive-langcjk
    dev-texlive/texlive-langcjk required by @selected

  (dev-texlive/texlive-langfrench-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-texlive/texlive-langfrench required by @selected
    texlive-langfrench

  (dev-texlive/texlive-latex-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-texlive/texlive-latex-2016 required by (dev-texlive/texlive-mathscience-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-latex-2015 required by (dev-texlive/texlive-bibtexextra-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-latex-2015 required by (dev-texlive/texlive-publishers-2015:0/0::gentoo, installed)
    >=dev-texlive/texlive-latex-2016 required by (dev-texlive/texlive-music-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-latex-2016 required by (app-text/texlive-2016:0/0::gentoo, ebuild scheduled for merge)
    dev-texlive/texlive-latex required by (dev-tex/xcolor-2.11:0/0::gentoo, installed)
    >=dev-texlive/texlive-latex-2016 required by (dev-texlive/texlive-humanities-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-latex-2011 required by (dev-texlive/texlive-langcjk-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-latex-2016 required by (dev-texlive/texlive-latexrecommended-2016:0/0::gentoo, ebuild scheduled for merge)

  (dev-texlive/texlive-langgerman-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-texlive/texlive-langgerman-2016 required by (app-text/texlive-2016:0/0::gentoo, ebuild scheduled for merge)
    texlive-langgerman
    dev-texlive/texlive-langgerman required by @selected

  (dev-texlive/texlive-langenglish-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-texlive/texlive-langenglish required by @selected
    texlive-langenglish

  (dev-texlive/texlive-latexrecommended-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-texlive/texlive-latexrecommended required by (virtual/latex-base-1.0:0/0::gentoo, installed)
    >=dev-texlive/texlive-latexrecommended-2016 required by (dev-texlive/texlive-latexextra-2016:0/0::gentoo, ebuild scheduled for merge)
    dev-texlive/texlive-latexrecommended required by (dev-tex/pgf-3.0.1:0/0::gentoo, installed)
    >=dev-texlive/texlive-latexrecommended-2016 required by (app-text/texlive-2016:0/0::gentoo, ebuild scheduled for merge)
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1177
Location: Stuttgart, Germany

PostPosted: Wed Jan 25, 2017 10:47 am    Post subject: Reply with quote

Update: it turns out I have to remove all the texlive-lang[lang] packages and reinstall them manually (so, texlive-langenglish, texlive-langgerman, etc.), as well as texlive-mathextra, texlive-xetex, and texlive-latex. Perhaps one issue is that texlive-mathextra (and maybe some others) seem to have been replaced with texlive-mathscience.

In any case, is this an issue that should be reported? This seems like pretty severe inability to resolve dependencies.

Cheers,

EE
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10211
Location: Somewhere over Atlanta, Georgia

PostPosted: Wed Jan 25, 2017 11:01 am    Post subject: Reply with quote

It's among a known class of issues. If you search Bugzilla, I think you'll find several representative bugs already present. When you reinstalled the language packages, I hope you used --oneshot; otherwise, you've set yourself up for future issues. Regardless of what you did just now, you can check your world set for cruft with:
Code:
grep texlive /var/lib/portage/world
which should produce zero or one lines of output only (unless you know you've installed optional texlive packages that aren't automatically pulled in).

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2541
Location: Near Toronto

PostPosted: Wed Jan 25, 2017 12:55 pm    Post subject: Reply with quote

see bug https://bugs.gentoo.org/show_bug.cgi?id=606730

though painful, it is easy to work around the blockers
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1177
Location: Stuttgart, Germany

PostPosted: Wed Jan 25, 2017 3:10 pm    Post subject: Reply with quote

yeah, I just ended up doing it manually.

Incidentally, texlive-langlatin and texlive-langdutch are still both on the 2012 version, and texlive-xetex will fail to build if they're installed (the 2016 versions install a hyphenation file under /usr/share/texmf-dist/tex/generic/hyph-utf-8/loadhyph/loadhyph-[xx].tex (where [xx] is the language code, in this case nl and la respectively).

This appears to be a problem with upstream: the host site doesn't show those packages being updated, either.

Cheers,

EE
Back to top
View user's profile Send private message
thekraken
n00b
n00b


Joined: 08 Jan 2011
Posts: 11
Location: New Jersey

PostPosted: Sat Apr 01, 2017 1:28 am    Post subject: Similar issue... Reply with quote

I followed the instructions in this thread and manually unmerged all the culprit packages, but now texlive-2016 is trying to install both texlive-langgerman-2015 and 2016, causing a hard block:

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/ptexenc-1.3.4_p20160523::gentoo [1.3.3_p20150521::gentoo] USE="iconv -static-libs" 44865 KiB
[ebuild     U ~] app-text/dvipsk-5.996_p20160523::gentoo [5.995_p20150521::gentoo] USE="-doc -source" 34 KiB
[ebuild     U ~] dev-tex/bibtexu-3.71_p20160523::gentoo [3.71_p20150521::gentoo] USE="-doc -source" 10 KiB
[ebuild     U ~] app-text/ps2pkm-1.8_p20160523::gentoo [1.7_p20150521::gentoo] 0 KiB
[ebuild  N    ~] app-text/texlive-core-2016-r5::gentoo  USE="X cjk luajittex xetex -doc -source -tk" 10306 KiB
[ebuild  N    ~] dev-texlive/texlive-basic-2016::gentoo  USE="luajittex -doc -source" 4723 KiB
[ebuild  N    ~] dev-texlive/texlive-latex-2016::gentoo  USE="-doc -source" 861 KiB
[ebuild     U ~] dev-texlive/texlive-genericrecommended-2016::gentoo [2015::gentoo] USE="-doc -source" 223 KiB
[ebuild  N    ~] dev-texlive/texlive-fontutils-2016::gentoo  USE="-doc -source" 208 KiB
[ebuild  N    #] dev-texlive/texlive-langgerman-2015::gentoo  USE="-doc -source" 0 KiB
[ebuild  N    ~] dev-texlive/texlive-genericextra-2016::gentoo  USE="-doc -source" 373 KiB
[ebuild  N    ~] dev-texlive/texlive-fontsextra-2016::gentoo  USE="-doc -source" 272140 KiB
[ebuild     U ~] dev-texlive/texlive-plainextra-2016::gentoo [2015::gentoo] USE="-doc -source" 302 KiB
[ebuild  N    ~] dev-texlive/texlive-fontsrecommended-2016::gentoo  USE="-doc -source" 90668 KiB
[ebuild  N    ~] dev-texlive/texlive-langcjk-2016::gentoo  USE="-doc -source" 2197 KiB
[ebuild  N    ~] dev-texlive/texlive-bibtexextra-2016::gentoo  USE="-doc -source" 1656 KiB
[ebuild  N    ~] dev-texlive/texlive-humanities-2016::gentoo  USE="-doc -source" 399 KiB
[ebuild     U ~] dev-texlive/texlive-latexrecommended-2016::gentoo [2015-r1::gentoo] USE="-doc -source" 12729 KiB
[ebuild  N     ] dev-tex/currvita-0.9i-r1::gentoo  0 KiB
[ebuild  N     ] app-text/pdfjam-2.08::gentoo  0 KiB
[ebuild  N     ] dev-tex/leaflet-20041222::gentoo  0 KiB
[ebuild  N     ] dev-tex/g-brief-4.0.2::gentoo  0 KiB
[ebuild  N     ] dev-tex/envlab-1.2-r1::gentoo  0 KiB
[ebuild  N     ] dev-tex/chktex-1.7.1::gentoo  USE="pcre -debug -doc {-test}" 0 KiB
[ebuild  N     ] dev-tex/svninfo-0.7.4::gentoo  0 KiB
[ebuild  N     ] dev-tex/latexmk-435::gentoo  0 KiB
[ebuild  N     ] dev-tex/pgf-3.0.1::gentoo  USE="-doc -source" 0 KiB
[ebuild  N     ] dev-texlive/texlive-pstricks-2015::gentoo  USE="-doc -source" 25602 KiB
[ebuild  N    ~] dev-texlive/texlive-pictures-2016::gentoo  USE="-doc -source" 3398 KiB
[ebuild  N    ~] dev-texlive/texlive-latexextra-2016::gentoo  USE="-doc -source" 12041 KiB
[ebuild  N    ~] dev-texlive/texlive-mathscience-2016::gentoo  USE="-doc -source" 3082 KiB
[ebuild     U ~] dev-texlive/texlive-xetex-2016::gentoo [2015::gentoo] USE="X -doc -source" 854 KiB
[blocks b      ] <dev-texlive/texlive-xetex-2016 ("<dev-texlive/texlive-xetex-2016" is blocking dev-texlive/texlive-latexrecommended-2016)
[ebuild  N     ] dev-tex/europecv-20060424-r2::gentoo  USE="-examples" 0 KiB
[ebuild  N     ] dev-tex/glossaries-3.04::gentoo  USE="-doc -examples" 0 KiB
[ebuild  N    ~] dev-texlive/texlive-formatsextra-2016::gentoo  USE="-doc -source" 252 KiB
[ebuild  N    ~] app-text/texlive-2016::gentoo  USE="X cjk extra humanities png truetype xetex xml -context -detex -dvi2tty -epspdf -games -graphics -jadetex -luatex -metapost -music -omega -pdfannotextractor -pstricks -publishers -science -tex4ht -texi2html -xindy" L10N="-af -ar -as -bg -bn -br -ca -cs -cy -da -de -el -en -en-GB -eo -es -et -eu -fa -fi -fr -ga -gl -gu -he -hi -hr -hsb -hu -hy -ia -id -is -it -ja -kn -ko -la -lo -lt -lv -ml -mn -mr -nb -nl -nn -no -or -pa -pl -pt -rm -ro -ru -sa -sco -sk -sl -sq -sr -sv -ta -te -th -tk -tr -uk -vi -zh" 0 KiB
[blocks B      ] <dev-texlive/texlive-langgerman-2016 ("<dev-texlive/texlive-langgerman-2016" is hard blocking dev-texlive/texlive-basic-2016)

Total: 36 packages (8 upgrades, 28 new), Size of downloads: 486911 KiB
Conflict: 2 blocks (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-texlive/texlive-langgerman-2015:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-texlive/texlive-langgerman required by (dev-tex/currvita-0.9i-r1:0/0::gentoo, ebuild scheduled for merge)
    dev-texlive/texlive-langgerman required by (dev-tex/g-brief-4.0.2:0/0::gentoo, ebuild scheduled for merge)

  (dev-texlive/texlive-basic-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-fontsextra-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-fontsrecommended-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-formatsextra-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-xetex-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-pictures-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-plainextra-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-fontutils-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-latex-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-genericrecommended-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2015 required by (dev-texlive/texlive-pstricks-2015:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-genericextra-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (app-text/texlive-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-langcjk-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2015 required by (dev-texlive/texlive-langgerman-2015:0/0::gentoo, ebuild scheduled for merge)



It seems like langgerman-2015 is being pulled in for currvita and g-brief, but texlive-2016 wants to pull langgerman-2016 instead. I could probably do without those packages, and without langgerman, but I don't know what I'd have to do to block them, or what flag pulls them in. Can they be made to call langgerman-2016 instead? Neither are installed on my system ATM.
_________________
#926329 +(3230)- [X]

<N00b>Can someone explain cell division?
<Nerd> o
<Nerd> 0
<Nerd> 8
<Nerd> oo
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Mon Apr 17, 2017 6:09 am    Post subject: Reply with quote

thekraken, I think it's that texlive-langgerman-2016 is unstable, so needs to be in package.keywords.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum