Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Python fails on latest uclibc hardened stage 3
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Astronome
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 148

PostPosted: Sun Jan 22, 2017 6:29 pm    Post subject: [Solved] Python fails on latest uclibc hardened stage 3 Reply with quote

I'm trying to install Gentoo on a new system using the latest uclibc hardened
stage 3 (stage3-amd64-uclibc-hardened-20170105.tar.bz2) but ran into a blocker
when I tried to upgrade: https://dpaste.de/ookq

I tried removing the following line from package.mask:

Code:
=dev-lang/python-3.4.5


That removed the blocker but emerging Python failed: https://dpaste.de/kBFz

I also tried removing the following line from package.accept_keywords:

Code:
=dev-lang/python-3.5.2 ~amd64


The result was the same, however.


Last edited by Astronome on Sun Jan 22, 2017 8:33 pm; edited 1 time in total
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sun Jan 22, 2017 7:37 pm    Post subject: Reply with quote

Astronome ...

I'd imagine that it having build issues would equate to it being in package.mask (for the uClibc profile). If you don't actually need the 3.4 slot you could set PYTHON_TARGETS="python2_7" in make.conf, unmerge the 3.4 slot, and re-merge any package that currently has USE=python_target_python3_4 set.

As for the python-exec blocker, that doesn't seem to have any problem with the 2.7 slot:

Code:
# emerge -pvq dev-lang/python
[ebuild   R   ] dev-lang/python-2.7.12  USE="gdbm ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -build -doc -examples -hardened -ipv6 (-libressl) -tk -wininst
# emerge -pvq dev-lang/python-exec
[ebuild   R   ] dev-lang/python-exec-2.4.4  PYTHON_TARGETS="(jython2_7) (pypy) (pypy3) (python2_7) (python3_4) (python3_5)"

HTH & best ... khay
Back to top
View user's profile Send private message
Astronome
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 148

PostPosted: Sun Jan 22, 2017 8:33 pm    Post subject: Reply with quote

khayyam wrote:
If you don't actually need the 3.4 slot you could set PYTHON_TARGETS="python2_7" in make.conf


That did it! Thanks as usual!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum