Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
no sound from vmpk
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Mon Jan 23, 2017 11:02 am    Post subject: no sound from vmpk Reply with quote

media-sound/vmpk-0.6.2a::gentoo USE="dbus"


using alsa as output driver, I'm getting no sound, and no errors either.

I honestly do not know where to start the debugging process.

thanks
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Mon Jan 23, 2017 1:07 pm    Post subject: Reply with quote

http://vmpk.sourceforge.net/

Quote:
There is no sound

VMPK doesn't produce any sound by itself. You need a MIDI synthesizer, and please read the documentation again.


Read the manual first may help :)
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Wed Jan 25, 2017 11:33 am    Post subject: Reply with quote

I have installed qsynth, configured it to use pulseaudio, no sound
in the setup page I can see the driver in use is pulseaudio but there is no device in the drop down list
Any idea what I should do or where I should look?

thanks
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7972
Location: ~Brussels - Belgique

PostPosted: Wed Jan 25, 2017 11:38 am    Post subject: Reply with quote

Did you connect the MIDI output of the virtual keyboard to qsynth (using aconnect) ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Thu May 11, 2017 2:43 pm    Post subject: Reply with quote

I think so:
client 0: 'System' [type=kernel]
0 'Timer '
1 'Announce '
client 14: 'Midi Through' [type=kernel]
0 'Midi Through Port-0'
Connected From: 129:0
client 128: 'VMPK Input' [type=user]
0 'in '
client 129: 'VMPK Output' [type=user]
0 'out '
Connecting To: 14:0
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum