Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Plasma + Wayland
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
lcronos
n00b
n00b


Joined: 09 Jun 2014
Posts: 69

PostPosted: Sun Jan 29, 2017 11:41 pm    Post subject: [SOLVED] Plasma + Wayland Reply with quote

I'm working on getting Plasma (5.9) + Wayland working and am close with the only remaining bug appearing to be the desktop not loading. When I try to launch Plasma with Wayland, be it through SDDM or with startplasmacompositor, the splash screen goes by then I get a black screen. My mouse works, and I have access to yakuake. I can use yakuake to launch other applications, and they seem to behave properly, I just don't have a desktop. This doesn't seem to be a Plasma bug, because Weston doesn't launch at all either. I'm not on my Gentoo laptop right now, so I can't provide any emerge info (if it's needed), but I'll try to get it up in an hour or so. That aside, I'm using OpenRC + elogind (from the KDE overlay) and an Intel HD 4400 integrated graphics card.

I followed the steps listed here, https://blog.martin-graesslin.com/blog/2016/07/why-does-kwin_wayland-not-start/, and the two tests mentioned both worked as expected, I just can't get the actual session to launch. I also made sure to do the steps listed out in this post https://forums.gentoo.org/viewtopic-p-8002592.html?sid=e42953499d78007247b12ae5ac5f7ec5#8002592, so I'm not sure what else I'm missing. I know that Plasma 5.9 isn't ready for use yet, and if I can get Weston working but Plasma fails to work, I'll revert to 5.8 and test then. However, since Weston doesn't work I don't want to emerge plasma-meta and all it's dependencies twice for no reason.

Sorry it took a while, here's my emerge --info:
Code:
Portage 2.3.3 (python 2.7.12-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-4.9.4, glibc-2.23-r3, 4.4.39-gentoo x86_64)
=================================================================
System uname: Linux-4.4.39-gentoo-x86_64-Intel-R-_Core-TM-_i5-4210U_CPU_@_1.70GHz-with-gentoo-2.3
KiB Mem:     6038620 total,   4626552 free
KiB Swap:   12582908 total,  12582908 free
Timestamp of repository gentoo: Sun, 29 Jan 2017 16:30:01 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-lang/perl:            5.22.3_rc4::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.22.4::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.4::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

dotnet
    location: /var/lib/layman/dotnet
    masters: gentoo
    priority: 0

dr
    location: /var/lib/layman/dr
    masters: gentoo
    priority: 1

kde
    location: /var/lib/layman/kde
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.ussg.iu.edu/pub/linux/gentoo ftp://lug.mtu.edu/gentoo/ http://gentoo.osuosl.org/ http://mirror.lug.udel.edu/pub/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa alsa-plugin amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gpm iconv ipv6 jpeg kde kipi lcms ldap libnotify mad mng modules mp3 mp4 mpeg multilib ncurses nls nptl offensive ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qml qt3support qt4 qt5 readline sdl seccomp semantic-desktop session spell ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wayland widgets wifi wxwidgets x264 xattr xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="synaptics evdev keyboard intel" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Last edited by lcronos on Fri Feb 03, 2017 11:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
Voyl
n00b
n00b


Joined: 06 Nov 2016
Posts: 2
Location: Lisbon

PostPosted: Fri Feb 03, 2017 9:50 pm    Post subject: Reply with quote

Downgrading Plasma won't help you, I tried to get it working (since 5.7) with OpenRC + elogind and gave up. Switched to systemd and it just works, (5.7-5.9)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Fri Feb 03, 2017 9:53 pm    Post subject: Reply with quote

Well, work on elogind and reverse dependencies is not even remotely finished. If you want to work on it and possibly contribute to the ebuilds and/or wiki, generally stick to the latest available ~arch version of Plasma. Ignore Qt-5.8.0, it is broken - 5.7.1 will work best, if at all. Also upgrade to xorg-server-1.19.1.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
lcronos
n00b
n00b


Joined: 09 Jun 2014
Posts: 69

PostPosted: Fri Feb 03, 2017 10:02 pm    Post subject: Reply with quote

That makes sense. I'm debating on switching to systemd, but I like OpenRC quite a bit, so I'm not sure it's worth switching to systemd just to try Plasma Wayland. I saw in that post I linked to here, that someone did have luck getting it to work with elogind, so I wonder what we did different. There are a few other bugs I've noticed with elogind, so I've disabled it for now.

Just a side note, I noticed that the KDE overlay has a package called loginkit which from my understanding does what elogind does (implemented differently I guess), so I was wondering if you knew what the difference might be.


EDIT: It looks like I solved my problem.
You have to make all the edits detailed in that post I linked in OP, but then you also have to make sure to use sys-auth/polkit-0.113-r2 with the elogind use flag enabled. I have a working wayland session now.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum