Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] nvidia.ko not work for kener > 4.9.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
lanjian9151
n00b
n00b


Joined: 06 Mar 2014
Posts: 8

PostPosted: Wed Feb 01, 2017 3:45 pm    Post subject: [Solved] nvidia.ko not work for kener > 4.9.0 Reply with quote

Hello,

My current kernel is 4.9.0 and Nvidia-driver working good with it, but after I compiled the Nvidia-driver with no error under kernel > 4.9.0 (4.9.4 4.9.5 4.9.6) the system said cannot insert the nvidia.ko operation not permitted. Did anyone have the same issue? Is it related with kernel config? thanks for the help.
My nvidia-dirvers is 378.09
test kernel is 4.9.6-gentoo-r1

The issue solved, I found on the boot kernel report many module was denied, shows "loadpin module denied obj=/xxxxx.....", after googling I found I enabled the
CONFIG_SECURITY_LOADPIN in config file, just disable this and it's worked.
But I don't know why 4.9.0 use the same setting have no this issue, never mind, it's working. :D


Last edited by lanjian9151 on Wed Feb 01, 2017 6:33 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21779
Location: here

PostPosted: Wed Feb 01, 2017 4:50 pm    Post subject: Reply with quote

In my system with gentoo-sources-4.9.6 and x11-drivers/nvidia-drivers-378.09 there is no problem.
What's the exact error message?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
lanjian9151
n00b
n00b


Joined: 06 Mar 2014
Posts: 8

PostPosted: Wed Feb 01, 2017 5:00 pm    Post subject: Reply with quote

fedeliallalinea wrote:
In my system with gentoo-sources-4.9.6 and x11-drivers/nvidia-drivers-378.09 there is no problem.
What's the exact error message?


when I finished the kernel and nvidia-driver compile then do the reboot, the startx cannot init X, I tried the modprobe nvidia, the error is "cannot insert nvidia.ko, operation not permitted. try to use modprobe nvidia -vv, it shows "kernel module denied nvidia.ko".
I use initramfs by the way, the kernel config file is copied from 4.9.0, is there any change in 4.9.6 will block the nvidia.ko? thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum