Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Vanilla Kernel >4.7 sucks? [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Lars
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 168
Location: Germany, near baltic sea

PostPosted: Sat Dec 17, 2016 6:42 pm    Post subject: Vanilla Kernel >4.7 sucks? [SOLVED] Reply with quote

I love my Gentoo Linux since years I'm a hardcore freak. But in vanilla kernel 4.8 seams to be the worm. German proverb :D

Normally I copy the /usr/src/old-linux/.config to the new kernel directory /usr/src/linux/ do a make oldconfig build the kernel copy the bzImage to my grub and reboot. This is the normal way, all works most the time as expected.

But since kernel 4.8 X11 needs round about 2-3min until the xfce desktop opens. Then I have only english key layout normal is german, the second screen shows some of the first screen.

Tested with 4.8.10, 4.8.12 and 4.9

What should I rebuild so the system runs as expected?

The mysterious: I switched to gentoo-sources-4.8.14 and there are not the problems above. Xfce opens fast (<5sec) german key layout

Any hints?

Regards
Lars

My system is a simple Skylake 6700k with 16gb RAM.
Code:

Portage 2.3.0 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop, gcc-4.9.3, glibc-2.22-r4, 4.8.14-gentoo x86_64)
=================================================================
System uname: Linux-4.8.14-gentoo-x86_64-Intel-R-_Core-TM-_i7-6700K_CPU_@_4.00GHz-with-gentoo-2.2
KiB Mem:    16273816 total,   3936296 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Thu, 15 Dec 2016 20:30:01 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.22.2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.5.2-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.22.4::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.7.9-r3::gentoo, 1.8.5-r5::gentoo, 1.9.6-r4::gentoo, 1.10.3-r1::gentoo, 1.11.6-r1::gentoo, 1.12.6::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CC="gcc"
CFLAGS=" -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /lib/rcscripts/addons /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.3/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXX="g++"
CXXFLAGS=" -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news preserve-libs protect-owned sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="32bit 64bit X a52 aac aalib acpi ads alisp alsa amd64 ao apache2 applet asm async audacious audio audiofile auto-hinter automount bash-completion berkdb bindist bittorrent branding bzip2 cairo cdda cdio cdparanoia cdr clang cli colordiff console consolekit corefonts cracklib crypt css ctype cups curl cvs cxx d dbus derby device-mapper dga dhcp dhcpcd dmx dri dri3 drm dts dv dvb dvd dvdr eap-sim eap-tls eds egl emacs emboss encode evdev evo exif expat extras faac faad fat fbsplash ffmpeg firefox flac fontconfig fortran ftp fuse g3dvl gallium gcj gconf gd gdbm gdu gif gimp git glamor glut gmp gnutls gold gpg gphoto2 gpm graphviz gstreamer gtk3 gudev gvfs hddtemp hdri hfs iconv icq icu id3tag idn ieee1394 image imagemagick imlib inotify ipod ipv6 java java6 javascript jce jdepend jit jmf joystick jpeg jpeg2k json kdrive ladspa lame lash latex lcms ldap libcaca libffi libnotify libsamplerate llvm llvm-gcc lm_sensors logrotate lua lua-cairo lua-imlib lzma lzo mad maildir matroska md5sum mdnsresponder-compat mercurial mhash mixer mjpeg mmap mmx mmxext mng modperl modules mono mozdom mozilla mp3 mp4 mpeg mpeg2 mplayer mppe-mppc multilib musepack music musicbrainz mysql nas nautilus ncurses net netbeans network-cron networkmanager nfs nfsv4 nls nptl nsplugin ogg openal opencl opengl openh264 openmp opus pam pango parse-clocks pch pcre pda pdf php pmu png podcast policykit posix povray ppds printsupport pulseaudio python qemu qt3support qt5 radio radius rar raw rdesktop rdesktop-vrdp readline reiserfs resolvconf rle rtc samba sasl scanner sdl sdl-image sdl-sound sdlaudio seamonkey seccomp sensord server session shorten slang slp smbclient smbsharemodes smp sna sndfile snmp soap socks5 sound soundex sounds sox speex spell sqlite srt sse sse2 sse3 ssl startup-notification stream subversion svg syslog taglib tcl tcpd threads thunar thunderbird tiff tk transcode truetype twolame udev udisks unicode unzip upower urandom usb uxa v4l2 vaapi vala vcd vdpau vdr virtualbox visualization vnc vorbis vpx wav webdav webinterface webkit webmedia webp wifi winbind wma wmf wps wxwidgets x264 xa xanim xattr xcb xcomposite xine xinerama xinetd xml xmlpatterns xmlreader xmlrpc xmlwriter xmp xosd xpm xrandr xscreensaver xsl xulrunner xv xvid xvmc yenc zip zlib zvbi" ABI_X86="32 64" ALSA_CARDS="es1938 via82xx bt87x" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_core authz_core authn_default authn_file authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="canon sony" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 ssse3 sse4_1 sse4_2 avx avx2 aes fma3 popcnt" CURL_SSL="nss" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de de_DE.UTF-8 en" NETBEANS_MODULES="apisupport gsf j2ee harness ide java nb websvccommon cnd groovy php profiler visualweb webcommon xml dlight" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21 ruby22" SANE_BACKENDS="canon plustek genesys" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

_________________
Quote:
Alles was nicht einfach ist, ist entweder falsch oder zu kompliziert.

V.Glazounov


Last edited by Lars on Fri Feb 03, 2017 7:43 am; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5965

PostPosted: Sun Dec 18, 2016 6:51 pm    Post subject: Reply with quote

Do you see anything that looks like a timeout in dmesg? (hint: dmesg -d | egrep -v '^$|<\s+0.0')
Back to top
View user's profile Send private message
Lars
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 168
Location: Germany, near baltic sea

PostPosted: Sun Dec 25, 2016 12:14 pm    Post subject: Reply with quote

Some problems seems to be fixed with the last emerge --sync.

* X11 starts in less than 1 min.
* I got the german keyboard layout back.
* The second screen do not show stuff from the first.

Code:

[2016-12-25 12:54:39]root@monster ~ # dmesg -d | egrep -v '^$|<\s+0.0'
[    0.125023 <    0,100063>] TSC deadline timer enabled
[    0.295102 <    0,169371>] x86: Booting SMP configuration:
[    1.767395 <    1,472196>] x86: Booted up 1 node, 8 CPUs
[    2.363888 <    0,140163>] scsi host0: ahci
[    2.697402 <    0,328842>] ata6: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[    3.007972 <    0,288017>] random: fast init done
[    3.353360 <    0,123309>] sd 2:0:0:0: [sdb] 3907029168 512-byte logical blocks: (2.00 TB/1.82 TiB)
[    3.563354 <    0,102633>] sd 4:0:0:0: [sdd] 5860533168 512-byte logical blocks: (3.00 TB/2.73 TiB)
[    4.083506 <    0,341192>] [drm] RC6 on
[    4.213348 <    0,129842>] clocksource: Switched to clocksource tsc
[    4.335655 <    0,122307>] vboxdrv: loading out-of-tree module taints kernel.
[    4.515676 <    0,126346>] udevd[1815]: starting version 3.1.5
[    4.660385 <    0,144709>] xhci_hcd 0000:00:14.0: xHCI Host Controller
[    5.043283 <    0,226960>] usb 1-12: new high-speed USB device number 2 using xhci_hcd
[    5.326200 <    0,152963>] usb 1-12: New USB device found, idVendor=1307, idProduct=0361
[    5.435628 <    0,109420>] ata8: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[    5.623484 <    0,117555>] sd 7:0:0:0: [sdf] 1465149168 512-byte logical blocks: (750 GB/699 GiB)
[    6.642122 <    0,828643>] EXT4-fs (sda1): re-mounted. Opts: (null)
[    8.066036 <    0,979082>] r8169 0000:06:00.0 eth0: link down
[   11.836672 <    3,770634>] r8169 0000:06:00.0 eth0: link up
[   14.919394 <    3,082722>] NET: Registered protocol family 10
[   15.194439 <    0,275045>] RPC: Registered named UNIX socket transport module.
[   30.829558 <   15,578637>] ahci 0000:00:17.0: port does not support device sleep

_________________
Quote:
Alles was nicht einfach ist, ist entweder falsch oder zu kompliziert.

V.Glazounov
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3253
Location: Illinois, USA

PostPosted: Sun Dec 25, 2016 2:00 pm    Post subject: Reply with quote

This probably did not affect you, but when you upgrade to a higher kernel version using an existing .config, you should run "make oldconfig" before menuconfig or any other action. This will ask you what to do about new kernel configuration items and even indicate the default by a capital letter.
Back to top
View user's profile Send private message
Lars
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 168
Location: Germany, near baltic sea

PostPosted: Fri Feb 03, 2017 7:43 am    Post subject: Reply with quote

It seems, that my problem was the absent linux-firmware package.

Yesterday due to some problems I deinstalled the linux-firmware, take a reboot and all my problems mentioned in my first post are back.

I installed the linux-firmware again, and all my problems are gone.

Therefore I change the topic to solved.
_________________
Quote:
Alles was nicht einfach ist, ist entweder falsch oder zu kompliziert.

V.Glazounov
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum