Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Update problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Mon Feb 06, 2017 2:09 pm    Post subject: [Solved] Update problem Reply with quote

Try emerge -uDN world and that's what I saw:
Code:

Calculating dependencies... done!
[ebuild  N     ] media-plugins/live-2013.02.11  USE="-examples -static-libs"
[ebuild  N     ] media-libs/libsidplay-2.1.1-r4  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/fdk-aac-0.1.3  USE="-examples -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/opus-1.1.3-r1  USE="-ambisonics -custom-modes -doc (-neon) -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse"
[ebuild  N     ] media-libs/libdvdcss-1.3.0  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-libs/libraw1394-2.1.0-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/libcddb-1.3.2-r1  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild     UD ] virtual/modutils-0 [0-r1]
[ebuild  N     ] media-fonts/dejavu-2.35  USE="X -fontforge"
[ebuild  N     ] sys-auth/realtime-base-0.1
[ebuild  N     ] media-libs/zvbi-0.2.35-r1  USE="X nls -doc -dvb -static-libs -v4l" ABI_X86="(64) -32 (-x32)"
[ebuild     UD ] virtual/mailx-1 [1-r1]
[ebuild  N     ] media-libs/libkate-0.3.7  USE="-doc -wxwidgets"
[ebuild  N     ] sys-libs/libavc1394-0.5.4-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/libv4l-1.10.1  USE="jpeg" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-sound/twolame-0.3.13-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/aalib-1.4_rc5-r6  USE="X -gpm -slang -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-sound/jack-audio-connection-kit-0.121.3-r1  USE="pam -alsa (-altivec) (-coreaudio) -cpudetection -debug -doc -examples -oss" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmx sse -3dnow"
[ebuild  N     ] media-libs/taglib-1.10  USE="asf mp4 -debug -examples {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/x265-2.2  USE="10bit 12bit -numa -pic {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/game-music-emu-0.6.0-r1  ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-cpp/eigen-3.2.8-r2  USE="openmp (-altivec) -debug -doc {-test}" CPU_FLAGS_X86="sse2 -sse3 -sse4_1 -sse4_2 -ssse3"
[ebuild  N     ] virtual/jack-0  ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/opencv-2.4.13  USE="eigen jpeg openmp png python -cuda -examples -ffmpeg -gstreamer -gtk -ieee1394 (-ipp) -java -jpeg2k -libav -opencl -openexr -opengl (-pch) -qt4 -qt5 -testprograms -threads -tiff -v4l (-vtk) -xine" PYTHON_TARGETS="python2_7"
[ebuild  N     ] app-doc/xmltoman-0.4
[ebuild  N     ] dev-lang/orc-0.4.26-r1  USE="pax_kernel -examples -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] virtual/linux-sources-1 [1] USE="-firmware%"
[ebuild     U ~] app-emulation/virtualbox-modules-5.1.14 [5.0.32] USE="pax_kernel*"
[ebuild  NS    ] sys-devel/automake-1.11.6-r1 [1.14.1, 1.15]
[ebuild     UD ] sys-apps/kbd-2.0.3 [2.0.3-r9]
[ebuild  N     ] dev-libs/fribidi-0.19.6  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-libs/libebml-1.3.4  USE="-debug -static-libs"
[ebuild  N     ] media-libs/libdvdread-5.0.3  USE="css -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-libs/libtar-1.2.20-r3  USE="zlib -static-libs"
[ebuild  N     ] media-libs/libshout-2.3.1-r1  USE="-speex -static-libs -theora" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/libmodplug-0.8.8.5  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/schroedinger-1.0.11-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/a52dec-0.7.4-r7  USE="-djbfft -oss -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/faad2-2.7-r3  USE="-digitalradio -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-libs/libssh2-1.7.0  USE="zlib -gcrypt (-libressl) -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/libcaca-0.99_beta19  USE="X cxx ncurses -doc -imlib (-java) (-mono) -opengl -python -ruby -slang -static-libs {-test} -truetype" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" RUBY_TARGETS="(-ruby20)"
[ebuild  N     ] media-libs/libtheora-1.1.1-r1  USE="encode -doc -examples -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-libs/libupnp-1.6.21  USE="ipv6 -debug -doc -static-libs"
[ebuild  N     ] media-libs/tremor-0_pre20130223-r1  USE="-low-accuracy -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/libmad-0.15.1b-r8  USE="-debug -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-dns/avahi-0.6.32  USE="dbus gdbm introspection ipv6 nls -autoipd -bookmarks -doc -gtk -gtk3 -howl-compat -mdnsresponder-compat -mono -python -qt4 (-selinux) {-test} -utils" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7"
[ebuild  N     ] media-libs/libmpeg2-0.5.1-r2  USE="X -sdl -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/libdca-0.0.5-r3  USE="-debug -oss -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/libdvdnav-5.0.3  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/libmatroska-1.4.5  USE="-static-libs"
[ebuild   R    ] media-libs/mesa-12.0.1  USE="vaapi*"
[ebuild  N     ] media-libs/libdc1394-2.2.1  USE="X -doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/libass-0.13.6  USE="fontconfig harfbuzz -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/libtiger-0.3.4  USE="-doc"
[ebuild  N     ] media-libs/glew-1.10.0-r2  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/ftgl-2.1.3_rc5  USE="-static-libs"
[ebuild  N     ] media-libs/libprojectm-2.1.0-r1  USE="openmp -debug" VIDEO_CARDS="(-nvidia)"
[ebuild  N     ] media-video/libav-11.8  USE="X bzip2 encode gpl hardcoded-tables network pic pulseaudio ssl vaapi zlib -aac -alsa (-altivec) -amr (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bs2b -cdio -cpudetection -custom-cflags -debug -doc -faac -fdk -fontconfig -frei0r -gsm -ieee1394 -jack -jpeg2k (-libressl) -mp3 (-neon) -openssl -opus -oss -rtmp -schroedinger -sdl -speex -static-libs {-test} -theora -threads -tools -truetype -twolame -v4l -vdpau -vorbis -vpx -wavpack -webp -x264 -x265 -xvid" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmx mmxext sse sse2 -3dnow -3dnowext -avx -avx2 -fma3 -fma4 -sse3 -sse4_1 -sse4_2 -ssse3 -xop"
[ebuild  N     ] media-sound/fluidsynth-1.1.6-r1  USE="dbus pulseaudio readline -alsa -debug -examples -jack -ladspa -lash -portaudio -sndfile" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-video/ffmpeg-2.8.10  USE="X bzip2 encode gpl hardcoded-tables iconv network pic postproc pulseaudio threads vaapi zlib -aac -aacplus -alsa (-altivec) -amr -amrenc (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bluray -bs2b -cdio -celt -cpudetection -debug -doc -examples -faac -fdk -flite -fontconfig -frei0r -fribidi -gme -gnutls -gsm -iec61883 -ieee1394 -jack -jpeg2k -ladspa -libass -libcaca (-libressl) -librtmp -libsoxr -libv4l -lzma (-mipsdspr1) (-mipsdspr2) (-mipsfpu) -modplug -mp3 (-neon) -openal -opengl -openssl -opus -oss -quvi -samba -schroedinger -sdl -snappy -speex -ssh -static-libs {-test} -theora -truetype -twolame -v4l -vdpau -vorbis -vpx -wavpack -webp -x264 -x265 -xcb -xvid -zvbi" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmx mmxext sse sse2 -3dnow -3dnowext -avx -avx2 -fma3 -fma4 -sse3 -sse4_1 -sse4_2 -ssse3 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher"
[ebuild  N     ] media-libs/libpostproc-10.20140517-r1  USE="pic (-altivec) -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmx mmxext -3dnow"
[ebuild  N     ] media-libs/chromaprint-1.2  USE="-libav {-test} -tools"
[ebuild     U ~] app-emulation/virtualbox-bin-5.1.14.112924 [5.0.32.112930]
[ebuild   R    ] media-video/vlc-2.2.4  USE="a52* aalib* alsa* bidi* bluray* cdda* cddb* chromaprint* dc1394* directfb* dts* dvb* dvd* faad* fdk* flac* fluidsynth* fontconfig* gme* gnutls* httpd* ieee1394* jack* kate* libass* libav* libcaca* libnotify* libtar* libtiger* linsys* live* lua* matroska* modplug* mp3* mpeg* mtp* omxil* opencv* opengl* optimisememory* opus* postproc* projectm* qt5* rtsp* schroedinger* sdl* sdl-image* sftp* shout* sid* skins* speex* svg* taglib* theora* tremor* truetype* twolame* udev* upnp* v4l* vaapi* vdpau* vlm* vorbis* vpx* wma-fixed* x265* xml* zeroconf* zvbi*"
[blocks B      ] media-video/ffmpeg:0 ("media-video/ffmpeg:0" is blocking media-libs/libpostproc-10.20140517-r1, media-video/libav-11.8)
[blocks B      ] media-libs/libpostproc ("media-libs/libpostproc" is blocking media-video/ffmpeg-2.8.10)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-video/ffmpeg-2.8.10:0/54.56.56::gentoo, ebuild scheduled for merge) pulled in by
    >=media-video/ffmpeg-2.6:0= required by (media-libs/chromaprint-1.2:0/0::gentoo, ebuild scheduled for merge)

  (media-video/libav-11.8:0/11::gentoo, ebuild scheduled for merge) pulled in by
    >=media-video/libav-10:0= required by (media-video/vlc-2.2.4:0/5-8::gentoo, ebuild scheduled for merge)
    media-video/libav:0=[vaapi] required by (media-video/vlc-2.2.4:0/5-8::gentoo, ebuild scheduled for merge)
    media-video/libav:0= required by (media-video/vlc-2.2.4:0/5-8::gentoo, ebuild scheduled for merge)
    >=media-video/libav-11:0= required by (media-video/vlc-2.2.4:0/5-8::gentoo, ebuild scheduled for merge)
    >=media-video/libav-0.8.2-r2:0= required by (media-libs/libpostproc-10.20140517-r1:0/0::gentoo, ebuild scheduled for merge)

  (media-libs/libpostproc-10.20140517-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/libpostproc:0= required by (media-video/vlc-2.2.4:0/5-8::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following license changes are necessary to proceed:
 (see "package.license" in the portage(5) man page for more details)
# required by media-video/vlc-2.2.4::gentoo[fdk]
# required by @selected
# required by @world (argument)
=media-libs/fdk-aac-0.1.3 FraunhoferFDK

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.


[Moderator edit: added [code] tags to preserve output layout. -Hu]


Last edited by sergei on Mon Feb 06, 2017 2:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
markisthejob
Tux's lil' helper
Tux's lil' helper


Joined: 04 Aug 2008
Posts: 142
Location: Cork, Republic of Ireland

PostPosted: Mon Feb 06, 2017 2:22 pm    Post subject: Reply with quote

media-video/ffmpeg and media-video/libav cant be installed on the same system. You need to check your USE flags and only use either ffmpeg or libav.

Last edited by markisthejob on Mon Feb 06, 2017 2:35 pm; edited 2 times in total
Back to top
View user's profile Send private message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Mon Feb 06, 2017 2:30 pm    Post subject: Reply with quote

Package.use: "media-video/vlc -libav". Did not help.
package.use: "media-video/vlc ffmpeg -libav". Did not help.


Last edited by sergei on Mon Feb 06, 2017 2:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7972
Location: ~Brussels - Belgique

PostPosted: Mon Feb 06, 2017 2:31 pm    Post subject: Reply with quote

And there is a USE flag that enables/disables MP3 encoding using commercial Fraunhaufer codec.

You can disable it and use libav/ffmpeg/lame to encode MP3s. If you really need it, you need to add an entry in /etc/portage/package.license
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
markisthejob
Tux's lil' helper
Tux's lil' helper


Joined: 04 Aug 2008
Posts: 142
Location: Cork, Republic of Ireland

PostPosted: Mon Feb 06, 2017 2:34 pm    Post subject: Reply with quote

on closer inspection media-libs/chromaprint has -libav in its use flags. Adding libav to its USE flags should fix your problem and stop trying to pull in ffmpeg
Back to top
View user's profile Send private message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Mon Feb 06, 2017 2:39 pm    Post subject: Reply with quote

Yes, it helped thanks.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5769

PostPosted: Mon Feb 06, 2017 2:41 pm    Post subject: Reply with quote

Code:
media-video/vlc -libav -postproc

Or add the version of libpostproc that pulls in libav to p.mask.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum