Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to update Gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
dhinds
n00b
n00b


Joined: 05 Jul 2014
Posts: 13

PostPosted: Mon Feb 20, 2017 10:06 pm    Post subject: Unable to update Gentoo Reply with quote

Running the Calculate Desktop Xfce Overlay, when I attempt to update, the following appears at the end of the list of available files:

Code:
!!! The following binary packages have been ignored due to changed dependencies:

x11-drivers/xf86-video-intel-2.99.917_p20161118::calculate
media-libs/mesa-12.0.1::gentoo
x11-apps/xwd-1.0.6::gentoo
x11-misc/light-locker-1.4.0-r2::calculate
x11-libs/fltk-1.3.3-r3::gentoo
sys-libs/glibc-2.23-r3::gentoo
www-client/otter-0.9.11::gentoo
x11-misc/x11vnc-0.9.14_p20161013::gentoo

NOTE: The --binpkg-changed-deps=n option will prevent emerge
from ignoring these binary packages if possible.
Using --binpkg-changed-deps=y will silence this warning.

The following mask changes are necessary to proceed:
(see "package.unmask" in the portage(5) man page for more details)
# required by dev-lang/ruby-2.1.9::gentoo[ncurses]
# required by dev-qt/qtwebkit-5.7.1::gentoo
# required by www-client/otter-0.9.11::gentoo
# required by @selected
# required by @world (argument)
# /var/lib/layman/calculate/profiles/base/package.mask/default:
=sys-libs/ncurses-6.0-r1

NOTE: The --autounmask-keep-masks option will prevent emerge
from creating package.unmask or ** keyword changes.

* Use eselect news read to view new items.

Emerge failed
Update failed


I'm not sure sure how to correct this and would appreciate any suggestions.

Thanks in advance.

[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. Moved from Portage and Programming to Unsupported Software, as suggested by asturm, since the problem comes from an overlay. You may still get help with this problem on the Gentoo forums, but your post fits better in Unsupported Software. -Hu]
Back to top
View user's profile Send private message
fturco
l33t
l33t


Joined: 08 Dec 2010
Posts: 613
Location: Italy

PostPosted: Tue Feb 21, 2017 10:55 am    Post subject: Reply with quote

As far as I can see dev-lang/ruby-2.1.9::gentoo[ncurses] requires =sys-libs/ncurses-6.0-r1 which is masked by the Calculate overlay (see /var/lib/layman/calculate/profiles/base/package.mask/default). There are a couple of alternatives:

1) Unmask ncurses. You need to edit /etc/portage/package.unmask and add the following line:

Code:
=sys-libs/ncurses-6.0-r1


2) Disable the ncurses USE flag for dev-lang/ruby. Edit /etc/portage/package.use and add the following line:

Code:
=dev-lang/ruby-2.1.9 -ncurses
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum