Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] ffmpeg findet gnutls nicht
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Sat Feb 25, 2017 7:38 am    Post subject: [SOLVED] ffmpeg findet gnutls nicht Reply with quote

Hallo Zusammen,

ich habe gerade mal wieder ein world Update gemacht, doch leider findet ffmpeg und ein paar andere gnutls nicht.

Code:
>>> Emerging (4 of 6) media-video/ffmpeg-3.2.4::gentoo
 * ffmpeg-3.2.4.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                                          [ ok ]
>>> Unpacking source...
>>> Unpacking ffmpeg-3.2.4.tar.bz2 to /tmp/portage/media-video/ffmpeg-3.2.4/work
>>> Source unpacked in /tmp/portage/media-video/ffmpeg-3.2.4/work
>>> Preparing source in /tmp/portage/media-video/ffmpeg-3.2.4/work/ffmpeg-3.2.4 ...
>>> Source prepared.
>>> Configuring source in /tmp/portage/media-video/ffmpeg-3.2.4/work/ffmpeg-3.2.4 ...
 * abi_x86_64.amd64: running multilib-minimal_abi_src_configure
/tmp/portage/media-video/ffmpeg-3.2.4/work/ffmpeg-3.2.4/configure --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --docdir=/usr/share/doc/ffmpeg-3.2.4/html --mandir=/usr/share/man --enable-shared --cc=x86_64-pc-linux-gnu-gcc --cxx=x86_64-pc-linux-gnu-g++ --ar=x86_64-pc-linux-gnu-ar --optflags=-march=corei7 -O2 -pipe --disable-static --enable-avfilter --enable-avresample --disable-stripping --enable-version3 --disable-indev=v4l2 --disable-outdev=v4l2 --disable-outdev=sdl --enable-version3 --enable-bzlib --enable-runtime-cpudetect --disable-debug --disable-gcrypt --enable-gnutls --disable-gmp --enable-gpl --enable-hardcoded-tables --enable-iconv --disable-lzma --enable-network --disable-openssl --enable-postproc --enable-libsmbclient --disable-ffplay --disable-sdl2 --enable-vaapi --disable-vdpau --enable-xlib --disable-libxcb --disable-libxcb-shm --disable-libxcb-xfixes --enable-zlib --disable-libcdio --disable-libiec61883 --enable-libdc1394 --enable-libcaca --disable-openal --enable-opengl --disable-libv4l2 --disable-libpulse --enable-libopencore-amrwb --enable-libopencore-amrnb --disable-libfdk-aac --disable-libopenjpeg --disable-libbluray --disable-libcelt --disable-libgme --disable-libgsm --disable-mmal --enable-libmodplug --disable-libopus --disable-libilbc --disable-librtmp --disable-libssh --enable-libschroedinger --disable-libspeex --enable-libvorbis --disable-libvpx --disable-libzvbi --disable-libbs2b --disable-chromaprint --disable-libebur128 --disable-libflite --disable-frei0r --disable-libfribidi --enable-fontconfig --disable-ladspa --disable-libass --enable-libfreetype --disable-librubberband --disable-libzimg --disable-libsoxr --enable-pthreads --disable-libvo-amrwbenc --enable-libmp3lame --disable-libkvazaar --disable-nvenc --disable-libopenh264 --disable-libsnappy --enable-libtheora --disable-libtwolame --disable-libwavpack --disable-libwebp --enable-libx264 --disable-libx265 --enable-libxvid --enable-x11grab --disable-amd3dnow --disable-amd3dnowext --disable-avx2 --disable-fma3 --disable-fma4 --disable-xop --enable-pic --cpu=corei7 --disable-doc --disable-htmlpages --enable-manpages
ERROR: gnutls not found using pkg-config



gnutls ist aber installiert:

Code:
server01 ~ # eix net-libs/gnutls
[I] net-libs/gnutls
     Verfügbare Versionen:   3.3.26 (~)3.5.8(0/30) (~)3.5.9-r2(0/30) {+crywrap +cxx dane doc examples guile +idn nls +openssl pkcs11 sslv2 +sslv3 static-libs test test-full +tls-heartbeat tools valgrind zlib ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" LINGUAS="cs de en fi fr it ms nl pl sv uk vi zh_CN"}
     Installierte Versionen: 3.5.9-r2(07:35:59 25.02.2017)(cxx idn nls openssl sslv3 tls-heartbeat zlib -dane -doc -examples -guile -pkcs11 -sslv2 -static-libs -test -test-full -tools -valgrind ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32" LINGUAS="de en -cs -fi -fr -it -ms -nl -pl -sv -uk -vi -zh_CN")
     Startseite:             http://www.gnutls.org/
     Beschreibung:           A TLS 1.2 and SSL 3.0 implementation for the GNU project

server01 ~ #


Hat Jemand eine Idee, was da schief läuft?


Last edited by 3PO on Sat Feb 25, 2017 4:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Sat Feb 25, 2017 10:55 am    Post subject: Reply with quote

Huh, ohne build.log ist sowas meist schwierig/mühselig :-/

Blind geraten: Eventuell braucht dein media-video/ffmpeg ein mit ABI_X86="64 32" gebautes net-libs/gnutls?! :)
Back to top
View user's profile Send private message
demiurg
n00b
n00b


Joined: 26 Jul 2005
Posts: 71

PostPosted: Sat Feb 25, 2017 11:10 am    Post subject: Noch eine Idee Reply with quote

Bei mir läuft ffmpeg-3.2.4 mit gnutls-3.3.26 - also Stable version. Laut ebuild von ffmpeg ist nur >=net-libs/gnutls-2.12.23-r6 verlangt, sollte das eigentlich kein Problem sein. Ein weiterer Gedanke gnutls einfach nur für sich mit emerge gnutls nochmal bauen. Ich habe die Erfahrung gemacht, dass in seltenen Fällen bei Updates das world-file anscheinend nicht korrekt aktualisiert wird. Beim emerge eines einzelnen Paketes ist das nie passiert.
_________________
Kernel 5.xx-gentoo
GCC 9.xx
Profile amd64/17.1/desktop/plasma
Ryzen 1700
GA AX370-Gaming K7 BIOS F31
ATI RX580
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Sat Feb 25, 2017 11:24 am    Post subject: Reply with quote

Im Build-Log steht auch nicht wesentlich mehr:

Code:
server01 ~ # cat /log/portage/media-video:ffmpeg-3.2.4:20170225-073822.log
 * Package:    media-video/ffmpeg-3.2.4
 * Repository: gentoo
 * Maintainer: media-video@gentoo.org
 * USE:        X abi_x86_64 alsa amd64 amr bzip2 cpu_flags_x86_aes cpu_flags_x86_avx cpu_flags_x86_mmx cpu_flags_x86_mmxext cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_ssse3 cpudetection elibc_glibc encode fftools_aviocat fftools_cws2fws fftools_ffescape fftools_ffeval fftools_ffhash fftools_fourcc2pixfmt fftools_graph2dot fftools_ismindex fftools_pktdumper fftools_qt-faststart fftools_sidxindex fftools_trasher fontconfig gnutls gpl hardcoded-tables iconv ieee1394 jack kernel_linux libcaca modplug mp3 network opengl oss pic postproc samba schroedinger theora threads truetype userland_GNU vaapi vorbis x264 xvid zlib
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking ffmpeg-3.2.4.tar.bz2 to /tmp/portage/media-video/ffmpeg-3.2.4/work
>>> Source unpacked in /tmp/portage/media-video/ffmpeg-3.2.4/work
>>> Preparing source in /tmp/portage/media-video/ffmpeg-3.2.4/work/ffmpeg-3.2.4 ...
>>> Source prepared.
>>> Configuring source in /tmp/portage/media-video/ffmpeg-3.2.4/work/ffmpeg-3.2.4 ...
 * abi_x86_64.amd64: running multilib-minimal_abi_src_configure
/tmp/portage/media-video/ffmpeg-3.2.4/work/ffmpeg-3.2.4/configure --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --docdir=/usr/share/doc/ffmpeg-3.2.4/html --mandir=/usr/share/man --enable-shared --cc=x86_64-pc-linux-gnu-gcc --cxx=x86_64-pc-linux-gnu-g++ --ar=x86_64-pc-linux-gnu-ar --optflags=-march=corei7 -O2 -pipe --disable-static --enable-avfilter --enable-avresample --disable-stripping --enable-version3 --disable-indev=v4l2 --disable-outdev=v4l2 --disable-outdev=sdl --enable-version3 --enable-bzlib --enable-runtime-cpudetect --disable-debug --disable-gcrypt --enable-gnutls --disable-gmp --enable-gpl --enable-hardcoded-tables --enable-iconv --disable-lzma --enable-network --disable-openssl --enable-postproc --enable-libsmbclient --disable-ffplay --disable-sdl2 --enable-vaapi --disable-vdpau --enable-xlib --disable-libxcb --disable-libxcb-shm --disable-libxcb-xfixes --enable-zlib --disable-libcdio --disable-libiec61883 --enable-libdc1394 --enable-libcaca --disable-openal --enable-opengl --disable-libv4l2 --disable-libpulse --enable-libopencore-amrwb --enable-libopencore-amrnb --disable-libfdk-aac --disable-libopenjpeg --disable-libbluray --disable-libcelt --disable-libgme --disable-libgsm --disable-mmal --enable-libmodplug --disable-libopus --disable-libilbc --disable-librtmp --disable-libssh --enable-libschroedinger --disable-libspeex --enable-libvorbis --disable-libvpx --disable-libzvbi --disable-libbs2b --disable-chromaprint --disable-libebur128 --disable-libflite --disable-frei0r --disable-libfribidi --enable-fontconfig --disable-ladspa --disable-libass --enable-libfreetype --disable-librubberband --disable-libzimg --disable-libsoxr --enable-pthreads --disable-libvo-amrwbenc --enable-libmp3lame --disable-libkvazaar --disable-nvenc --disable-libopenh264 --disable-libsnappy --enable-libtheora --disable-libtwolame --disable-libwavpack --disable-libwebp --enable-libx264 --disable-libx265 --enable-libxvid --enable-x11grab --disable-amd3dnow --disable-amd3dnowext --disable-avx2 --disable-fma3 --disable-fma4 --disable-xop --enable-pic --cpu=corei7 --disable-doc --disable-htmlpages --enable-manpages
ERROR: gnutls not found using pkg-config

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solve the problem.
 * ERROR: media-video/ffmpeg-3.2.4::gentoo failed (configure phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  115:  Called src_configure
 *   environment, line 3213:  Called multilib-minimal_src_configure
 *   environment, line 2330:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *   environment, line 2544:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 2260:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 2258:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *   environment, line  675:  Called multilib-minimal_abi_src_configure
 *   environment, line 2324:  Called multilib_src_configure
 *   environment, line 2843:  Called die
 * The specific snippet of code:
 *       "${@}" || die
 *
 * If you need support, post the output of `emerge --info '=media-video/ffmpeg-3.2.4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-video/ffmpeg-3.2.4::gentoo'`.
 * The complete build log is located at '/log/portage/media-video:ffmpeg-3.2.4:20170225-073822.log'.
 * For convenience, a symlink to the build log is located at '/tmp/portage/media-video/ffmpeg-3.2.4/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/media-video/ffmpeg-3.2.4/temp/environment'.
 * Working directory: '/tmp/portage/media-video/ffmpeg-3.2.4/work/ffmpeg-3.2.4-abi_x86_64.amd64'
 * S: '/tmp/portage/media-video/ffmpeg-3.2.4/work/ffmpeg-3.2.4'
server01 ~ #


Und das Neubauen von gnutls brachte leider auch nichts.
Back to top
View user's profile Send private message
demiurg
n00b
n00b


Joined: 26 Jul 2005
Posts: 71

PostPosted: Sat Feb 25, 2017 1:18 pm    Post subject: Tante Google nicht direkt hilfreich Reply with quote

Welche anderen Programme haben denn Probleme gnutls zu finden?

ffmpeg ist jedenfalls mit -gnutls übersetzt und installiert. Es scheint also nicht standardmäßig aktiv zu sein, dabei mir nirgendwo das Flag gnutls aktiviert oder abgeschaltet ist (make.conf oder package.use). Irgendwie schwirrt eine Hängepartie mit gnutls beim Aktualisieren im Hinterkopf herum, dass muss aber noch vor Weihnachten gewesen sein und ich bekomme es nicht mehr zusammen. Da gab es gefühlt zwei Tage später eine Aktualisierung im Tree und das Problem war weg.

Gruß
demiurg
_________________
Kernel 5.xx-gentoo
GCC 9.xx
Profile amd64/17.1/desktop/plasma
Ryzen 1700
GA AX370-Gaming K7 BIOS F31
ATI RX580
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Sat Feb 25, 2017 2:14 pm    Post subject: Re: Tante Google nicht direkt hilfreich Reply with quote

demiurg wrote:
Welche anderen Programme haben denn Probleme gnutls zu finden? ...


Code:
 *
 * The following 6 packages have failed to build, install, or execute
 * postinst:
 *
 *  (net-misc/curl-7.53.0:0/0::gentoo, ebuild scheduled for merge), Log file:
 *   '/log/portage/net-misc:curl-7.53.0:20170225-140419.log'
 *  (net-print/cups-2.2.2-r3:0/0::gentoo, ebuild scheduled for merge), Log file:
 *   '/log/portage/net-print:cups-2.2.2-r3:20170225-140517.log'
 *  (net-ftp/lftp-4.7.5:0/0::gentoo, ebuild scheduled for merge), Log file:
 *   '/log/portage/net-ftp:lftp-4.7.5:20170225-140545.log'
 *  (media-video/ffmpeg-3.2.4:0/55.57.57::gentoo, ebuild scheduled for merge), Log file:
 *   '/log/portage/media-video:ffmpeg-3.2.4:20170225-140659.log'
 *  (net-misc/networkmanager-1.4.4-r1:0/0::gentoo, ebuild scheduled for merge), Log file:
 *   '/log/portage/net-misc:networkmanager-1.4.4-r1:20170225-140729.log'
 *  (app-emulation/qemu-2.8.0-r4:0/0::gentoo, ebuild scheduled for merge), Log file:
 *   '/log/portage/app-emulation:qemu-2.8.0-r4:20170225-140754.log'
 *
server01 ~ #


Ich habe mal die Los hier hochgeladen:

https://paste.pound-python.org/show/WUY3UxhGU5u7Q0HKZ63Z/
https://paste.pound-python.org/show/Fta3sDS4uOnVZoFtkOkn/
https://paste.pound-python.org/show/XxaZw4hc2XLLxi4oVki7/
https://paste.pound-python.org/show/6YCirMvtVp6FNQM9EvqB/
https://paste.pound-python.org/show/4vikiJm6WXg7qOO6oAEu/
https://paste.pound-python.org/show/1LqJtAa5ZEIH3OeBwULe/
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Sat Feb 25, 2017 3:34 pm    Post subject: Re: ffmpeg findet gnutls nicht Reply with quote

3PO wrote:
[...]

gnutls ist aber installiert:

Code:
server01 ~ # eix net-libs/gnutls
[I] net-libs/gnutls
     Verfügbare Versionen:   3.3.26 (~)3.5.8(0/30) (~)3.5.9-r2(0/30) {+crywrap +cxx dane doc examples guile +idn nls +openssl pkcs11 sslv2 +sslv3 static-libs test test-full +tls-heartbeat tools valgrind zlib ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" LINGUAS="cs de en fi fr it ms nl pl sv uk vi zh_CN"}
     Installierte Versionen: 3.5.9-r2(07:35:59 25.02.2017)(cxx idn nls openssl sslv3 tls-heartbeat zlib -dane -doc -examples -guile -pkcs11 -sslv2 -static-libs -test -test-full -tools -valgrind ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32" LINGUAS="de en -cs -fi -fr -it -ms -nl -pl -sv -uk -vi -zh_CN")
     Startseite:             http://www.gnutls.org/
     Beschreibung:           A TLS 1.2 and SSL 3.0 implementation for the GNU project

server01 ~ #


Hat Jemand eine Idee, was da schief läuft?

pastebin wrote:
Code:
checking for GNUTLS... no
configure: error: Package requirements (gnutls >= 2.12) were not met:

Package 'libidn2', required by 'gnutls', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GNUTLS_CFLAGS
and GNUTLS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

!!! Please attach the following file when seeking support:
!!! /tmp/portage/net-misc/networkmanager-1.4.4-r1/work/NetworkManager-1.4.4-abi_x86_64.amd64/config.log
 * ERROR: net-misc/networkmanager-1.4.4-r1::gentoo failed (configure phase):

Hm, mit welcher net-dns/libidn2 Version wurde net-libs/gnutls-3.5.9-r2 gebaut?
Sofern noch nicht geschehen, versuche es bitte mal mit >=net-dns/libidn2-0.16-r1
Code:
emerge -av1 \>=net-dns/libidn2-0.16-r1 net-libs/gnutls
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Sat Feb 25, 2017 4:06 pm    Post subject: Reply with quote

Danke, hat wohl wirklich an libidn2 gelegen. :wink:

Ich habe jetzt einfach mal die unstable installiert, danach lief das world Update durch:

Code:
echo "net-dns/libidn2" >> /etc/portage/package.keywords/net
emerge -av libidn2 gnutls
emerge -avuDN world
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum