Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]unknown filesystem 'efivars'-can't access efivars
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
tirkaz
n00b
n00b


Joined: 12 May 2016
Posts: 12

PostPosted: Sun Feb 26, 2017 3:19 am    Post subject: [SOLVED]unknown filesystem 'efivars'-can't access efivars Reply with quote

Good evening,

I've installed Gentoo successfully a few months ago using the Wiki's Handbook. I used sysrescuecd in UEFI mode to complete my install. I'm having issues accessing my efivars though on my current install. Ultimately, I'd like to change the entry order in my UEFI boot menu. I can't seem to do this properly because the efivars are not available when running efibootmgr. Per this link, my kernel is set up appropriately.

/etc/portage/make.conf has the following line:
Code:
GRUB_PLATFORMS="efi-64"

Grub installed without error. Installing Grub also pulled in efibootmgr because of the line above.

When I manually try and mount the efivars using
Code:
mount -t efivars efivars /sys/firmware/efi/efivars
I get
Code:
mount: unknown filesystem type 'efivars'
.

I'm starting to think I didn't properly set up a UEFI environment. Can anyone assist me?

Thanks in advance.


Last edited by tirkaz on Sun Mar 05, 2017 3:04 am; edited 1 time in total
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sun Feb 26, 2017 5:10 am    Post subject: Reply with quote

tirkaz ...

that page is incorrect, it is 'efivarfs', not 'efivars', and you should be careful, you can brick the machine with this mounted rw, I'd suggest you mount 'readonly', or provide 'noauto' in fstab.

/etc/fstab:
efivarfs  /sys/firmware/efi/efivars  efivarfs  ro,nosuid,nodev,noexec,noatime 0 0

Code:
# mount -o remount,rw /sys/firmware/efi/efivars
# efibootmgr --bootorder XXXX,YYYY,ZZZZ
# mount -o remount,ro /sys/firmware/efi/efivars

That said, I don't use 'efivarfs', and if you use an older efibootmgr, ie =<sys-boot/efibootmgr-0.5.4-r1, you don't need to (as that's needed is 'efivars').

HTH & best ... khay
Back to top
View user's profile Send private message
tirkaz
n00b
n00b


Joined: 12 May 2016
Posts: 12

PostPosted: Sun Feb 26, 2017 8:37 am    Post subject: Reply with quote

khayyam,

Thank you for the help.

I tried your line in fstab and am getting
Code:
mount: unknown filesystem type 'efivarfs'


I'm using efibootmgr version 14, so if I understand correctly, I shouldn't need efivarfs, but need efivars. Is this correct?

Not sure what my next step is :(
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sun Feb 26, 2017 10:07 am    Post subject: Reply with quote

tirkaz wrote:
I tried your line in fstab and am getting 'mount: unknown filesystem type 'efivarfs''

tirkaz ... ahhh, I'd forgotten to mention that the wiki page you linked to doesn't mention enabling CONFIG_EFIVAR_FS.

tirkaz wrote:
I'm using efibootmgr version 14, so if I understand correctly, I shouldn't need efivarfs, but need efivars. Is this correct?

No, 0.5.4-r1, higher versions then went on to use efivarfs, so 14 will probably require efivars, and efivarfs. Again, I stuck with 0.5.4-r1 as for a while there were bugs with the efivarfs implimentation and/or efibootmgr ... where things stand now I don't know.

best ... khay
Back to top
View user's profile Send private message
tirkaz
n00b
n00b


Joined: 12 May 2016
Posts: 12

PostPosted: Sun Feb 26, 2017 8:04 pm    Post subject: Reply with quote

khayyam,

I have CONFIG_EFIVAR_FS built in as well. Same issue.

Perhaps the issue I'm facing is a bug with this particular version of efibootmgr? I'll try and downgrade to a previous version and see if the issue persists.

If anyone else has any other insight, I'd appreciate it.

Thank you.
Back to top
View user's profile Send private message
AMID_EVIL
n00b
n00b


Joined: 05 Feb 2016
Posts: 5

PostPosted: Wed Mar 01, 2017 2:20 am    Post subject: Reply with quote

tirkaz wrote:
khayyam,

I have CONFIG_EFIVAR_FS built in as well. Same issue.

Perhaps the issue I'm facing is a bug with this particular version of efibootmgr? I'll try and downgrade to a previous version and see if the issue persists.

If anyone else has any other insight, I'd appreciate it.

Thank you.

No, try to boot without grub, read article https://wiki.gentoo.org/wiki/EFI_stub_kernel
Make sure that you enabled all necessary variables, use efibootmgr to create boot-entity in UEFI.
You don't need any loader if your motherboard supports EFI.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Wed Mar 01, 2017 6:19 am    Post subject: Reply with quote

AMID_EVIL wrote:
No, try to boot without grub, read article https://wiki.gentoo.org/wiki/EFI_stub_kernel Make sure that you enabled all necessary variables, use efibootmgr to create boot-entity in UEFI. You don't need any loader if your motherboard supports EFI.

AMID_EVIL ... if the OP is having issues running efibootmgr then your suggestion of using efi_stub are of no use.

best ... khay
Back to top
View user's profile Send private message
Mr. T.
Guru
Guru


Joined: 26 Dec 2016
Posts: 477

PostPosted: Wed Mar 01, 2017 5:15 pm    Post subject: Reply with quote

I wonder if your partition scheme and filesystems are ok? Could you provide us these information, please?
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3076
Location: Illinois, USA

PostPosted: Wed Mar 01, 2017 8:16 pm    Post subject: Reply with quote

AMID_EVIL wrote:
You don't need any loader if your motherboard supports EFI.

UNLESS you want to have the ability to select a kernel to boot at boot time. That's the whole point of using grub or refind.
Back to top
View user's profile Send private message
tirkaz
n00b
n00b


Joined: 12 May 2016
Posts: 12

PostPosted: Fri Mar 03, 2017 2:45 am    Post subject: Reply with quote

helecho wrote:
I wonder if your partition scheme and filesystems are ok? Could you provide us these information, please?


Hello,

Code:
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sdb      8:16   0   1.8T  0 disk
├─sdb4   8:20   0   7.9G  0 part [SWAP]
├─sdb2   8:18   0    16M  0 part
├─sdb3   8:19   0 983.2G  0 part
└─sdb1   8:17   0 871.9G  0 part /mnt/hdd
sda      8:0    0 223.6G  0 disk
├─sda5   8:5    0 213.6G  0 part /
└─sda1   8:1    0    10G  0 part /boot


Code:
Device             Start         End     Sectors     Size Type
>>  /dev/sda1           2048    20973567    20971520      10G EFI System       
    /dev/sda5       20973568   468860927   447887360   213.6G Linux filesystem


If there's any other information I can provide please let me know.
Back to top
View user's profile Send private message
Mr. T.
Guru
Guru


Joined: 26 Dec 2016
Posts: 477

PostPosted: Fri Mar 03, 2017 12:19 pm    Post subject: Reply with quote

I advice you change the partition scheme unless you have unusual needs!
gdisk:
devices         size         mnt          type                     id
---------------------------------------------------------------------------------
/dev/sda1       128 MiB      /boot        ESP                      EF00
/dev/sda2       8 GiB        none         swap                     8200
/dev/sda3       30-80 GiB    /            Gentoo_System            8300

filesystems:
root# mkfs.vfat -F 32 /dev/sda1
root# mkswap /dev/sda2
root# mkfs.ext4 /dev/sda3

tirkaz wrote:
If there's any other information I can provide please let me know.

Indeed, the context is not clear:
tirkaz wrote:
I've installed Gentoo successfully a few months ago using the Wiki's Handbook.
I used sysrescuecd in UEFI mode to complete my install. I'm having issues accessing my efivars though on my current install.

We do not know if you have used a previous install and when you have tried to mount the efivarfs pseudo filesystem (before or after boot)?
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Fri Mar 03, 2017 1:03 pm    Post subject: Reply with quote

helecho wrote:
I advice you change the partition scheme unless you have unusual needs!

helecho ... why exactly? That would require they start from scratch and/or backup and replace the current install. There is nothing in the partitioning scheme that would cause mount to issue "unknown filesystem type 'efivarfs'" ... the problem is elsewhere.

@tirkaz ... please can you provide the output of the following:

Code:
# if [[ -f /proc/config.gz ]]; then zgrep EFI /proc/config || grep EFI /usr/src/linux-$(uname -r)/.config ; fi
# mount
# modprobe efivarfs
# cat /proc/filesystems
# dmesg | grep -i efi
# mount -o nosuid,nodev,noexec,noatime -t efivarfs efivarfs /sys/firmware/efi/efivars
# efibootmgr -v

best ... khay
Back to top
View user's profile Send private message
minsoehan
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2015
Posts: 101
Location: Yangon, Burma. (Mother Su's Country)

PostPosted: Fri Mar 03, 2017 1:17 pm    Post subject: Reply with quote

I think this page https://wiki.gentoo.org/wiki/Efibootmgr#Configuration may be helpful.

what does this
Code:
$ mount | grep efivars
output?
Back to top
View user's profile Send private message
tirkaz
n00b
n00b


Joined: 12 May 2016
Posts: 12

PostPosted: Sat Mar 04, 2017 2:23 am    Post subject: Reply with quote

helecho wrote:
I advice you change the partition scheme unless you have unusual needs!
gdisk:
devices         size         mnt          type                     id
---------------------------------------------------------------------------------
/dev/sda1       128 MiB      /boot        ESP                      EF00
/dev/sda2       8 GiB        none         swap                     8200
/dev/sda3       30-80 GiB    /            Gentoo_System            8300

filesystems:
root# mkfs.vfat -F 32 /dev/sda1
root# mkswap /dev/sda2
root# mkfs.ext4 /dev/sda3

tirkaz wrote:
If there's any other information I can provide please let me know.

Indeed, the context is not clear:
tirkaz wrote:
I've installed Gentoo successfully a few months ago using the Wiki's Handbook.
I used sysrescuecd in UEFI mode to complete my install. I'm having issues accessing my efivars though on my current install.

We do not know if you have used a previous install and when you have tried to mount the efivarfs pseudo filesystem (before or after boot)?


I'm not sure changing my partition scheme is going to be of help...

While doing the install that I'm currently working with, I reformatted /dev/sda5 from an NTFS and created /dev/sda1 as the EFI partition. I've tried the efivars after boot, as I'm not sure how I'd try them before boot.

Thank you.


Last edited by tirkaz on Sat Mar 04, 2017 3:47 am; edited 1 time in total
Back to top
View user's profile Send private message
tirkaz
n00b
n00b


Joined: 12 May 2016
Posts: 12

PostPosted: Sat Mar 04, 2017 2:25 am    Post subject: Reply with quote

minsoehan wrote:
I think this page https://wiki.gentoo.org/wiki/Efibootmgr#Configuration may be helpful.

what does this
Code:
$ mount | grep efivars
output?


The link above is what I referenced in my original post and what I'd been working with before I opened the thread.

This doesn't return anything, and when I attempt to mount it manually using the command in that thread, I get an error that the efivarfs is an unknown type of file system.

Thank you.
Back to top
View user's profile Send private message
tirkaz
n00b
n00b


Joined: 12 May 2016
Posts: 12

PostPosted: Sat Mar 04, 2017 5:03 am    Post subject: Reply with quote

khayyam wrote:
helecho wrote:
I advice you change the partition scheme unless you have unusual needs!

helecho ... why exactly? That would require they start from scratch and/or backup and replace the current install. There is nothing in the partitioning scheme that would cause mount to issue "unknown filesystem type 'efivarfs'" ... the problem is elsewhere.

@tirkaz ... please can you provide the output of the following:

Code:
# if [[ -f /proc/config.gz ]]; then zgrep EFI /proc/config || grep EFI /usr/src/linux-$(uname -r)/.config ; fi
# mount
# modprobe efivarfs
# cat /proc/filesystems
# dmesg | grep -i efi
# mount -o nosuid,nodev,noexec,noatime -t efivarfs efivarfs /sys/firmware/efi/efivars
# efibootmgr -v

best ... khay


Code:

[root@tuxbox tirkaz]# if [[ -f /proc/config.gz ]]; then zgrep EFI /proc/config || grep EFI /usr/src/linux-$(uname -r)/.config ; fi
CONFIG_EFI_PARTITION=y
CONFIG_EFI=y
CONFIG_EFI_STUB=y
# CONFIG_EFI_MIXED is not set
CONFIG_FB_EFI=y
CONFIG_DMI_SCAN_MACHINE_NON_EFI_FALLBACK=y
# EFI (Extensible Firmware Interface) Support
# CONFIG_EFI_VARS is not set
CONFIG_EFI_ESRT=y
CONFIG_EFI_RUNTIME_MAP=y
# CONFIG_EFI_FAKE_MEMMAP is not set
CONFIG_EFI_RUNTIME_WRAPPERS=y
# CONFIG_EFI_CAPSULE_LOADER is not set
# CONFIG_EFI_TEST is not set
CONFIG_UEFI_CPER=y
CONFIG_CACHEFILES=m
# CONFIG_CACHEFILES_DEBUG is not set
# CONFIG_CACHEFILES_HISTOGRAM is not set
CONFIG_EFIVAR_FS=m
# CONFIG_EARLY_PRINTK_EFI is not set
# CONFIG_EFI_PGT_DUMP is not set


Code:
[root@tuxbox tirkaz]# mount
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=10240k,nr_inodes=1009388,mode=755)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
/dev/sda5 on / type ext4 (rw,noatime,data=ordered)
tmpfs on /run type tmpfs (rw,nodev,relatime,size=811324k,mode=755)
mqueue on /dev/mqueue type mqueue (rw,nosuid,nodev,noexec,relatime)
shm on /dev/shm type tmpfs (rw,nosuid,nodev,noexec,relatime)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,nosuid,nodev,noexec,relatime)
selinuxfs on /sys/fs/selinux type selinuxfs (rw,relatime)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup_root on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,relatime,size=10240k,mode=755)
openrc on /sys/fs/cgroup/openrc type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib64/rc/sh/cgroup-release-agent.sh,name=openrc)
cpuset on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cpu on /sys/fs/cgroup/cpu type cgroup (rw,nosuid,nodev,noexec,relatime,cpu)
cpuacct on /sys/fs/cgroup/cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct)
blkio on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
memory on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
devices on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
freezer on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
net_cls on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
perf_event on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
/dev/sdb1 on /mnt/hdd type ext4 (rw,relatime,data=ordered)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nosuid,nodev,noexec,relatime)
none on /run/user/1000 type tmpfs (rw,relatime,mode=700,uid=1000)
/dev/sda1 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)


Code:
modprobe efivarfs
provides no output

Code:
[root@tuxbox tirkaz]# cat /proc/filesystems
nodev   sysfs
nodev   rootfs
nodev   ramfs
nodev   bdev
nodev   proc
nodev   cpuset
nodev   cgroup
nodev   cgroup2
nodev   tmpfs
nodev   devtmpfs
nodev   binfmt_misc
nodev   debugfs
nodev   tracefs
nodev   securityfs
nodev   sockfs
nodev   bpf
nodev   pipefs
nodev   hugetlbfs
nodev   devpts
   iso9660
nodev   pstore
nodev   mqueue
nodev   selinuxfs
   ext2
   ext3
   ext4
   btrfs
   reiserfs
   jfs
nodev   rpc_pipefs
nodev   nfs
nodev   nfs4
   xfs
   fuseblk
nodev   fuse
nodev   fusectl
   vfat


Code:
[root@tuxbox tirkaz]# dmesg | grep -i efi
[    0.000000] efi: EFI v2.31 by American Megatrends
[    0.000000] efi:  ESRT=0xdef7e998  ACPI 2.0=0xde7c4000  ACPI=0xde7c4000  SMBIOS=0xf05b0  MPS=0xfd670
[    0.000000] ACPI: UEFI 0x00000000DE7DE890 000042 (v01 ALASKA A M I    01072009      00000000)
[    0.000000] clocksource: refined-jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 1910969940391419 ns
[    0.514786] Registered efivars operations
[    3.204149] efifb: probing for efifb
[    3.204159] efifb: framebuffer at 0xf1000000, using 3072k, total 3072k
[    3.204161] efifb: mode is 1024x768x32, linelength=4096, pages=1
[    3.204162] efifb: scrolling: redraw
[    3.204164] efifb: Truecolor: size=8:8:8:8, shift=24:16:8:0
[    3.206322] fb0: EFI VGA frame buffer device
[    4.204798] tsc: Refined TSC clocksource calibration: 3599.997 MHz


Code:
[root@tuxbox tirkaz]# mount -o nosuid,nodev,noexec,noatime -t efivarfs efivarfs /sys/firmware/efi/efivars
mount: unknown filesystem type 'efivarfs'


Code:
[root@tuxbox tirkaz]# efibootmgr -v
EFI variables are not supported on this system.


Thank you.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sat Mar 04, 2017 10:03 am    Post subject: Reply with quote

tirkaz wrote:
Code:
# CONFIG_EFI_VARS is not set
[...]
CONFIG_EFIVAR_FS=m

tirkaz ... I'll state again, I'm not using efivarfs, but that (and the gentoo efibootmgr wiki) would seem to be wrong, I would expect EFIVAR_FS to depend on EFI_VARS. That seems to be supported by the fact that no efivarfs is shown in /proc/filesystems (after the module is loaded). If enabling this doesn't resolve the issue I can only suspect you're not booting efi (please check your BIOS/Firmware that no "legacy" mode, or what-have-you, is selected).

best ... khay
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5761

PostPosted: Sat Mar 04, 2017 6:23 pm    Post subject: Reply with quote

efibootmgr requires CONFIG_EFI_VARS. Everything else is fine.
Back to top
View user's profile Send private message
tirkaz
n00b
n00b


Joined: 12 May 2016
Posts: 12

PostPosted: Sat Mar 04, 2017 6:49 pm    Post subject: Reply with quote

Ant P. wrote:
efibootmgr requires CONFIG_EFI_VARS. Everything else is fine.

I can't seem to find this anywhere in menuconfig... Searching the string with / says it's in Firmware Drivers ---> EFI Support, but the only thing that looks similar in there is
Code:
EFI Variable Support via sysfs
which is built in

In my .config file in /usr/src/linux, It's set as
Code:
CONFIG_EFI_VARS=y


khayyam wrote:
tirkaz ... I'll state again, I'm not using efivarfs, but that (and the gentoo efibootmgr wiki) would seem to be wrong, I would expect EFIVAR_FS to depend on EFI_VARS. That seems to be supported by the fact that no efivarfs is shown in /proc/filesystems (after the module is loaded). If enabling this doesn't resolve the issue I can only suspect you're not booting efi (please check your BIOS/Firmware that no "legacy" mode, or what-have-you, is selected).


It was set on LEGACY+UEFI, I changed it to UEFI only, it successfully booted, but I'm still facing the same issue.

Perhaps I'm too dense to figure this out...

Thank you.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sat Mar 04, 2017 10:42 pm    Post subject: Reply with quote

tirkaz wrote:
Ant P. wrote:
efibootmgr requires CONFIG_EFI_VARS. Everything else is fine.

I can't seem to find this anywhere in menuconfig... Searching the string with / says it's in Firmware Drivers ---> EFI Support, but the only thing that looks similar in there is 'EFI Variable Support via sysfs' which is built in.

tirkaz ... that is the correct entry for CONFIG_EFI_VARS, however the above shows it's not enabled for the currently booted kernel. I suspect you have built a kernel but not copied it to /boot (correctly) ... or some issue like that

tirkaz wrote:
In my .config file in /usr/src/linux, It's set as 'CONFIG_EFI_VARS=y'

I provide the above command to check what was enabled and it shows "CONFIG_EFI_VARS is not set", this came from either /proc/config.gz or /usr/src/linux-$(uname -r)/.config so you're either not booting the kernel which has this set, or it's set for some other kernel than the version booted (you may have copied bzImage to /boot when /boot wasn't mounted). Please do the following:

Code:
# su -
# eselect kernel list
# eselect kernel set {n} # where '{n}' is the number provided by 'list'
# cd /usr/src/linux
# grep CONFIG_EFI_VARS .config || make menuconfig # enable CONFIG_EFI_VARS
# make && make modules_install
# mount /boot
# cp arch/x86/boot/bzImage /boot/vmlinuz-version.efi

You then need to either re-run grub-config, or do whatever you normally do to update your bootloader.

HTH & best ... khay
Back to top
View user's profile Send private message
tirkaz
n00b
n00b


Joined: 12 May 2016
Posts: 12

PostPosted: Sun Mar 05, 2017 3:03 am    Post subject: Reply with quote

khayyam wrote:
tirkaz wrote:
Ant P. wrote:
efibootmgr requires CONFIG_EFI_VARS. Everything else is fine.

I can't seem to find this anywhere in menuconfig... Searching the string with / says it's in Firmware Drivers ---> EFI Support, but the only thing that looks similar in there is 'EFI Variable Support via sysfs' which is built in.

tirkaz ... that is the correct entry for CONFIG_EFI_VARS, however the above shows it's not enabled for the currently booted kernel. I suspect you have built a kernel but not copied it to /boot (correctly) ... or some issue like that

tirkaz wrote:
In my .config file in /usr/src/linux, It's set as 'CONFIG_EFI_VARS=y'

I provide the above command to check what was enabled and it shows "CONFIG_EFI_VARS is not set", this came from either /proc/config.gz or /usr/src/linux-$(uname -r)/.config so you're either not booting the kernel which has this set, or it's set for some other kernel than the version booted (you may have copied bzImage to /boot when /boot wasn't mounted). Please do the following:

Code:
# su -
# eselect kernel list
# eselect kernel set {n} # where '{n}' is the number provided by 'list'
# cd /usr/src/linux
# grep CONFIG_EFI_VARS .config || make menuconfig # enable CONFIG_EFI_VARS
# make && make modules_install
# mount /boot
# cp arch/x86/boot/bzImage /boot/vmlinuz-version.efi

You then need to either re-run grub-config, or do whatever you normally do to update your bootloader.

HTH & best ... khay


Hello khayyam!

I followed your instructions and ended up with a kernel panic. I think there was a kernel panic because of a lack of an initial ramdisk.

I chrooted into a sysrescuecd, rebuilt kernel and ramdisk using the .config with the change you made, and all is well. I now have access to the efivars through efibootmgr.

I really appreciate your help khayyam. I can only assume the kernel with the changes wasn't properly being utilized. This is puzzling to me, but I think that I must have missed a step somewhere along the lines between configuring the kernel and actually getting grub to look at it.

Thank you very much!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum