Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ibus & ibus-anthy
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
emochi
n00b
n00b


Joined: 19 Jul 2016
Posts: 60
Location: Tokyo, Japan

PostPosted: Sun Mar 12, 2017 10:29 am    Post subject: Ibus & ibus-anthy Reply with quote

Hello.
When I try to install ibus & ibus-anthy, the following error message will be displayed.
Code:
user $ sudo emerge --ask ibus ibus-anthy

These are the packages that would be merged, in order:

Calculating dependencies

!!! Problem resolving dependencies for app-i18n/ibus
... done!

!!! The ebuild selected to satisfy "ibus" has unmet requirements.
- app-i18n/ibus-1.5.15::gentoo USE="X gtk introspection nls python -deprecated -gconf -gtk3 -test -vala -wayland" ABI_X86="64" PYTHON_TARGETS="python2_7"

  The following REQUIRED_USE flag constraints are unsatisfied:
    python? ( any-of ( deprecated ( gtk3 introspection ) ) )

  The above constraints are a subset of the following complete expression:
    any-of ( gtk gtk3 X ) deprecated? ( python ) vala? ( introspection ) python? ( python_targets_python2_7 any-of ( deprecated ( gtk3 introspection ) ) )
user $

Please give me advice to solve it.

[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2970
Location: Germany

PostPosted: Sun Mar 12, 2017 10:39 am    Post subject: Reply with quote

What happens if you enable the gtk3 useflag?
Back to top
View user's profile Send private message
emochi
n00b
n00b


Joined: 19 Jul 2016
Posts: 60
Location: Tokyo, Japan

PostPosted: Sun Mar 12, 2017 2:10 pm    Post subject: Reply with quote

Thanks a lot frostschutz.

I enable the gtk3 useflag.
I could not install ibus & ibus-anthy.
Instead, I was able to install scim & scim-anthy.

Many thanks.
Back to top
View user's profile Send private message
C5ace
Apprentice
Apprentice


Joined: 23 Dec 2013
Posts: 278
Location: Brisbane, Australia

PostPosted: Sun Mar 12, 2017 3:00 pm    Post subject: Reply with quote

Konichiwa emochi san,

My wife's laptop has app-i18n/ibus app-i18n/ibus-anthy installed (Xtc4 desktop):

emerge -vp app-i18n/ibus app-i18n/ibus-anthy:

[ebuild R ] app-i18n/ibus-1.5.12::gentoo USE="X gtk gtk3 introspection nls python -deprecated -gconf {-test} -vala -wayland" PYTHON_TARGETS="python2_7" 0 KiB

[ebuild R ] app-i18n/ibus-anthy-1.5.4::gentoo USE="nls -deprecated" PYTHON_TARGETS="python2_7" 0 KiB

Also these fonts:
media-fonts/font-jis-misc
media-fonts/font-sony-misc
media-fonts/intlfonts
media-fonts/ipamonafont
media-fonts/ja-ipafonts
media-fonts/kochi-substitute
media-fonts/mikachan-font-otf
media-fonts/mikachan-font-ttc
media-fonts/mikachan-font-ttf
media-fonts/sazanamiJapanese
Back to top
View user's profile Send private message
emochi
n00b
n00b


Joined: 19 Jul 2016
Posts: 60
Location: Tokyo, Japan

PostPosted: Mon Mar 13, 2017 4:51 am    Post subject: Reply with quote

Konnichiwa C5ace san,

I tried installing again, but the result was as follows.

Code:
user $ sudo emerge -vp app-i18n/ibus app-i18n/ibus-anthy

These are the packages that would be merged, in order:

Calculating dependencies

!!! Problem resolving dependencies for app-i18n/ibus
... done!

!!! The ebuild selected to satisfy "app-i18n/ibus" has unmet requirements.
- app-i18n/ibus-1.5.15::gentoo USE="X gtk introspection nls python -deprecated -gconf -gtk3 -test -vala -wayland" ABI_X86="64" PYTHON_TARGETS="python2_7"

  The following REQUIRED_USE flag constraints are unsatisfied:
    python? ( any-of ( deprecated ( gtk3 introspection ) ) )

  The above constraints are a subset of the following complete expression:
    any-of ( gtk gtk3 X ) deprecated? ( python ) vala? ( introspection ) python? ( python_targets_python2_7 any-of ( deprecated ( gtk3 introspection ) ) )

user $


Thank you very much for your advice.

[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
C5ace
Apprentice
Apprentice


Joined: 23 Dec 2013
Posts: 278
Location: Brisbane, Australia

PostPosted: Mon Mar 13, 2017 6:04 am    Post subject: Reply with quote

emochi wrote:
Konnichiwa C5ace san,

I tried installing again, but the result was as follows.

Quote:
user $ sudo emerge -vp app-i18n/ibus app-i18n/ibus-anthy

These are the packages that would be merged, in order:

Calculating dependencies

!!! Problem resolving dependencies for app-i18n/ibus
... done!

!!! The ebuild selected to satisfy "app-i18n/ibus" has unmet requirements.
- app-i18n/ibus-1.5.15::gentoo USE="X gtk introspection nls python -deprecated -gconf -gtk3 -test -vala -wayland" ABI_X86="64" PYTHON_TARGETS="python2_7"

The following REQUIRED_USE flag constraints are unsatisfied:
python? ( any-of ( deprecated ( gtk3 introspection ) ) )

The above constraints are a subset of the following complete expression:
any-of ( gtk gtk3 X ) deprecated? ( python ) vala? ( introspection ) python? ( python_targets_python2_7 any-of ( deprecated ( gtk3 introspection ) ) )

user $


Thank you very much for your advice.


You are using unstable app-i18n/ibus-1.5.15!

The only difference I see is that you have the '-gtk3' instead of 'gtk3' use flag.

My make.conf file USE="-kde -gnome -qt -qt5 -ipv6 -bluetooth -systemd -gtk2"

Try:
Code:

emerge -av --unmerge app-i18n/ibus app-i18n/ibus-anthy


Then:
Code:

emerge --sync
emerge --update --deep --with-bdeps=y --newuse --backtrack=300 --changed-deps=y --keep-going=y @world -va


Fix all errors and repeat.

When no errors do:
Code:

emerge --depclean
revdep-rebuild


If all runs without errors:
Code:

USE="gtk3" emerge -av =app-i18n/ibus-1.5.12
emerge -av =app-i18n/ibus-anthy-1.5.4


If this does not work, post the contents of /etc/portage/make.conf, /etc/locale.gen and the output of emerge --info.
Back to top
View user's profile Send private message
Syl20
Guru
Guru


Joined: 04 Aug 2005
Posts: 564
Location: France

PostPosted: Mon Mar 13, 2017 8:52 am    Post subject: Re: Ibus & ibus-anthy Reply with quote

emochi wrote:
Code:
  The following REQUIRED_USE flag constraints are unsatisfied:
    python? ( any-of ( deprecated ( gtk3 introspection ) ) )

This means you need either the "deprecated" USE flag enabled, or both the "gtk3" and "introspection" ones.
Back to top
View user's profile Send private message
emochi
n00b
n00b


Joined: 19 Jul 2016
Posts: 60
Location: Tokyo, Japan

PostPosted: Mon Mar 13, 2017 12:59 pm    Post subject: Reply with quote

Thanks a lot C5ace.
Thanks a lot Syl20.

I was able to install ibus and ibus-anthy.
However, I found that ibus-anthy can not be used for Japanese input.
I found that ibus-anthy does not work.

Many thanks.
Back to top
View user's profile Send private message
C5ace
Apprentice
Apprentice


Joined: 23 Dec 2013
Posts: 278
Location: Brisbane, Australia

PostPosted: Tue Mar 14, 2017 10:30 am    Post subject: Reply with quote

emochi wrote:
Thanks a lot C5ace.
Thanks a lot Syl20.

I was able to install ibus and ibus-anthy.
However, I found that ibus-anthy can not be used for Japanese input.
I found that ibus-anthy does not work.

Many thanks.


Are you using Xfce as Desktop?
Back to top
View user's profile Send private message
emochi
n00b
n00b


Joined: 19 Jul 2016
Posts: 60
Location: Tokyo, Japan

PostPosted: Tue Mar 14, 2017 11:35 am    Post subject: Reply with quote

I am using Xfce as desktop.
Back to top
View user's profile Send private message
emochi
n00b
n00b


Joined: 19 Jul 2016
Posts: 60
Location: Tokyo, Japan

PostPosted: Tue Mar 14, 2017 1:17 pm    Post subject: Reply with quote

Thanks a lot C5ace.

About construction of Japanese input system
Code:
user $ sudo emerge --ask media-fonts/ja-ipafonts
user $ sudo emerge --ask media-fonts/vlgothic
user $ sudo emerge --ask media-fonts/monafont
user $ sudo emerge --ask media-fonts/ipamonafont
user $ sudo emerge --ask media-fonts/sazanami
user $ sudo emerge --ask scim scim-anthy

user $ sudo nano ~/.bash_profile
I wrote it as follows.
export LC_CTYPE=ja_JP.UTF-8
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim

user $ sudo nano ~/.xsession
I added "scim - d" as below.
exec startxfce4 --with-ck-launch
scim -d

user $ sudo nano /etc/scim/global
I changed as follows.
/SupportedUnicodeLocales = ja_JP.UTF-8
/DefaultPanelProgram = scim-panel-gtk
/DefaultConfigModule = simple
/DefaultSocketFrontEndAddress = local:/tmp/scim-socket-frontend
/DefaultSocketIMEngineAddress = local:/tmp/scim-socket-frontend
/DefaultSocketConfigAddress = local:/tmp/scim-socket-frontend
/DefaultPanelSocketAddress = local:/tmp/scim-panel-socket
/DefaultHelperManagerSocketAddress = local:/tmp/scim-helper-manager-socket
/DefaultSocketTimeout = 5000


Many thanks.
Back to top
View user's profile Send private message
C5ace
Apprentice
Apprentice


Joined: 23 Dec 2013
Posts: 278
Location: Brisbane, Australia

PostPosted: Tue Mar 14, 2017 1:56 pm    Post subject: Reply with quote

emochi wrote:
I am using Xfce as desktop.


I presume you have Japanese fonts installed and activated.

Go to Applications -> Settings -> IBus Preferences and under "General" tab set:
-Next input method to "<super>space"
-Candidates orientation to "Vertical"
-Show Property panel to "Always"
Tick "Show icon on system tray"
Tick "Embed preedit text in application window"

Under "Input Method" tab, Add
- English - English (US)
- Japanese - Anthy

Under "Advance" tab
Tick "Share the same input method among all applications"

I presulem you have a US keyboard.

You should now see icon "EN" on the system tray. Open Click on the icon and select "Japanese - Anthy". You should now see the Anthy icon.

Open a text editor or Libre Office and type shizuoka. If all OK you should get しずおか then hit the space bar and Enter your should get 静岡.

Clicking a second time on the Anthy icon brings up a menu to configure the input method, dictionary, preferences and select English.

If you get stuck, read:
https://wiki.gentoo.org/wiki/How_to_read_and_write_in_Japanese
Back to top
View user's profile Send private message
emochi
n00b
n00b


Joined: 19 Jul 2016
Posts: 60
Location: Tokyo, Japan

PostPosted: Wed Mar 15, 2017 9:58 am    Post subject: Reply with quote

Thanks a lot C5ace.
Thank you very much for your kind advices.
Many thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum