Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
About mail-client/mutt
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
emochi
n00b
n00b


Joined: 19 Jul 2016
Posts: 60
Location: Tokyo, Japan

PostPosted: Tue Mar 14, 2017 6:38 am    Post subject: About mail-client/mutt Reply with quote

Hello.
I can not install 'mail-client/mutt'.
Quote:
user $ sudo emerge --ask mail-client/mutt

These are the packages that would be merged, in order:

Calculating dependencies i

!!! Problem resolving dependencies for mail-client/mutt
... done!

!!! The ebuild selected to satisfy "mail-client/mutt" has unmet requirements.
- mail-client/mutt-1.8.0::gentoo USE="berkdb crypt gdbm hcache nls ssl -debug -doc (-gnutls) -gpg -idn -imap -kerberos -libressl -lmdb -mbox -nntp -notmuch -pop -qdbm -sasl (-selinux) -sidebar -slang -smime -smtp -tokyocabinet -vanilla" ABI_X86="64"

The following REQUIRED_USE flag constraints are unsatisfied:
hcache? ( exactly-one-of ( berkdb gdbm lmdb qdbm tokyocabinet ) )

The above constraints are a subset of the following complete expression:
hcache? ( exactly-one-of ( berkdb gdbm lmdb qdbm tokyocabinet ) ) imap? ( ssl ) pop? ( ssl ) nntp? ( ssl ) smime? ( ssl !gnutls ) smtp? ( ssl ) sasl? ( any-of ( imap pop smtp nntp ) ) kerberos? ( any-of ( imap pop smtp nntp ) )

user $

Please give me advice.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21754
Location: here

PostPosted: Tue Mar 14, 2017 6:54 am    Post subject: Reply with quote

Code:
The following REQUIRED_USE flag constraints are unsatisfied:
hcache? ( exactly-one-of ( berkdb gdbm lmdb qdbm tokyocabinet ) )

Message tell you that you have set hcache you can have only one of these "berkdb gdbm lmdb qdbm tokyocabinet" use flags.
You need to disable or berkdb or gdbm if you want hcache with package.use
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
emochi
n00b
n00b


Joined: 19 Jul 2016
Posts: 60
Location: Tokyo, Japan

PostPosted: Tue Mar 14, 2017 7:48 am    Post subject: Reply with quote

Thanks a lot fedeliallalinea.

I was able to install mail-client/mutt.
Code:
user $ sudo emerge -av =mail-client/mutt-1.7.2

Many thanks.
Back to top
View user's profile Send private message
emochi
n00b
n00b


Joined: 19 Jul 2016
Posts: 60
Location: Tokyo, Japan

PostPosted: Tue Mar 14, 2017 11:37 am    Post subject: Reply with quote

Please tell me how to set up sending and receiving mail using mutt.
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Tue Mar 14, 2017 12:11 pm    Post subject: Reply with quote

emochi wrote:
Please tell me how to set up sending and receiving mail using mutt.

http://wiki.gentoo.org/wiki/mutt
_________________
"Growth for the sake of growth is the ideology of the cancer cell." Edward Abbey
Back to top
View user's profile Send private message
emochi
n00b
n00b


Joined: 19 Jul 2016
Posts: 60
Location: Tokyo, Japan

PostPosted: Tue Mar 14, 2017 1:42 pm    Post subject: Reply with quote

Thanks a lot josephg.

It seems very difficult to set Mutt.
With my ability, it may be slightly impossible.
Quote:
Setting mutt
user $ sudo mkdir -p ~/.mutt/cache/headers
user $ sudo mkdir -p ~/.mutt/cache/bodies
user $ sudo touch ~/.mutt/certificates
user $ sudo touch ~/.mutt/muttrc

user $ sudo nano ~/.mutt/muttrc

set ssl_starttls = yes
set ssl_force_tls = yes
set imap_user = ‘username@gmail.com’
set imap_pass = ‘password’
set from = ’username@gmail.com’
set realname = ’Usuha Emochi’
set folder = ‘imaps://imap.gmail.com/’
set spoolfile = ‘imaps://imap.gmail.com/INBOX’
set postponed = ‘imaps://imap.gmail.com/[Gmail]/Drafts’
set header_cache = ‘~/.mutt/cache/headers’
set message_cachedir = ‘~/.mutt/cache/bodies’
set certificate_file = ‘~/.mutt/certificates’
set smtp_url = ‘smtps://username@gmail.com:password@smtp.gmail.com:465/’
set move = no
set imap_keepalive = 900

It is not possible to improve the above setting and use it.


Last edited by emochi on Thu Mar 16, 2017 8:45 am; edited 3 times in total
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Tue Mar 14, 2017 2:24 pm    Post subject: Reply with quote

emochi ...

in the above you don't have USE='imap smtp sasl' set ... all of which are needed for imap, smtp, and tls.

best ... khay
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 260
Location: Northern California

PostPosted: Wed Mar 15, 2017 7:49 am    Post subject: Reply with quote

emochi...

Like khayyam said, you either need 'imap smtp sasl' USE flags for direct communication between mutt and your ISP's mail server (the 'Outlook' way), or if you're using a local mbox mail spool (the 'Unix' way) you need to set up the receive side (eg fetchmail and optionally procmail) and the sending side (eg exim) of the mail spool. The latter method is the 'power user' approach to mutt mail, but getting the setup right is a little tricky. There's also a plethora of other mbox transports like dovecot, postfix, getmail, msmtp, offlineimap, etc. etc. Look around the Network and Security forum for more examples of the various ways mutt can be set up.
Back to top
View user's profile Send private message
emochi
n00b
n00b


Joined: 19 Jul 2016
Posts: 60
Location: Tokyo, Japan

PostPosted: Wed Mar 15, 2017 10:56 am    Post subject: Reply with quote

Thanks a lot khayyam.
Thanks a lot radio_flyer.
Quote:
user $ mutt
Error on line 1 of /home/pure/.mutt/muttrc: ssl_starttls is unknown variable
Error on line 2 of /home/pure/.mutt/muttrc: ssl_force_tls is an unknown variable
Error in line 3 of /home/pure/.mutt/muttrc: imap_user is an unknown variable
Error in line 4 of /home/pure/.mutt/muttrc: imap_pass is an unknown variable
Error in line 11 of /home/pure/.mutt/muttrc: message_cachedir is an unknown variable
Error on line 12 in /home/pure/.mutt/muttrc: certificate_file is an unknown variable
Error in line 13 of /home/pure/.mutt/muttrc: smtp_url is an unknown variable
Error at line 15 in /home/pure/.mutt/muttrc: imap_keepalive is an unknown variable
Error in source: /home/pure/.mutt/muttrc
I need something to continue ...
user $

My make.conf file USE="bindist xa libkms imap smtp sasl"
Should I stop by my skills?
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Wed Mar 15, 2017 12:35 pm    Post subject: Reply with quote

emochi ... I think it's due to your use of backticks, and (perhaps) spaces, please try the following:

~/.mutt/muttrc:
set ssl_starttls="yes"
set ssl_force_tls="yes"
set imap_user="user_name@gmail.com"
set imap_pass="password"
set from="user_name@gmail.com"
set realname="E Mochi"
set folder="imaps://imap.gmail.com/"
set spoolfile="imaps://imap.gmail.com/INBOX"
set postponed="imaps://imap.gmail.com/[Gmail]/Drafts"
set header_cache="~/.mutt/cache/headers"
set message_cachedir="~/.mutt/cache/bodies"
set certificate_file="~/.mutt/certificates"
set smtp_url="smtps://user_name@gmail.com:password@smtp.gmail.com:465/"
set move="no"
set imap_keepalive="900"

Also, you should make sure that ~/.mutt/certificates exists, and has the correct permissions:

Code:
% touch ~/.mutt/certificates
% chmod u+rw,go-rwx ~/.mutt/certificates

Also, having 'USE="imap smtp sasl" in make.conf doesn't mean the package is built with those useflags, if you change them you are required to rebuild the package (I assume you did but I'd prefer not to trust this is the case):

/etc/portage/package.use:
mail-client/mutt imap smtp sasl smime

Code:
# emerge --ask --changed-use mail-client/mutt

To use radio_flyer's description, I use "the unix way", mail-mta/postfix for MTA (which is setup to forward mail to various mailservers based on the sender) and net-mail/offlineimap for grabing mail from imap. This means all mail is available (offline) and outgoing mail can be defered (so, held) if the machine is offline. I have used mutt's builtin smtp/imap and it worked, but being able to compose/send mail 'offline' is a necessity, as I do all mail on a laptop (though I have a fallback mutt setup on a remote machine that can be accessed via ssh).

HTH & best ... khay
Back to top
View user's profile Send private message
emochi
n00b
n00b


Joined: 19 Jul 2016
Posts: 60
Location: Tokyo, Japan

PostPosted: Wed Mar 15, 2017 4:50 pm    Post subject: Reply with quote

Thanks a lot khayyam.

The following error message was displayed.
Code:
user $ sudo emerge --ask --changed-use mail-client/mutt

These are the packages that would be merged, in order:

Calculating dependencies                               

!!! Problem resolving dependencies for mail-client/mutt
... done!

!!! The ebuild selected to satisfy "mail-client/mutt" has unmet requirements.
- mail-client/mutt-1.8.0::gentoo USE="berkdb crypt gdbm hcache nls ssl -debug -doc (-gnutls) -gpg -idn -imap -kerberos -libressl -lmdb -mbox -nntp -notmuch -pop -qdbm -sasl (-selinux) -sidebar -slang -smime -smtp -tokyocabinet -vanilla" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    hcache? ( exactly-one-of ( berkdb gdbm lmdb qdbm tokyocabinet ) )

  The above constraints are a subset of the following complete expression:
    hcache? ( exactly-one-of ( berkdb gdbm lmdb qdbm tokyocabinet ) ) imap? ( ssl ) pop? ( ssl ) nntp? ( ssl ) smime? ( ssl !gnutls ) smtp? ( ssl ) sasl? ( any-of ( imap pop smtp nntp ) ) kerberos? ( any-of ( imap pop smtp nntp ) )

user $

Code:
/etc/portage/package.use
mail-client/mutt imap smtp sasl smime

What kind of operation procedure should this be done?
I am very concerned with the rudimentary question.
Code:
user $ ls /etc/portage/package.use/
use
user $ cat /etc/portage/package.use/
cat: /etc/portage/package.use/: Is a directory
user $ sudo echo "mail-client/mutt imap smtp sasl smime" >> /etc/portage/package.use
bash: /etc/portage/package.use: Is a directory

root # echo "mail-client/mutt imap smtp sasl smime" >> /etc/portage/package.use
bash: /etc/portage/package.use: Is a directory
root #


[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 260
Location: Northern California

PostPosted: Wed Mar 15, 2017 6:37 pm    Post subject: Reply with quote

emochi, check out this forum post for the differences between using a directory or a file for /etc/portage/package.use:

https://forums.gentoo.org/viewtopic-t-1045470-start-0.html

If there's nothing in the directory, you can just rmdir it and then your echo command will work. If you keep the directory format, just echo the mutt USE flags into a file inside the directory, eg:
# echo "mail-client/mutt -berkdb imap smtp sasl smime" > /etc/portage/package.use/mutt

Note that I also turned off the berkdb USE flag because you can only have one database selected when compiling mutt, and by default your selected profile (or the ebuild, didn't check) enables both berkdb and gdbm.
Alternatively, feel free to disable gdbm and use berkdb (or turn off both and use one of the other ones on the hcache? line).
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Wed Mar 15, 2017 7:04 pm    Post subject: Reply with quote

emochi wrote:
The following error message was displayed.

user $ sudo emerge --ask --changed-use mail-client/mutt:
  The following REQUIRED_USE flag constraints are unsatisfied:
    hcache? ( exactly-one-of ( berkdb gdbm lmdb qdbm tokyocabinet ) )

emochi ... with USE=hcache set you can only set "exactly one of" 'berkdb' or 'gdbm':

/etc/portage/package.use:
mail-client/mutt imap smtp sasl smime -gdbm

Note that I'm using 1.5.24-r2 (stable), which doesn't have the hcache useflag, and I can build with both 'berkdb' and 'gdbm' useflags enabled, the ~arch/unstable package has all three as +IUSE ...

equery -NC u =mail-client/mutt-1.8.0 | egrep '(berkdb|gdbm|hcache)':
 + + berkdb   : Add support for sys-libs/db (Berkeley DB for MySQL)
 + + gdbm     : Add support for sys-libs/gdbm (GNU database libraries)
 + - hcache   : Enable header cache

That will enevitably cause the above error, and is testament to why using ~arch requires the skills to do so.

emochi wrote:
khayyam wrote:
/etc/portage/package.use:
mail-client/mutt imap smtp sasl smime

What kind of operation procedure should this be done? I am very concerned with the rudimentary question.

package.use is a directory, but the above is a designation (as it use to be a file), the filename(s) within this are arbitrary so I generally don't stipulate the filename (because I don't know how yours may, or may not, be configured) ... anyhow, simply provide a suitable filename:

Code:
# echo "mail-client/mutt imap smtp sasl smime -gdbm" >> /etc/portage/package.use/$(uname -m).package.use

or ... as you seem to be using sudo for system administation:

Code:
% echo "mail-client/mutt imap smtp sasl smime -gdbm" | sudo tee -a /etc/portage/package.use/$(uname -m).package.use

HTH & best ... khay
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 260
Location: Northern California

PostPosted: Wed Mar 15, 2017 7:49 pm    Post subject: Reply with quote

khayyam, I was happily using stable mutt too on my stable system until last week when gpgme hit the stable tree. Now there's this:

https://bugs.gentoo.org/show_bug.cgi?id=604902

However, other bug reports show issues with the 1.7 series (duplicate emails etc), so I just moved to 1.8.0 and haven't had any issues with it.

The stable tree is a bit of mess right now with mutt. Until the devs sort it out going ~ with 1.8.0 seems to be the only option. I'm surprised you haven't run into that issue yet.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Wed Mar 15, 2017 8:22 pm    Post subject: Reply with quote

radio_flyer wrote:
khayyam, I was happily using stable mutt too on my stable system until last week when gpgme hit the stable tree. Now there's this: https://bugs.gentoo.org/show_bug.cgi?id=604902

radio_flyer ... thanks for the heads up ... I'm not effected because I don't have mail-client/mutt[gpg] as I don't use gpgme. I configure gpg via muttrc and that is all gpgme is used for (ie, all you need do is set 'set crypt_use_gpgme=yes'), otherwise (sans gpgme) you need to do something like this.

BTW, I think the gpg useflag for mutt is misleading, people may believe that you can't use gpg without this enabled ... which is incorrect. The useflag should probably be 'gpgme', as that is all it enables.

thanks again & best ... khay
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 260
Location: Northern California

PostPosted: Wed Mar 15, 2017 9:33 pm    Post subject: Reply with quote

Same here khayyam, my .mutt_gpgrc dates from 2005 and looks a lot like your example.

However, I ran across this page a while back:
http://henrytodd.org/notes/2014/simpler-gnupg-mutt-config-with-gpgme/

and decided to give it a try. I still keep the standard gpgrc around also so I can bounce back and forth as necessary depending on what is broken or not in portage :lol:

BTW, I totally agree with you about the gpg USE flag.
Back to top
View user's profile Send private message
emochi
n00b
n00b


Joined: 19 Jul 2016
Posts: 60
Location: Tokyo, Japan

PostPosted: Thu Mar 16, 2017 4:40 am    Post subject: Reply with quote

Thanks a lot khayyam.
Thanks a lot radio_flyer.

Code:
user $ sudo emerge -av =mail-client/mutt-1.7.2

user $ sudo mkdir -p ~/.mutt/cache/headers
user $ sudo mkdir -p ~/.mutt/cache/bodies
user $ sudo touch ~/.mutt/certificates
user $ sudo chmod u+rw,go-rwx ~/.mutt/certificates
user $ sudo touch ~/.mutt/muttrc

user $ sudo nano ~/.mutt/muttrc

set ssl_starttls="yes"
set ssl_force_tls="yes"
set imap_user="username@gmail.com"
set imap_pass="password"
set from="username@gmail.com"
set realname="Usuha Emochi"
set folder="imaps://imap.gmail.com/"
set spoolfile="imaps://imap.gmail.com/INBOX"
set postponed="imaps://imap.gmail.com/[Gmail]/Drafts"
set header_cache="~/.mutt/cache/headers"
set message_cachedir="~/.mutt/cache/bodies"
set certificate_file="~/.mutt/certificates"
set smtp_url="smtps://username@gmail.com:password@smtp.gmail.com:465/"
set move="no"
set imap_keepalive="900"

user $ echo "mail-client/mutt imap smtp sasl smime -gdbm" | sudo tee -a /etc/portage/package.use/$(uname -m).package.use

user $ sudo emerge --ask --changed-use mail-client/mutt

I appreciate your kind advices.
I can send and receive e-mails using mail-client/mutt.
Thank you very much.
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Wed Mar 29, 2017 10:34 pm    Post subject: Reply with quote

except for the emerge, i would not sudo any of your following commands.
_________________
"Growth for the sake of growth is the ideology of the cancer cell." Edward Abbey
Back to top
View user's profile Send private message
emochi
n00b
n00b


Joined: 19 Jul 2016
Posts: 60
Location: Tokyo, Japan

PostPosted: Thu Mar 30, 2017 10:05 am    Post subject: Reply with quote

Thanks a lot josephg.
I appreciate your kind advices here.
Many thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum