Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
BricsCAD
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
A.S. Pushkin
Guru
Guru


Joined: 09 Nov 2002
Posts: 304
Location: dx/dt, dy/dt, dz/dt, t

PostPosted: Mon Apr 03, 2017 2:10 pm    Post subject: BricsCAD Reply with quote

I have some interest in BricsCAD. I note support for Fedora, OpenSuSE and Ubuntu.
I understand why Gentoo is not supported, but I wonder if it might be possible.
My laptop is a Dell d620 so I may install Fedora or OpenSuSE as it's rather gutless to run
virtualbox as compared to my desktop with an i7 and muc ram.

Being not a programmer I'm not sure how I might compare OpenSuSE to Gentoo, that is to see
what my Gentoo box lacks as compared to OpenSuSE.

Is this a rather fruitless waste of time to do?

I may need to run Rhino on the laptop, as well, which is not available for Linux. That's for a
boat design course I want to take this summer.

Any suggestions from you would be appreciated.
_________________
ASPushkin

"In a time of universal deceit - telling the truth is a revolutionary act." -- George Orwell
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22219
Location: here

PostPosted: Mon Apr 03, 2017 2:30 pm    Post subject: Reply with quote

I think is possible to run this program on Gentoo.
In download page of BricsCAD I see that in addition to Ubuntu/Fedora/OpenSuse exists also a 'Custom Installation' (I think there is a self extracting binary '.bin').
The second step is to check if all dependency are included in .bin or otherwise available in portage tree.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
A.S. Pushkin
Guru
Guru


Joined: 09 Nov 2002
Posts: 304
Location: dx/dt, dy/dt, dz/dt, t

PostPosted: Mon Apr 03, 2017 10:49 pm    Post subject: BricsCAD Reply with quote

fedeliallalinea thanks for the reply. I may have missed that point you make.

I'll work on that and post if I am able to get it working.

Thanks again!
_________________
ASPushkin

"In a time of universal deceit - telling the truth is a revolutionary act." -- George Orwell
Back to top
View user's profile Send private message
A.S. Pushkin
Guru
Guru


Joined: 09 Nov 2002
Posts: 304
Location: dx/dt, dy/dt, dz/dt, t

PostPosted: Mon May 01, 2017 4:47 am    Post subject: BricsCAD [Solved in part] Reply with quote

For now I've found another solution for me. Other may find a more direct means.

Since BricsCAD is directly available for Ubuntu, Fedora and OpenSUSE I decided
to attempt installing it into Virtualbox. Success!!

I may attempt a direct install in Gentoo, but running rpm there were some dependency issues
for Gentoo. I have an Epson Perfection V550 Scanner and there are rpms available. This has
been another issue. This seems to function as well in Virtualbox.

Often Gentoo is a bit painful as now (qt issues and now perl issues), but I want to continue
with Gentoo so using another where RPMs are available seems a good avenue.

CPU and RAM makes it possible.

Thanks

EDIT:

I ran rpm against the latest version of BricsCAD, BricsCAD-V17.1.22-1-en_US.x86_64.rpm

Here is the output:

[code]
error: Failed dependencies:
libc.so.6()(64bit) is needed by bricscadv17-17.1.22-1.x86_64
libstdc++.so.6()(64bit) is needed by bricscadv17-17.1.22-1.x86_64
libexpat.so.1()(64bit) is needed by bricscadv17-17.1.22-1.x86_64
libfontconfig.so.1()(64bit) is needed by bricscadv17-17.1.22-1.x86_64
libICE.so.6()(64bit) is needed by bricscadv17-17.1.22-1.x86_64
libcups.so.2()(64bit) is needed by bricscadv17-17.1.22-1.x86_64
libuuid.so.1()(64bit) is needed by bricscadv17-17.1.22-1.x86_64
libgtk-x11-2.0.so.0()(64bit) is needed by bricscadv17-17.1.22-1.x86_64
libSM.so.6()(64bit) is needed by bricscadv17-17.1.22-1.x86_64
libGLU.so.1()(64bit) is needed by bricscadv17-17.1.22-1.x86_64
libclearlooks.so()(64bit) is needed by bricscadv17-17.1.22-1.x86_64
libgthread-2.0.so.0()(64bit) is needed by bricscadv17-17.1.22-1.x86_64
libpng12.so.0()(64bit) is needed by bricscadv17-17.1.22-1.x86_64
libpth.so.20()(64bit) is needed by bricscadv17-17.1.22-1.x86_64
libcurl.so.4()(64bit) is needed by bricscadv17-17.1.22-1.x86_64
libfreetype.so.6()(64bit) is needed by bricscadv17-17.1.22-1.x86_64
/bin/sh is needed by bricscadv17-17.1.22-1.x86_64
[code]

I'm missing libstdc++.so.6 (have the wrong version), libclearlooks.so(missing), libpng12.so.0(missing),
libpth.so.20 (missing).

I suppose the next step is to determine if there is a package I can install that will fix this issue.

Thanks
_________________
ASPushkin

"In a time of universal deceit - telling the truth is a revolutionary act." -- George Orwell
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum