Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge dev-lang/php-7.0.15 unmet requirements when updating
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Whome001
n00b
n00b


Joined: 12 Apr 2014
Posts: 10

PostPosted: Thu Apr 06, 2017 6:40 am    Post subject: emerge dev-lang/php-7.0.15 unmet requirements when updating Reply with quote

I have been able to update my web server(apache2,php,mariadb) for few years but now am blocked by the some magic gentoo issue. This is the sysout log and portage configuration files.

emerge --ask --verbose --update --deep world
Code:

These are the packages that would be merged, in order:
Calculating dependencies /
!!! Problem resolving dependencies for dev-lang/php from @selected            ... done!

!!! The ebuild selected to satisfy "dev-lang/php" has unmet requirements.
- dev-lang/php-7.0.15::gentoo USE="acl apache2 berkdb bzip2 cli crypt ctype fileinfo filter gdbm hash iconv ipv6 json ldap ldap-sasl mysql nls opcache phar posix readline session simplexml ssl tokenizer unicode xml zlib -bcmath -calendar -cdb -cgi -cjk -coverage -curl -debug -embed -enchant -exif (-firebird) -flatfile -fpm -ftp -gd -gmp -imap -inifile -intl -iodbc -kerberos -libedit (-libressl) -mhash -mssql -mysqli -oci8-instant-client -odbc -pcntl -pdo -phpdbg -postgres -qdbm -recode (-selinux) -sharedmem -snmp -soap -sockets -spell -sqlite -systemd -sysvipc -threads -tidy -truetype -wddx -webp -xmlreader -xmlrpc -xmlwriter -xpm -xslt -zip" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    mysql? ( any-of ( mysqli pdo ) )

  The above constraints are a subset of the following complete expression:
    cli? ( exactly-one-of ( readline libedit ) ) truetype? ( gd ) webp? ( gd ) cjk? ( gd ) exif? ( gd ) xpm? ( gd ) gd? ( zlib ) simplexml? ( xml ) soap? ( xml ) wddx? ( xml ) xmlrpc? ( any-of ( xml iconv ) ) xmlreader? ( xml ) xslt? ( xml ) ldap-sasl? ( ldap ) mhash? ( hash ) phar? ( hash ) qdbm? ( !gdbm ) readline? ( !libedit ) recode? ( !imap !mysqli ) sharedmem? ( !threads ) mysql? ( any-of ( mysqli pdo ) ) any-of ( cli cgi fpm apache2 embed phpdbg )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


/etc/portage/package.use
Code:
#dev-lang/php apache2 cgi cli mysql pdo simplexml xml
#dev-lang/php apache2 cli mysql pdo simplexml xml
#=dev-lang/php-5* -* cli cgi apache2  mysql pdo  simplexml xml

dev-lang/php apache2
=dev-lang/php-5* -* cli readline cgi apache2 ctype curl crypt fastbuild force-cgi-redirect ftp gd hash iconv ipv6 memlimit mysql mcrypt nls pcre pic posix pdo reflection session simplexml soap sockets spl sqlite ssl tokenizer truetype xml xmlreader xmlwriter xsl zlib zip mbstring nls unicode filter mysqli mysqlnd json

net-misc/ntp caps

## busybox cannot use static and pam flags together, disable pam
sys-apps/busybox static -pam


/etc/portage/package.mask
Code:
>dev-db/mysql-5.6


/etc/portage/package.unmask
Code:
# required by virtual/perl-libnet-1.220.0-r3
# required by dev-perl/Net-SMTP-SSL-1.10.0-r1
# required by dev-vcs/git-2.0.5[perl]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Andreas K. Huettel <dilfridge@gentoo.org> (29 Mar 2015)
# Mask Perl 5.18 for removal. Please upgrade to Perl 5.20
=dev-lang/perl-5.18.2-r2


emerge --info
Code:
Portage 2.3.0 (python 3.4.3-final-0, hardened/linux/amd64, gcc-4.8.5, glibc-2.22-r4, 3.14.36-grsec x86_64)
=================================================================
System uname: Linux-3.14.36-grsec-x86_64-Intel-R-_Xeon-R-_CPU_X5650_@_2.67GHz-with-gentoo-2.3
KiB Mem:     2044060 total,     29968 free
KiB Swap:    1023996 total,    924188 free
Timestamp of repository gentoo: Wed, 05 Apr 2017 16:15:01 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-lang/perl:            5.22.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.3.5-r2::gentoo, 3.4.3-r1::gentoo
dev-util/cmake:           3.6.3::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.23.2::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.26.1::gentoo
sys-devel/gcc:            4.8.5::gentoo, 4.9.4::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://gentoo.tnnet.fi/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.tnnet.fi/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 apache2 berkdb bzip2 cli cracklib crypt cxx dri gdbm hardened iconv ipv6 justify ldap ldap-sasl mailwrapper mmx modules multilib mysql ncurses nls nptl openmp pam pax_kernel pcre pie readline sasl seccomp session sse sse2 ssl ssp suexec tcpd unicode urandom vda xattr xtpax zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias asis auth_digest proxy unixd access_compat authz_core authn_core ssl socache_shmcb" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21782
Location: here

PostPosted: Thu Apr 06, 2017 6:50 am    Post subject: Reply with quote

For php-7 you need to add use flag mysqli or pdo when you set mysql
Code:
mysql? ( any-of ( mysqli pdo ) )

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Whome001
n00b
n00b


Joined: 12 Apr 2014
Posts: 10

PostPosted: Thu Apr 06, 2017 7:00 am    Post subject: Reply with quote

Can I define separate USE flags for PHP5 and PHP7 environments? I have lots of php web apps, some of them legacy, scripts not done by me and no intention to modify. I wish to keep an existing default php5.6 apache2 environment.

I was thinking something like this, use pdo|remove mysqli for PHP7, keep existing flags for PHP5 where both pdo and mysqli is given.

/etc/portage/package.use
Code:

=dev-lang/php-5* -* cli readline cgi apache2 ctype curl crypt fastbuild force-cgi-redirect ftp gd hash iconv ipv6 memlimit mysql mcrypt nls pcre pic posix pdo reflection session simplexml soap sockets spl sqlite ssl tokenizer truetype xml xmlreader xmlwriter xsl zlib zip mbstring nls unicode filter mysqli mysqlnd json

=dev-lang/php-7* -* cli readline cgi apache2 ctype curl crypt fastbuild force-cgi-redirect ftp gd hash iconv ipv6 memlimit mysql mcrypt nls pcre pic posix pdo reflection session simplexml soap sockets spl sqlite ssl tokenizer truetype xml xmlreader xmlwriter xsl zlib zip mbstring nls unicode filter  mysqlnd json


[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21782
Location: here

PostPosted: Thu Apr 06, 2017 8:19 am    Post subject: Reply with quote

Whome001 wrote:
Can I define separate USE flags for PHP5 and PHP7 environments?

Yes, but with slot notation


Code:
dev-lang/php:5.6 -* cli readline cgi apache2 ctype curl crypt fastbuild force-cgi-redirect ftp gd hash iconv ipv6 memlimit mysql mcrypt nls pcre pic posix pdo reflection session simplexml soap sockets spl sqlite ssl tokenizer truetype xml xmlreader xmlwriter xsl zlib zip mbstring nls unicode filter mysqli mysqlnd json

dev-lang/php:7.0 -* cli readline cgi apache2 ctype curl crypt fastbuild force-cgi-redirect ftp gd hash iconv ipv6 memlimit mysql mcrypt nls pcre pic posix pdo reflection session simplexml soap sockets spl sqlite ssl tokenizer truetype xml xmlreader xmlwriter xsl zlib zip mbstring nls unicode filter  mysqlnd json

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Whome001
n00b
n00b


Joined: 12 Apr 2014
Posts: 10

PostPosted: Thu Apr 06, 2017 9:24 am    Post subject: Reply with quote

Thanks, things going forward, I was able to list pending updates and emerge --update the most critical internet frontend services such as apache2 etc..

This preserved-rebuild command I was not able to solve. Also pending update list has BLOCKED issues with python and libevent packages. I try to solve them later with Google and then come back asking here more help.

Code:
$ emerge @preserved-rebuild
emerge: there are no ebuilds to satisfy "dev-db/sqlite:0".
(dependency required by "@preserved-rebuild" [argument])

- - - -
dev-libs/libevent:0

  (dev-libs/libevent-2.1.8:0/2.1-6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libevent-2.0.22:0/0::gentoo, installed) pulled in by
    >=dev-libs/libevent-2.0.9:0/0=[threads] required by (net-misc/ntp-4.2.8_p9:0/0::gentoo, installed)
                             ^^^^^                                             
    <=dev-libs/libevent-2.1 required by (net-fs/nfs-utils-1.3.1-r5:0/0::gentoo, installed)
    ^^                  ^^^                                                     

dev-lang/python-exec:2

  (dev-lang/python-exec-2.4.4:2/2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-lang/python-exec-2.4.2 required by (app-eselect/eselect-python-20160516:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^                                                                                                                               

  (dev-lang/python-exec-2.0.1-r1:2/2::gentoo, installed) pulled in by
    dev-lang/python-exec:2/2=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)] required by (virtual/python-argparse-1:0/0::gentoo, installed)


[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21782
Location: here

PostPosted: Thu Apr 06, 2017 11:20 am    Post subject: Reply with quote

For libevent read here
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum