Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No Jack Audio from Lenovo Docking Station when T470 connecte
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
saski4711
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jun 2004
Posts: 85

PostPosted: Fri Apr 07, 2017 5:55 am    Post subject: No Jack Audio from Lenovo Docking Station when T470 connecte Reply with quote

Hello,

I'm unable to get any sound from the Headphone Jack of a Lenovo Ultra Docking Station with a new Lenovo T470 connected. With a T440p however I get sound from the Docking Station Headphone Jack.

I did some research on my alsa configuration and found out that there is no pin configuration supplied from the Laptop BIOS that connects to the Docking Headphone Jack.

The hdajacksensetest tool only shows this when the Laptop is docked and a Headphone is pluged in:
Code:

Pin 0x18 (Black Mic, Left side): present = No
Pin 0x21 (Black Headphone, Left side): present = No


So I did some patching using a early firmware load patch floating around the web targeting the same docking station for my older T440p laptop:
Code:

echo 0x17 0x21211010 > /sys/class/sound/hwC0D0/user_pin_configs
echo 1 > /sys/class/sound/hwC0D0/reconfig


Now my Docking Station Headphone Jack is being detected! :)

With the Headphone Connected:
Code:

Pin 0x17 (Black Headphone, Docking station, Rear side): present = Yes
Pin 0x18 (Black Mic, Left side): present = No
Pin 0x21 (Black Headphone, Left side): present = No

And disconnected:
Code:

Pin 0x17 (Black Headphone, Docking station, Rear side): present = No
Pin 0x18 (Black Mic, Left side): present = No
Pin 0x21 (Black Headphone, Left side): present = No

However there is STILL no sound even after unmuting everything in alsamixer!
I'm pretty sure 0x17 is the right pincfg but I'm not sure about 0x21211010 and how I obtain such an address for my laptop.

Could someone please help me out here or give me a hint?

Here is a alsa-info.sh dump when the Laptop is not connected to the Dock:
https://pastebin.com/eTNnfnzL

And here when the Laptop is connected to the Dock (No changes):
https://pastebin.com/ySBsKUeH

And here after setting the pin config 0x17 0x21211010:
https://pastebin.com/xmDfsNtQ

I'm sure I'm very close. But something is still missing. Any help is much apprechiated!

Thanks in advance
Back to top
View user's profile Send private message
jakutis
n00b
n00b


Joined: 10 Jan 2018
Posts: 1

PostPosted: Wed Jan 10, 2018 1:30 pm    Post subject: Reply with quote

same issue here on fedora 27, thinkpad t470p
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum