Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No console tty's with systemd even after activating them 1-6
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
urcindalo
Guru
Guru


Joined: 08 Feb 2005
Posts: 591
Location: Almeria, Spain

PostPosted: Mon Apr 10, 2017 6:12 pm    Post subject: No console tty's with systemd even after activating them 1-6 Reply with quote

Hi and thanks for reading this!

My home box runs a mostly stable amd64 plasma 5 installation with systemd (apart from a few ~amd64 photo editing tools).
I did follow the systemd Gentoo Wiki installation guide to the latter in Xmas, when I changed from openrc. The guide says this:
Quote:
By default systemd only launches a getty process when it's going to be used. This causes some display managers (like GDM) to use the remaining TTYs for opening graphical sessions on demand, which can result in having consoles and graphical sessions placed randomly depending on the order they were used.

To stick with a more "classical" behavior (i.e, consoles placed from tty1 to tty6 and graphical sessions using the remaining TTYs) force it to always launch getty on those:

Code:
root #systemctl enable getty@tty{2,3,4,5,6}.service


I've doubled-check I did in fact "systemctl enable getty@tty{2,3,4,5,6}.service". However, whenever I try to change to a console tty, let's say on tty2 by Ctrl+Alt+F2, all I get is the same window I have on the graphical session but with no mouse (not even the cursor). In other words, trying to change to a console tty on 2 to 6 is indistinguishable from removing the mouse on the graphical session. I only get back the true graphical session when changing back to tty1 (Ctrl+Alt+F1).

So, shouldn't the first graphical session be launched on tty7 in the first place? Why do I get it on tty1 as if the "systemctl enable getty@tty{2,3,4,5,6}.service" were not honored?

I also tried adding tty1 to the above command, but it fails this way:
Code:
# systemctl enable getty@tty{1,2,3,4,5,6}.service
Failed to execute operation: File exists


What can I do? I'm really clueless.
Thanks in advance.
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1519
Location: KUUSANKOSKI, Finland

PostPosted: Mon Apr 10, 2017 6:44 pm    Post subject: Reply with quote

I think you also need to configure systemd-logind.
Specifically the options NAutoVTs and ReserveVT.

I've seen some lag systemd starting getty on a tty when switched on... To avoid that set ReseveVT to same value as NAutoVTs. At least that has worked on my setup. :)
Then reload systemd-logind.service (This may kill your X sessions). Finally try enable those getty services.

I hope this helps.
Back to top
View user's profile Send private message
urcindalo
Guru
Guru


Joined: 08 Feb 2005
Posts: 591
Location: Almeria, Spain

PostPosted: Wed Apr 12, 2017 8:12 am    Post subject: Reply with quote

Zucca wrote:
I think you also need to configure systemd-logind.
Specifically the options NAutoVTs and ReserveVT


Thanks for your help and suggestion. I changed those options as shown here:
Code:
[Login]
NAutoVTs=2
ReserveVT=2


However, I don't get a console getty even on 2 :?

All that also looks like redundant, according to configure systemd-logind:
Quote:
By default, autovt@.service is linked to getty@.service


I thought maybe this is related to sddm. So, I took a look at its config file and changed MinimumVT in /etc/sddm.conf from 1 to 3, while deactivating the previous custom configs of NAutoVTs and ReserveVT in /etc/systemd/logind.conf, just in case:
Code:
# The lowest virtual terminal number that will be used.
MinimumVT=3


Again, to no avail. All I got was the graphical sessions starts indeed on 3 (at least that), but if I try getty's on 1 or 2 I get the same behavior I explained in my initial post.

This is getting annoying.
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1519
Location: KUUSANKOSKI, Finland

PostPosted: Wed Apr 12, 2017 11:23 am    Post subject: Reply with quote

urcindalo wrote:
while deactivating the previous custom configs of NAutoVTs and ReserveVT in /etc/systemd/logind.conf, just in case
... Maybe set them back?

I just checked my system. I have NAutoVTs=4 and ReserveVT=2. HOWEVER systemd does not keep them (2) running all the time. Why? I don't know. Maybe a bug? I had an open login on vt1 so it was listed as active on 'systemctl'. Only until I swithed on to vt2 the getty@tty2 was started. And there was a delay as expected.
Sometimes the ways of systemd are unpredictable. :( I try to learn using it but already today I've been stumbling into two "silent errors". It's very hard to diagnose them. :\

Anyway. You said:
urcindalo wrote:
However, whenever I try to change to a console tty, let's say on tty2 by Ctrl+Alt+F2, all I get is the same window I have on the graphical session but with no mouse (not even the cursor). In other words, trying to change to a console tty on 2 to 6 is indistinguishable from removing the mouse on the graphical session.
... to me it sounds like your GPU isn't able to reset itself to the mode of the VT.

To investigate, try to run journalctl -f (or dmesg -w) as root on some terminal emulator. Then try to switch to another VT. Then switch back and see if there's any errors.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum