Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
hplip emerge problem [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
elsphinc
Tux's lil' helper
Tux's lil' helper


Joined: 24 Oct 2002
Posts: 135
Location: Lake Tahoe

PostPosted: Fri Apr 21, 2017 6:29 pm    Post subject: hplip emerge problem [SOLVED] Reply with quote

hplip failing to emerge


Code:
Calculating dependencies... done!
[ebuild  N     ] net-print/hplip-3.16.3::gentoo  USE="X hpcups libnotify policykit qt4 -doc -fax -hpijs -kde -libusb0 -minimal -parport -scanner -snmp -static-ppds" PYTHON_TARGETS="python2_7" 0 Ki



Code:
libtool: relink: x86_64-pc-linux-gnu-gcc -shared  -fPIC -DPIC  .libs/libhpipp_la-hp_ipp.o   -Wl,--as-needed -L/var/tmp/portage/net-print/hplip-3.16.3/image//usr/lib64 -L/usr/lib64 -lhpmud -lpthread -ldl -lusb-1.0  -march=native -O2 -Wl,-O1   -Wl,-soname -Wl,libhpipp.so.0 -o .libs/libhpipp.so.0.0.1
/var/tmp/portage/net-print/hplip-3.16.3/work/hplip-3.16.3/.libs/libhpipp.so: file not recognized: File truncated
collect2: error: ld returned 1 exit status
libtool: install: /usr/lib/portage/python3.4/ebuild-helpers/xattr/install -c .libs/libhpipp.so.0.0.1T /var/tmp/portage/net-print/hplip-3.16.3/image//usr/lib64/libhpipp.so.0.0.1
libtool: install: (cd /var/tmp/portage/net-print/hplip-3.16.3/image//usr/lib64 && { ln -s -f libhpipp.so.0.0.1 libhpipp.so.0 || { rm -f libhpipp.so.0 && ln -s libhpipp.so.0.0.1 libhpipp.so.0; }; })
libtool: install: (cd /var/tmp/portage/net-print/hplip-3.16.3/image//usr/lib64 && { ln -s -f libhpipp.so.0.0.1 libhpipp.so || { rm -f libhpipp.so && ln -s libhpipp.so.0.0.1 libhpipp.so; }; })
libtool: install: /usr/lib/portage/python3.4/ebuild-helpers/xattr/install -c .libs/libhpipp.lai /var/tmp/portage/net-print/hplip-3.16.3/image//usr/lib64/libhpipp.la
libtool:   error: error: relink 'cupsext.la' with the above command before installing it
make[1]: *** [Makefile:5260: install-cupsextLTLIBRARIES] Error 1
make[1]: *** Waiting for unfinished jobs....
libtool: warning: remember to run 'libtool --finish /usr/lib64'
make[1]: Leaving directory '/var/tmp/portage/net-print/hplip-3.16.3/work/hplip-3.16.3'
make: *** [Makefile:9315: install-am] Error 2
 * ERROR: net-print/hplip-3.16.3::gentoo failed (install phase):
 *   emake failed


Ideas?
_________________
elsphinc # kickin_ass &
mysql> create database namesdb;


Last edited by elsphinc on Fri Apr 21, 2017 7:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22016
Location: here

PostPosted: Fri Apr 21, 2017 6:53 pm    Post subject: Reply with quote

Try to compile with MAKEOPTS="-j1".
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
elsphinc
Tux's lil' helper
Tux's lil' helper


Joined: 24 Oct 2002
Posts: 135
Location: Lake Tahoe

PostPosted: Fri Apr 21, 2017 7:16 pm    Post subject: Reply with quote

That worked. Not sure how you came to that solution, but it worked thanks.
_________________
elsphinc # kickin_ass &
mysql> create database namesdb;
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22016
Location: here

PostPosted: Fri Apr 21, 2017 7:48 pm    Post subject: Reply with quote

elsphinc wrote:
That worked. Not sure how you came to that solution, but it worked thanks.

Simply with a google search. I found this changelog:
Quote:
- Using again plain 'make' instead of 'make %{?_smp_mflags}'
(cf. the entry below dated "Sun Apr 20 09:48:39 UTC 2014")
and plain 'make ... install' instead of
'make ... install %{?_smp_mflags}' to avoid random obscure
build failures with errors like "libtool: install: error: relink
`cupsext.la' with the above command before installing it", cf.
http://lists.gnu.org/archive/html/automake/2010-03/msg00039.html

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum