Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gennto & HP DeskJet Scanner problem (it use to be fine)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1583
Location: /mnt/Gentoo/Europe

PostPosted: Thu Apr 20, 2017 6:53 am    Post subject: Gennto & HP DeskJet Scanner problem (it use to be fine) Reply with quote

Hi,

For last couple of years, I was using my HP DeskJet 2050 scanner & printer without any problems.

As I needed to scan something Yesterday, I could not find device through hplip
Code:
*  net-print/hplip
      Latest version available: 3.16.11-r3
      Latest version installed: 3.16.11-r3
      Size of files: 22,563 KiB
      Homepage:      http://hplipopensource.com/hplip-web/index.html
      Description:   HP Linux Imaging and Printing - Print, scan, fax drivers and service tools
      License:       GPL-2

*  net-print/hplip-plugin
      Latest version available: 3.16.11
      Latest version installed: 3.16.11
      Size of files: 2,012 KiB
      Homepage:      http://hplipopensource.com/hplip-web/index.html
      Description:   Proprietary plugins and firmware for HPLIP
      License:       hplip-plugin


When I am trying xsane or skaner it says no device found. However lsusb see dvice:
Code:
$ lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 0461:4de3 Primax Electronics, Ltd
Bus 003 Device 002: ID 03f0:8711 Hewlett-Packard Deskjet 2050 J510
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 045e:07f8 Microsoft Corp. Wired Keyboard 600 (model 1576)
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub



I added manually a printer through CUPS (which detected printer), looks like is there, and I finnaly found it in hplip, but hplip says communication error, and I have still no acces through xsane or scanlite :/ When I removed it from CUPS, hplip cannot see device - like in last years.
Code:
# sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
found USB scanner (vendor=0x03f0 [HP], product=0x8711 [Deskjet 2050 J510 series]) at libusb:003:004
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.


hp-check syas: Total Errors: 8 (looks like python related)
https://pastebin.com/afJn82B2
Back to top
View user's profile Send private message
Hieronymus Bosch
Tux's lil' helper
Tux's lil' helper


Joined: 29 Jan 2015
Posts: 75
Location: 31°45′33.14″N 106°29′24.63″W

PostPosted: Thu Apr 20, 2017 4:00 pm    Post subject: Reply with quote

Try to reemerge hplip with scanner use flag
_________________
Details fueled any investigation ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum