Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
media-libs/libffado-2.3.0::hering-overlay fails to emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
cyber_sapien
n00b
n00b


Joined: 31 May 2015
Posts: 23

PostPosted: Fri May 05, 2017 1:07 pm    Post subject: media-libs/libffado-2.3.0::hering-overlay fails to emerge Reply with quote

Hi,
after updating my system from GCC 4 to 5 and recompiling the libraries libffado stopt working.
An emerge of libffado fails-

Please help me.


Last edited by cyber_sapien on Fri May 05, 2017 2:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21668
Location: here

PostPosted: Fri May 05, 2017 2:04 pm    Post subject: Reply with quote

First, your wgetpaste show only command and not content.
After upgrade you read this news?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cyber_sapien
n00b
n00b


Joined: 31 May 2015
Posts: 23

PostPosted: Fri May 05, 2017 2:21 pm    Post subject: Reply with quote

Hello fedeliallalinea,
thank you for your answer.
Sorry for empty wgetpaste - here is the build.log
https://bpaste.net/show/4758b5a894ec
and emerge --info
https://bpaste.net/show/423cae4ea9e7

and yes I read the news and I think
# revdep-rebuild --library 'libstdc++.so.6' -- --exclude gcc
caused the problem (crashed libffado)
lG
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21668
Location: here

PostPosted: Fri May 05, 2017 2:32 pm    Post subject: Reply with quote

Anyway it seems a gcc upgrade problem.
Try to recompile libxml2
Code:
# emerge -1 libxml2 libffado

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cyber_sapien
n00b
n00b


Joined: 31 May 2015
Posts: 23

PostPosted: Fri May 05, 2017 4:13 pm    Post subject: Reply with quote

I recompiled libxml2 but the problem persists.
I also tried compiling with libxmlpp-2.4 and libxmlpp-3.0.
What else could I try?
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13725

PostPosted: Sat May 06, 2017 12:57 am    Post subject: Reply with quote

It looks to me like dev-libs/libxml2 was rebuilt for C++11, but depends on some other package which was not rebuilt. I suggest you finish the advice in the news that fedeliallalinea linked initially. You say that it failed on libffado when rebuilding. That says packages were rebuilt in the wrong order. Skip over libffado, finish everything else, then come back to it.
Back to top
View user's profile Send private message
cyber_sapien
n00b
n00b


Joined: 31 May 2015
Posts: 23

PostPosted: Sat May 06, 2017 7:57 pm    Post subject: Reply with quote

To recompile everything again fixed the issue.
Thanx Hu and fedeliallalinea for your help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum