Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems installing Gnome, after fine handbook installation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
stefan2017
n00b
n00b


Joined: 09 May 2017
Posts: 9

PostPosted: Tue May 09, 2017 11:31 am    Post subject: Problems installing Gnome, after fine handbook installation Reply with quote

Hello all

i have a problem with installing the Gnome Desktop Enviroment.

emerge --pretend gnome
says: there are blocked packages
Code:

[blocks B      ] sys-fs/eudev ("sys-fs/eudev" is blocking sys-apps/systemd-233-r1, sys-apps/gentoo-systemd-integration-6)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/eudev-3.1.5)
[blocks B      ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/eudev-3.1.5)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/systemd-233-r1:0/2::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/systemd required by (gnome-base/gnome-settings-daemon-3.22.2:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-186:0=[pam] required by (gnome-base/gdm-3.22.3-r1:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-6:0/0::gentoo, ebuild scheduled for merge)
    sys-apps/systemd:0= required by (sys-apps/dbus-1.10.18:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-204[pam] required by (sys-auth/pambase-20150213:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-control-center-3.22.2-r1:2/2::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-shell-3.22.3-r2:0/0::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (virtual/tmpfiles-0:0/0::gentoo, installed)

  (sys-fs/eudev-3.1.5:0/0::gentoo, installed) pulled in by
    >=sys-fs/eudev-1.3:0/0[abi_x86_32(-)?,abi_x86_64(-)?,
    abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,
    abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
    abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] (>=sys-fs/eudev-1.3:0/0[abi_x86_64(-)]) required by (virtual/libudev-215-r1:0/1::gentoo, installed)
    >=sys-fs/eudev-2.1.1 required by (virtual/udev-217:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by sys-libs/ldb-1.1.26::gentoo
# required by net-fs/samba-4.2.14::gentoo
# required by net-fs/cifs-utils-6.4::gentoo[acl]
>=sys-libs/tevent-0.9.28 python
# required by gnome-base/gnome-shell-3.22.3-r2::gentoo
# required by gnome-extra/chrome-gnome-shell-8-r1::gentoo
>=gnome-base/gnome-control-center-3.22.2-r1 networkmanager
# required by gnome-base/gnome-control-center-3.22.2-r1::gentoo[cups]
# required by net-libs/gnome-online-accounts-3.22.5::gentoo[gnome]
# required by net-misc/gnome-online-miners-3.22.0::gentoo
# required by gnome-extra/gnome-documents-3.22.3::gentoo
# required by gnome-base/gnome-extra-apps-3.22.2::gentoo[tracker]
# required by gnome-base/gnome-3.22.2::gentoo[extras]
# required by gnome (argument)
>=net-fs/samba-4.2.14 client
# required by net-fs/samba-4.2.14::gentoo
# required by net-fs/cifs-utils-6.4::gentoo[acl]
>=sys-libs/ntdb-1.0-r1 python
# required by sys-libs/ldb-1.1.26::gentoo
# required by net-fs/samba-4.2.14::gentoo
# required by net-fs/cifs-utils-6.4::gentoo[acl]
>=sys-libs/tdb-1.3.8 python
# required by media-gfx/gnome-photos-3.22.5::gentoo
# required by gnome-base/gnome-extra-apps-3.22.2::gentoo[tracker]
# required by gnome-base/gnome-3.22.2::gentoo[extras]
# required by gnome (argument)
>=media-libs/gegl-0.3.8 raw jpeg2k
# required by gnome-base/gdm-3.22.3-r1::gentoo
# required by gnome-base/gnome-3.22.2::gentoo
# required by gnome (argument)
>=sys-auth/pambase-20150213 systemd
# required by sys-apps/systemd-233-r1::gentoo
# required by gnome-base/gdm-3.22.3-r1::gentoo
# required by gnome-base/gnome-3.22.2::gentoo
# required by gnome (argument)
>=sys-apps/dbus-1.10.18 systemd

emerge: there are no ebuilds built with USE flags to satisfy "sys-auth/pambase[systemd]".
!!! One of the following packages is required to complete your request:
- sys-auth/pambase-20120417-r3::gentoo (Change USE: +systemd)
(dependency required by "gnome-base/gdm-3.22.3-r1::gentoo" [ebuild])
(dependency required by "gnome-base/gnome-3.22.2::gentoo" [ebuild])
(dependency required by "gnome" [argument])


At now i've done the installation with the Gentoo AMD64 handbook. The system (a
guest in a virtualbox) has rebooted the console-system and is running an up.

I've decided to you OpenRC not Systemd

I decided to install the MBR Partition Layout.
Code:

# ARCHITEKTUR: amd64
# ABI: multilib
# SYSTEM-BIOS: bios
# INSTALL-FROM: install-amd64-minimal-20170420.iso
# STAGE: stage3-amd64-20170427.tar.bz2

parted --script -a optimal "$InstallHDD_G" -- mklabel msdos \
unit mib \
mkpart primary  4 50 \
set 1 hidden on \
mkpart primary ext2 50 1000 \
mkpart primary linux-swap 1000 2024 \
mkpart primary ext4 2024 -1 \
print

eselect profile list
Available profile symlink targets:
  [1]   default/linux/amd64/13.0
  [2]   default/linux/amd64/13.0/selinux
  [3]   default/linux/amd64/13.0/desktop
  [4]   default/linux/amd64/13.0/desktop/gnome *

I've decided to use genkernel:
emerge --ask sys-kernel/genkernel

I not really know what i shoud do now.

Thanks

[Moderator edit: added [code] tags to preserve output layout. -Hu]

Split a bunch of lines to make the forum layout behave.Chiitoo
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7972
Location: ~Brussels - Belgique

PostPosted: Tue May 09, 2017 11:42 am    Post subject: Reply with quote

Hi!

Please select the gnome/systemd profile, because gnome asks systemd:
[5] default/linux/amd64/13.0/desktop/gnome/systemd
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
stefan2017
n00b
n00b


Joined: 09 May 2017
Posts: 9

PostPosted: Tue May 09, 2017 12:21 pm    Post subject: Reply with quote

Thanks for your quick response,

but only changing the profile doesn' t seem to work?

[blocks B ] sys-fs/eudev ("sys-fs/eudev" is blocking sys-apps/gentoo-systemd-integration-6, sys-apps/systemd-233-r1)
[blocks B ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/eudev-3.1.5)
[blocks B ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/eudev-3.1.5)

!!! The following installed packages are masked:
- sys-fs/eudev-3.1.5::gentoo (masked by: package.mask)
/usr/portage/profiles/targets/systemd/package.mask:
# Pacho Ramos <pacho@gentoo.org> (21 Apr 2015)
# This is for running sys-apps/systemd and also helps
# portage to not try to pull in other providers leading to
# strange blockers.

- sys-kernel/genkernel-3.4.52.4-r2::gentoo (masked by: package.mask)
/usr/portage/profiles/targets/systemd/package.mask:
# sys-kernel/genkernel is not compatible with Systemd, you need
# to use sys-kernel/genkernel-next instead


Is genkernel automatically upgraded to genkernel-next, or have i do
do that manually?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21754
Location: here

PostPosted: Tue May 09, 2017 12:23 pm    Post subject: Reply with quote

Code:
- sys-kernel/genkernel-3.4.52.4-r2::gentoo (masked by: package.mask)
/usr/portage/profiles/targets/systemd/package.mask:
# sys-kernel/genkernel is not compatible with Systemd, you need
# to use sys-kernel/genkernel-next instead

With systemd you need to install genkernel-next and not genkernel, because is not compatible
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
axl
Guru
Guru


Joined: 11 Oct 2002
Posts: 536
Location: Romania

PostPosted: Tue May 09, 2017 12:23 pm    Post subject: Reply with quote

use genkernel-next instead of genkernel.

and do an emerge --unmerge sys-fs/eudev. after that you should be fine. unless you have other manual masks.
Back to top
View user's profile Send private message
stefan2017
n00b
n00b


Joined: 09 May 2017
Posts: 9

PostPosted: Tue May 09, 2017 12:37 pm    Post subject: Reply with quote

After

emerge --unmerge sys-fs/eudev
emerge --unmerge sys-kernel/genkernel
emerge --ask sys-kernel/genkernel-next

it seems to work

System is compiling....
Back to top
View user's profile Send private message
stefan2017
n00b
n00b


Joined: 09 May 2017
Posts: 9

PostPosted: Tue May 09, 2017 1:24 pm    Post subject: Reply with quote

After compiling genkernel-next

and

emerge --autounmask-write gnome
dispatch-conf
emerge gnome

Gnome now is compiling too.
It seems to work. I'll see tomorrow or later.

Thanks to al of you.
Back to top
View user's profile Send private message
axl
Guru
Guru


Joined: 11 Oct 2002
Posts: 536
Location: Romania

PostPosted: Tue May 09, 2017 1:27 pm    Post subject: Reply with quote

congrats and enjoy your system :)
Back to top
View user's profile Send private message
stefan2017
n00b
n00b


Joined: 09 May 2017
Posts: 9

PostPosted: Wed May 10, 2017 2:18 pm    Post subject: X11 (startx) won't start Reply with quote

Hello again,

in my virtualbox after compiling the Gnome Desktop Enviroment won't start.
Code:

cat /var/log/Xorg.0.log|grep EE
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1813.096] (EE) dbus-core: error connecting to system bus: org.freedesktop.DBus.Error.FileNotFound (Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory)
[  1813.237] (EE) Failed to load module "vboxvideo" (module does not exist, 0)
[  1813.269] (EE) open /dev/dri/card0: No such file or directory
[  1813.269] (EE) open /dev/dri/card0: No such file or directory
[  1813.275] (EE) open /dev/fb0: No such file or directory
[  1813.275] (EE) open /dev/fb0: No such file or directory
[  1813.275] (EE) Screen 0 deleted because of no matching config section.
[  1813.275] (EE) Screen 0 deleted because of no matching config section.
[  1813.447] (EE) AIGLX: reverting to software rendering
[  1814.685] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:0c.0/usb1/1-1/1-1:1.0/0003:80EE:0021.0001/input/input5/event4"
[  1814.778] (EE) dbus-core: error connecting to system bus: org.freedesktop.DBus.Error.FileNotFound (Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory)




Then i tried:
Code:

emerge --pretend --verbose-conflicts app-emulation/virtualbox-guest-additions


with the following errors:
Code:

[blocks B      ] <x11-drivers/xf86-video-virtualbox-5.1.14 ("<x11-drivers/xf86-video-virtualbox-5.1.14" is blocking x11-base/xorg-drivers-1.19)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, ebuild scheduled for merge) pulled in by
    <x11-base/xorg-server-1.19:=[-minimal] required by (x11-drivers/xf86-video-virtualbox-5.0.32:0/0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^ ^                                                                                                                                                                                   

  (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.19.2= required by (x11-drivers/xf86-video-dummy-0.3.8:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                           
    x11-base/xorg-server:0/1.19.2= required by (x11-drivers/xf86-video-nouveau-1.0.13:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                               
    x11-base/xorg-server:0/1.19.2= required by (x11-drivers/xf86-input-keyboard-1.9.0:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                               
    x11-base/xorg-server:0/1.19.2= required by (x11-drivers/xf86-input-mouse-1.9.2:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                           
    x11-base/xorg-server:0/1.19.2= required by (x11-drivers/xf86-video-fbdev-0.4.4:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                           
    x11-base/xorg-server:0/1.19.2= required by (x11-drivers/xf86-input-libinput-0.24.0:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                               
    x11-base/xorg-server:0/1.19.2= required by (x11-drivers/xf86-video-amdgpu-1.2.0:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                             
    x11-base/xorg-server:0/1.19.2= required by (x11-drivers/xf86-video-intel-2.99.917_p20170216:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                                         
    x11-base/xorg-server:0/1.19.2= required by (x11-drivers/xf86-video-ati-7.8.0:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                         
    x11-base/xorg-server:0/1.19.2= required by (x11-drivers/xf86-video-vesa-2.3.4:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                           


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-base/xorg-drivers-1.19:0/0::gentoo, installed) pulled in by
    >=x11-base/xorg-drivers-1.18 required by (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, ebuild scheduled for merge)
    >=x11-base/xorg-drivers-1.19 required by (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, installed)

  (x11-drivers/xf86-video-virtualbox-5.0.32:0/0::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-drivers/xf86-video-virtualbox-5.0.32 required by (app-emulation/virtualbox-guest-additions-5.0.32:0/0::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


I then tried:

/etc/portage/package.mask/virtualbox
=x11-drivers/xf86-video-virtualbox-5.1.14

that does not work

What can i do now?

[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
stefan2017
n00b
n00b


Joined: 09 May 2017
Posts: 9

PostPosted: Thu May 11, 2017 1:35 pm    Post subject: Reply with quote

Hello@all

now i checked the kernel config from here (https://wiki.gentoo.org/wiki/VirtualBox#Gentoo_guests)
and compiled a new kernel
Code:

make menuconfig
make && make modules_install
make install

updgaded grub2
Code:

grub-install /dev/sda

and unmerged
Code:

emerge --unmerge x11-drivers/xf86-video-fbdev-0.4.4
emerge --unmerge x11-drivers/xf86-video-amdgpu-1.2.0:0
emerge --unmerge x11-drivers/xf86-video-intel-2.99.917_p20170216:0
emerge --unmerge x11-base/xorg-server-1.19.2:0/1.19.2
emerge --unmerge x11-base/xorg-drivers-1.19:0/0


masked the package: =x11-base/xorg-drivers-1.19:0/0
with
Code:

touch /etc/portage/package.mask/x11
nano -w /etc/portage/package.mask/x11

and do
emerge --pretend app-emulation/virtualbox-guest-additions (what seens ok)
emerge app-emulation/virtualbox-guest-additions


but there is an compile time error:
Code:

/lib/modules/4.9.16-gentoo/build/arch/x86/include/asm/string_64.h:103:6: note: in expansion of macro ‘static_branch_unlikely’
  if (static_branch_unlikely(&mcsafe_key))
      ^
kmk: *** [/var/tmp/portage/app-emulation/virtualbox-guest-additions-5.0.32/work/VirtualBox-5.0.32/out/linux.amd64/release/obj/RuntimeGuestR0/common/alloc/heapsimple.o] Error 1
kmk: *** Exiting with status 2
 * ERROR: app-emulation/virtualbox-guest-additions-5.0.32::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=app-emulation/virtualbox-guest-additions-5.0.32::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-emulation/virtualbox-guest-additions-5.0.32::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-emulation/virtualbox-guest-additions-5.0.32/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-emulation/virtualbox-guest-additions-5.0.32/temp/environment'.
 * Working directory: '/var/tmp/portage/app-emulation/virtualbox-guest-additions-5.0.32/work/VirtualBox-5.0.32'
 * S: '/var/tmp/portage/app-emulation/virtualbox-guest-additions-5.0.32/work/VirtualBox-5.0.32'


Code:

emerge --info '=app-emulation/virtualbox-guest-additions-5.0.32::gentoo

Portage 2.3.5 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-5.4.0, glibc-2.23-r3, 4.9.16-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.9.16-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_950_@_3.07GHz-with-gentoo-2.3
KiB Mem:     4043636 total,   2771620 free
KiB Swap:    1048572 total,   1048572 free
Timestamp of repository gentoo: Tue, 09 May 2017 00:45:01 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.26.1 p1.0) 2.26.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-lang/perl:            5.24.1-r1::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.24.2::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.26.1::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/chromium/policies/managed/chrome-gnome-shell.json /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/opt/chrome/policies/managed/chrome-gnome-shell.json /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.eu.oneandone.net/linux/distributions/gentoo/gentoo/ http://mirror.netcologne.de/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://ftp.halifax.rwth-aachen.de/gentoo/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli colord cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gif glamor gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv introspection ipv6 jpeg lcms ldap libnotify libsecret mad mng modules mp3 mp4 mpeg multilib nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio qt3support qt4 readline sdl seccomp session spell ssl startup-notification svg systemd tcpd tiff tracker truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON



Code:
# emerge -pqv '=app-emulation/virtualbox-guest-additions-5.0.32::gentoo'
[ebuild  N    ] app-emulation/virtualbox-guest-additions-5.0.32  USE="X"
[ebuild  N    ] x11-drivers/xf86-video-virtualbox-5.0.32  USE="dri" PYTHON_TARGETS="python2_7"



Code:

/lib/modules/4.9.16-gentoo/build/include/linux/jump_label.h:297:48: error: expected primary-expression before ‘struct’
      !__builtin_types_compatible_p(typeof(*x), struct static_key_false)) \
                                                ^
/lib/modules/4.9.16-gentoo/build/include/linux/compiler.h:168:42: note: in definition of macro ‘unlikely’
 # define unlikely(x) __builtin_expect(!!(x), 0)
                                          ^
/lib/modules/4.9.16-gentoo/build/include/linux/jump_label.h:387:44: note: in expansion of macro ‘static_key_enabled’
 #define static_branch_unlikely(x) unlikely(static_key_enabled(&(x)->key))
                                            ^
/lib/modules/4.9.16-gentoo/build/arch/x86/include/asm/string_64.h:103:6: note: in expansion of macro ‘static_branch_unlikely’
  if (static_branch_unlikely(&mcsafe_key))
      ^
kmk: *** [/var/tmp/portage/app-emulation/virtualbox-guest-additions-5.0.32/work/VirtualBox-5.0.32/out/linux.amd64/release/obj/RuntimeGuestR0/common/alloc/heapsimple.o] Error 1
kmk: *** Exiting with status 2
 * ERROR: app-emulation/virtualbox-guest-additions-5.0.32::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=app-emulation/virtualbox-guest-additions-5.0.32::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-emulation/virtualbox-guest-additions-5.0.32::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-emulation/virtualbox-guest-additions-5.0.32/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-emulation/virtualbox-guest-additions-5.0.32/temp/environment'.
 * Working directory: '/var/tmp/portage/app-emulation/virtualbox-guest-additions-5.0.32/work/VirtualBox-5.0.32'
 * S: '/var/tmp/portage/app-emulation/virtualbox-guest-additions-5.0.32/work/VirtualBox-5.0.32'


[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21754
Location: here

PostPosted: Thu May 11, 2017 1:46 pm    Post subject: Reply with quote

See here
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
stefan2017
n00b
n00b


Joined: 09 May 2017
Posts: 9

PostPosted: Thu May 11, 2017 1:53 pm    Post subject: Reply with quote

Thank you,

but first i would try emerge java (see https://forums.virtualbox.org/viewtopic.php?f=7&t=60233)


what have i to emerge to install java?

Thanks
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21754
Location: here

PostPosted: Thu May 11, 2017 2:41 pm    Post subject: Reply with quote

stefan2017 wrote:
what have i to emerge to install java?

Install dev-java/icedtea-bin or dev-java/icedtea-bin. There is also dev-java/oracle-jdk-bin but this is proprietary implementation of oracle
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
stefan2017
n00b
n00b


Joined: 09 May 2017
Posts: 9

PostPosted: Thu May 11, 2017 2:44 pm    Post subject: Reply with quote

Ok,
and perhaps this may help too?

http://www.calculate-linux.ru/packages/app-emulation/virtualbox/virtualbox-5.0.32.ebuild
Back to top
View user's profile Send private message
stefan2017
n00b
n00b


Joined: 09 May 2017
Posts: 9

PostPosted: Fri May 12, 2017 8:28 am    Post subject: Reply with quote

Hello@all,

after doing some experiments, i upgraded to app-emulation/virtualbox-guest-additions-5.1.22::gentoo
now a simple X11-Gui works with the:
Code:
lsmod|grep vbox
vboxsf                 45056  0
vboxguest             245760  3 vboxsf


i had to mask:
Code:
cat /etc/portage/package.mask/virtualbox
=x11-drivers/xf86-video-virtualbox-5.0.32
=app-emulation/virtualbox-guest-additions-5.0.32:0/0::gentoo


Code:
emerge --autounmask-write app-emulation/virtualbox-guest-additions
rc-update add /etc/init.d/virtualbox-guest-additions default
cp /usr/share/doc/virtualbox-guest-additions-5.1.22/xorg.conf.vbox.bz2 /etc/X11/


Code:
usermod -aG vboxguest jhgjgjg
 eselect opengl set xorg-x11
 /etc/init.d/virtualbox-guest-additions start
 emerge x11-drivers/xf86-input-libinput
 emerge x11-wm/twm
 emerge x11-terms/xterm



Details:
Code:
# emerge --ask --update --deep --newuse @world

 * IMPORTANT: 13 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

The following packages are causing rebuilds:

  (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-drivers/xf86-video-fbdev-0.4.4:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-amdgpu-1.2.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-intel-2.99.917_p20170216:0/0::gentoo, ebuild scheduled for merge)
[ebuild   R    ] sys-apps/busybox-1.25.1  USE="systemd*"
[ebuild     U *] x11-base/xorg-drivers-9999 [1.18-r1] VIDEO_CARDS="-i915% -i965%"
[ebuild  N     ] dev-python/appdirs-1.4.3  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)"
[ebuild  N     ] dev-python/pyparsing-2.1.10  USE="-doc -examples" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)"
[ebuild  N     ] dev-python/packaging-16.8  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)"
[ebuild     U  ] dev-python/setuptools-34.0.2-r1 [30.4.0]
[ebuild   R    ] virtual/udev-217  USE="(systemd*)"
[ebuild   R    ] virtual/libudev-215-r1  USE="(systemd*)"
[ebuild   R    ] sys-process/procps-3.3.12  USE="systemd*"
[ebuild   R    ] sys-apps/util-linux-2.28.2  USE="systemd*"
[ebuild  r  U  ] x11-base/xorg-server-1.19.2 [1.18.4] USE="-debug%"
[ebuild  rR    ] x11-drivers/xf86-video-intel-2.99.917_p20170216
[ebuild  rR    ] x11-drivers/xf86-video-fbdev-0.4.4
[ebuild  rR    ] x11-drivers/xf86-video-amdgpu-1.2.0
[ebuild   R    ] net-print/cups-2.1.4  USE="systemd*"
[ebuild   R    ] sys-auth/polkit-0.113  USE="systemd*"
[ebuild   R    ] x11-misc/colord-1.3.4  USE="systemd*"

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by x11-base/xorg-server-1.19.2::gentoo[xorg]
# required by x11-drivers/xf86-video-fbdev-0.4.4::gentoo
# required by @__auto_slot_operator_replace_installed__ (argument)
=x11-base/xorg-drivers-9999 **

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Would you like to add these changes to your config files? [Yes/No]


Autounmask changes successfully written.

 * IMPORTANT: config file '/etc/portage/package.accept_keywords' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

 
 dispatch-conf
 use new
 
 emerge --ask --update --deep --newuse @world
 
 These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-apps/busybox-1.25.1  USE="systemd*"
[ebuild     U *] x11-base/xorg-drivers-9999 [1.18-r1] VIDEO_CARDS="-i915% -i965%"
[ebuild  N     ] dev-python/appdirs-1.4.3  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)"
[ebuild  N     ] dev-python/pyparsing-2.1.10  USE="-doc -examples" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)"
[ebuild  N     ] dev-python/packaging-16.8  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)"
[ebuild     U  ] dev-python/setuptools-34.0.2-r1 [30.4.0]
[ebuild   R    ] virtual/udev-217  USE="(systemd*)"
[ebuild   R    ] virtual/libudev-215-r1  USE="(systemd*)"
[ebuild   R    ] sys-process/procps-3.3.12  USE="systemd*"
[ebuild   R    ] sys-apps/util-linux-2.28.2  USE="systemd*"
[ebuild  r  U  ] x11-base/xorg-server-1.19.2 [1.18.4] USE="-debug%"
[ebuild  rR    ] x11-drivers/xf86-video-fbdev-0.4.4
[ebuild  rR    ] x11-drivers/xf86-video-intel-2.99.917_p20170216
[ebuild  rR    ] x11-drivers/xf86-video-amdgpu-1.2.0
[ebuild   R    ] net-print/cups-2.1.4  USE="systemd*"
[ebuild   R    ] sys-auth/polkit-0.113  USE="systemd*"
[ebuild   R    ] x11-misc/colord-1.3.4  USE="systemd*"

The following packages are causing rebuilds:

  (x11-base/xorg-server-1.19.2:0/1.19.2::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-drivers/xf86-video-fbdev-0.4.4:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-intel-2.99.917_p20170216:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-amdgpu-1.2.0:0/0::gentoo, ebuild scheduled for merge)

Would you like to merge these packages? [Yes/No]

unmask
=x11-drivers/xf86-video-virtualbox-5.0.32
=app-emulation/virtualbox-guest-additions-5.0.32:0/0::gentoo

emerge --pretend  --verbose-conflicts app-emulation/virtualbox-guest-additions

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] app-emulation/virtualbox-guest-additions-5.1.22  USE="X"
[ebuild  N    ~] x11-drivers/xf86-video-virtualbox-5.1.22  USE="dri" PYTHON_TARGETS="python2_7"

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by app-emulation/virtualbox-guest-additions-5.1.22::gentoo[X]
# required by app-emulation/virtualbox-guest-additions (argument)
=x11-drivers/xf86-video-virtualbox-5.1.22 ~amd64
# required by x11-drivers/xf86-video-virtualbox-5.1.22::gentoo[dri]
=app-emulation/virtualbox-guest-additions-5.1.22 ~amd64


emerge --autounmask-write app-emulation/virtualbox-guest-additions

 * IMPORTANT: 13 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!
[ebuild  N    ~] app-emulation/virtualbox-guest-additions-5.1.22  USE="X"
[ebuild  N    ~] x11-drivers/xf86-video-virtualbox-5.1.22  USE="dri" PYTHON_TARGETS="python2_7"

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by x11-drivers/xf86-video-virtualbox-5.1.22::gentoo[dri]
=app-emulation/virtualbox-guest-additions-5.1.22 ~amd64
# required by app-emulation/virtualbox-guest-additions-5.1.22::gentoo[X]
# required by app-emulation/virtualbox-guest-additions (argument)
=x11-drivers/xf86-video-virtualbox-5.1.22 ~amd64

Autounmask changes successfully written.
[/code]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum