Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't see my wifi interface (Iwlwifi)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
axelbest
n00b
n00b


Joined: 30 Dec 2005
Posts: 21
Location: Toronto, Canada

PostPosted: Tue May 30, 2017 3:06 pm    Post subject: Can't see my wifi interface (Iwlwifi) Reply with quote

Hi,

I'm just reinstalled all my system but at that time probably I did something wrong and I can't see my Wi-Fi interface. Yes, is compiled as a module in Kernel.

Code:
lspci -v
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)
        Subsystem: Intel Corporation Centrino Advanced-N 6200 2x2 AGN
        Flags: bus master, fast devsel, latency 0, IRQ 26
        Memory at f0600000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: [c8] Power Management version 3
        Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [e0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number 00-23-14-ff-ff-93-5c-a0
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi


Code:
dmesg
[   11.775283] Intel(R) Wireless WiFi driver for Linux
[   11.775284] Copyright(c) 2003- 2015 Intel Corporation
[   11.775463] iwlwifi 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
[   11.824290] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-6.ucode failed with error -2
[   11.824318] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-5.ucode failed with error -2
[   11.865850] iwlwifi 0000:03:00.0: loaded firmware version 9.221.4.1 build 25532 op_mode iwldvm
[   11.927480] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled
[   11.927482] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
[   11.927483] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
[   11.927484] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Advanced-N 6200 AGN, REV=0x74
[   11.929529] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled



Code:
ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.6.163  netmask 255.255.255.0  broadcast 192.168.6.255
        inet6 fe80::ca0a:a9ff:febf:4e5b  prefixlen 64  scopeid 0x20<link>
        ether c8:0a:a9:bf:4e:5b  txqueuelen 1000  (Ethernet)
        RX packets 59151  bytes 80908542 (77.1 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 19383  bytes 1542186 (1.4 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 248  bytes 18572 (18.1 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 248  bytes 18572 (18.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0




any tip?

Thanks in advance
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7093
Location: Saint Amant, Acadiana

PostPosted: Tue May 30, 2017 3:32 pm    Post subject: Reply with quote

ifconfig -a will show it.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
niceflower
Tux's lil' helper
Tux's lil' helper


Joined: 31 Mar 2017
Posts: 76

PostPosted: Tue May 30, 2017 10:14 pm    Post subject: Reply with quote

the handbook: https://wiki.gentoo.org/wiki/Wifi

build in the kernel modules needed, make sure you check if they should be [M] or *
then check module loading
then find out what hardware you got and what driver you need, my wifi works with a d-link bought from a shop, then you can install the module and the wifi works on usb
it is like 40 euro and endless wireless
https://forums.gentoo.org/viewtopic-t-1064284.html


your dmesg
[ 11.775283] Intel(R) Wireless WiFi driver for Linux
is fine

the ifconfig does not show your wireless driver yet,

https://wiki.gentoo.org/wiki/Intel_Corporation_PRO/Wireless_3945ABG
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5762

PostPosted: Tue May 30, 2017 11:21 pm    Post subject: Reply with quote

niceflower wrote:
...

Lecturing someone on how to compile their wifi driver and then quoting their own driver loaded messages back at them isn't helpful. This isn't the first time you've done something like this in someone else's threads, stop trying to inflate your post count.
Back to top
View user's profile Send private message
axelbest
n00b
n00b


Joined: 30 Dec 2005
Posts: 21
Location: Toronto, Canada

PostPosted: Wed May 31, 2017 12:01 am    Post subject: Reply with quote

Jaglover wrote:
ifconfig -a will show it.


Thank you, it's shows as wlan0. Is different of what was before (wlp3s0).

I have some problems with my Systemd, but ot's for another topic. Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum