Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]another stupid mistake - rebuilt without static-libs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
stardotstar
l33t
l33t


Joined: 10 Feb 2006
Posts: 887
Location: 2074/SYD/NSW/AU

PostPosted: Fri Jul 14, 2017 8:22 am    Post subject: [SOLVED]another stupid mistake - rebuilt without static-libs Reply with quote

So, I found static-libs conflicted with wifi stuff - can't remember exactly now and being hidpi I can't read a thing right now on my XPS15 - (got to set the console up next) and I did a world remerge without static-libs use in global (and I read about it some but obviously don't have a clue about the deeper implications of half this stuff) and now I boot and can't startx anymore.

I'm going to have a break but if anyone can see where my path went so badly wrong and (no doubt why) I'd appreciate the corrections to my ways (I know I'm rushing a bit headlong but my time is very constrained especially since I don't have wifi or an ability to disconnect and reconnect the eth during a session).

Something to do with losing the Xfree86 Nouveau as well which I thought was safe to kill

Code:
xps15 /var/log # cat Xorg.0.log
[    51.646]
X.Org X Server 1.19.3
Release Date: 2017-03-15
[    51.646] X Protocol Version 11, Revision 0
[    51.646] Build Operating System: Linux 4.9.34-gentoo x86_64 Gentoo
[    51.646] Current Operating System: Linux xps15 4.9.34-gentoo #9 SMP PREEMPT Fri Jul 14 16:45:39 AEST 2017 x86_64
[    51.646] Kernel command line: root=PARTUUID=77d93d41-4384-4c12-b22a-74f0dbb417f5
[    51.646] Build Date: 11 July 2017  01:48:12AM
[    51.646] 
[    51.647] Current version of pixman: 0.34.0
[    51.647]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    51.647] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    51.647] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jul 14 18:13:33 2017
[    51.647] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    51.647] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    51.647] (==) ServerLayout "Layout0"
[    51.647] (**) |-->Screen "Screen0" (0)
[    51.647] (**) |   |-->Monitor "Monitor0"
[    51.647] (**) |   |-->Device "Device0"
[    51.647] (**) |   |-->GPUDevice "intel"
[    51.647] (**) |-->Inactive Device "intel"
[    51.647] (**) |-->Input Device "Keyboard0"
[    51.647] (**) |-->Input Device "Mouse0"
[    51.647] (==) Automatically adding devices
[    51.647] (==) Automatically enabling devices
[    51.647] (==) Automatically adding GPU devices
[    51.647] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    51.647] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    51.647]    Entry deleted from font path.
[    51.647] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    51.647]    Entry deleted from font path.
[    51.647] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    51.647]    Entry deleted from font path.
[    51.647] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    51.647]    Entry deleted from font path.
[    51.647]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    51.647] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    51.647]    Entry deleted from font path.
[    51.647]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    51.647] (==) FontPath set to:
   /usr/share/fonts/misc/
[    51.647] (**) ModulePath set to "/usr/lib64/opengl/nvidia,/usr/lib64/xorg/modules"
[    51.647] (**) Extension "Composite" is enabled
[    51.647] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    51.647] (WW) Disabling Keyboard0
[    51.647] (WW) Disabling Mouse0
[    51.647] (II) Loader magic: 0x813c80
[    51.647] (II) Module ABI versions:
[    51.647]    X.Org ANSI C Emulation: 0.4
[    51.647]    X.Org Video Driver: 23.0
[    51.647]    X.Org XInput driver : 24.1
[    51.647]    X.Org Server Extension : 10.0
[    51.647] (II) xfree86: Adding drm device (/dev/dri/card0)
[    51.665] (--) PCI:*(0:0:2:0) 8086:591b:1028:07be rev 4, Mem @ 0xeb000000/16777216, 0x80000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[    51.665] (--) PCI: (0:1:0:0) 10de:1c8d:1028:07be rev 161, Mem @ 0xec000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[    51.665] (II) LoadModule: "glx"
[    51.665] (II) Loading /usr/lib64/opengl/nvidia/extensions/libglx.so
[    51.668] (II) Module glx: vendor="NVIDIA Corporation"
[    51.668]    compiled for 4.0.2, module version = 1.0.0
[    51.668]    Module class: X.Org Server Extension
[    51.668] (II) NVIDIA GLX Module  381.22  Thu May  4 00:17:15 PDT 2017
[    51.668] (II) LoadModule: "nvidia"
[    51.668] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[    51.668] (II) Module nvidia: vendor="NVIDIA Corporation"
[    51.668]    compiled for 4.0.2, module version = 1.0.0
[    51.668]    Module class: X.Org Video Driver
[    51.668] (II) LoadModule: "modesetting"
[    51.669] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[    51.669] (II) Module modesetting: vendor="X.Org Foundation"
[    51.669]    compiled for 1.19.3, module version = 1.19.3
[    51.669]    Module class: X.Org Video Driver
[    51.669]    ABI class: X.Org Video Driver, version 23.0
[    51.669] (II) NVIDIA dlloader X Driver  381.22  Wed May  3 23:53:41 PDT 2017
[    51.669] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    51.669] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    51.669] (--) using VT number 7

[    51.693] (II) Loading sub module "fb"
[    51.693] (II) LoadModule: "fb"
[    51.693] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    51.693] (II) Module fb: vendor="X.Org Foundation"
[    51.693]    compiled for 1.19.3, module version = 1.0.0
[    51.693]    ABI class: X.Org ANSI C Emulation, version 0.4
[    51.693] (II) Loading sub module "wfb"
[    51.693] (II) LoadModule: "wfb"
[    51.693] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[    51.693] (II) Module wfb: vendor="X.Org Foundation"
[    51.693]    compiled for 1.19.3, module version = 1.0.0
[    51.693]    ABI class: X.Org ANSI C Emulation, version 0.4
[    51.693] (II) Loading sub module "ramdac"
[    51.693] (II) LoadModule: "ramdac"
[    51.693] (II) Module "ramdac" already built-in
[    51.708] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[    51.708] (EE) NVIDIA:     system's kernel log for additional error messages and
[    51.708] (EE) NVIDIA:     consult the NVIDIA README for details.
[    51.714] (II) modeset(G0): using drv /dev/dri/card0
[    51.714] (EE) No devices detected.
[    51.714] (EE)
Fatal server error:
[    51.714] (EE) no screens found(EE)
[    51.714] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    51.714] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    51.714] (EE)
[    51.793] (EE) Server terminated with error (1). Closing log file.
xps15 /var/log # lsmod


emerge --info

Code:
xps15 /var/log # emerge --info
Portage 2.3.6 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-5.4.0, glibc-2.23-r4, 4.9.34-gentoo x86_64)
=================================================================
System uname: Linux-4.9.34-gentoo-x86_64-Intel-R-_Core-TM-_i7-7700HQ_CPU_@_2.80GHz-with-gentoo-2.3
KiB Mem:    32655048 total,  32015152 free
KiB Swap:   29296636 total,  29296636 free
Timestamp of repository gentoo: Thu, 13 Jul 2017 10:30:01 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.28 p1.2) 2.28
app-shells/bash:          4.3_p48-r1::gentoo
dev-lang/perl:            5.24.1-r2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.26.3::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.15-r2::gentoo
sys-devel/binutils:       2.28-r2::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.swin.edu.au/gentoo ftp://ftp.swin.edu.au/gentoo rsync://ftp.iij.ad.jp/pub/linux/gentoo/ http://ftp.iij.ad.jp/pub/linux/gentoo/ ftp://ftp.iij.ad.jp/pub/linux/gentoo/ rsync://ftp.jaist.ac.jp/pub/Linux/Gentoo/ http://ftp.jaist.ac.jp/pub/Linux/Gentoo/ ftp://ftp.jaist.ac.jp/pub/Linux/Gentoo/"
LANG="en_AU.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gpm gtk iconv ipv6 jpeg kde kipi kwallet lcms ldap libnotify mad mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qml qt3support qt4 qt5 readline sdl seccomp semantic-desktop session spell ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis widgets wxwidgets x264 xattr xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


_________________
]8P


Last edited by stardotstar on Sat Jul 15, 2017 1:44 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43383
Location: 56N 3W

PostPosted: Fri Jul 14, 2017 8:52 am    Post subject: Reply with quote

stardotstar,

Code:
[    51.708] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[    51.708] (EE) NVIDIA:     system's kernel log for additional error messages and
[    51.708] (EE) NVIDIA:     consult the NVIDIA README for details.
[    51.714] (II) modeset(G0): using drv /dev/dri/card0


Did you do a kernel upgrade/rebuild and miss
Code:
emerge @module-rebuild

As you use nvdia-drivers, which provides an 'out of tree' kernel module, it needs to be rebuilt when
a) your kernel version changes
b) for some changes in kernel configuration.

Code:
emerge @module-rebuild
rebuilds all of your out of tree kernel modules against the kernel pointed to by /usr/src/linux, so be sure that points to the kernel you want to rebuild against.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7077
Location: Austria

PostPosted: Fri Jul 14, 2017 9:52 am    Post subject: Re: Made another stupid mistake - rebuilt without static-lib Reply with quote

stardotstar wrote:
and I did a world remerge without static-libs use in global (and I read about it some but obviously don't have a clue about the deeper implications of half this stuff)

Why would you want static-libs enabled globally?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
stardotstar
l33t
l33t


Joined: 10 Feb 2006
Posts: 887
Location: 2074/SYD/NSW/AU

PostPosted: Sat Jul 15, 2017 1:21 am    Post subject: Reply with quote

Thanks guys,

Why would I want them globally? I have no idea - is it possible I saw static-libs listed with global instead of local next to it - or perhaps before I became more attuned to that distinction I naievely put static-libs in my make.conf.

Steep learning curve guys, I appreciate your guidance.
_________________
]8P
Back to top
View user's profile Send private message
stardotstar
l33t
l33t


Joined: 10 Feb 2006
Posts: 887
Location: 2074/SYD/NSW/AU

PostPosted: Sat Jul 15, 2017 1:40 am    Post subject: Reply with quote

So, Neddy, that was totally part of the problem - that command immediately prompted me to update nvidia modules,

I/ve updated them and now have the good ol black screen - which does seem to suggest a problem with the optimus rendering passthrough to the Intel onboard graphics (if that kind of makes sense) - and I note that glamor shows an error in my Xorg.0.log

Code:
will@xps15 ~ $ cat /var/log/Xorg.0.log | grep EE
[ 60649.525] Current Operating System: Linux xps15 4.9.34-gentoo #9 SMP PREEMPT Fri Jul 14 16:45:39 AEST 2017 x86_64
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 60650.550] (EE) modeset(G0): eglGetDisplay() failed
[ 60650.551] (EE) modeset(G0): glamor initialization failed


Whole log is here:
https://paste.pound-python.org/show/yBgip2ICwDQFpQ2RC0oT/

I havn't changed the xorg configs in the mean time. I notice still something about acpi and weird things like (II) evdev: Video Bus: Configuring as keyboard
Code:
 NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[ 60650.565] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[ 60650.565] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[ 60650.565] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[ 60650.565] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[ 60650.565] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[ 60650.565] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[ 60650.565] (II) NVIDIA(0):     Config Options in the README.
[ 60650.581] (II) NVIDIA(0): Setting mode "NULL"


Code:
[ 60650.453] (WW) NVIDIA(0): Unable to get display device for DPI computation.

_________________
]8P
Back to top
View user's profile Send private message
stardotstar
l33t
l33t


Joined: 10 Feb 2006
Posts: 887
Location: 2074/SYD/NSW/AU

PostPosted: Sat Jul 15, 2017 1:43 am    Post subject: Reply with quote

Sorry all, reboot and its back up...

Thanks
_________________
]8P
Back to top
View user's profile Send private message
stardotstar
l33t
l33t


Joined: 10 Feb 2006
Posts: 887
Location: 2074/SYD/NSW/AU

PostPosted: Sat Jul 15, 2017 3:44 am    Post subject: Reply with quote

Final tidyup re my static-libs thing - what should I do to resolve these current static-lib cautions:

Code:
xps15 /home/will # emerge --ask --update --deep --verbose --tree --newuse kde-plasma/plasma-desktop

 * IMPORTANT: 14 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-libs/libgcrypt:0

  (dev-libs/libgcrypt-1.7.8:0/20::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-libs/libgcrypt-1.6.3:0[static-libs] required by (sys-power/suspend-1.0_p20150810:0/0::gentoo, installed)
                                 ^^^^^^^^^^^

dev-libs/libgpg-error:0

  (dev-libs/libgpg-error-1.27-r1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    dev-libs/libgpg-error[static-libs] required by (sys-power/suspend-1.0_p20150810:0/0::gentoo, installed)
                          ^^^^^^^^^^^

dev-libs/lzo:2

  (dev-libs/lzo-2.09:2/2::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-libs/lzo-2[static-libs] required by (sys-power/suspend-1.0_p20150810:0/0::gentoo, installed)
                     ^^^^^^^^^^^



 * kde-plasma/plasma-desktop

Would you like to add these packages to your world favorites? [Yes/No]

_________________
]8P
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2641

PostPosted: Sat Jul 15, 2017 5:45 am    Post subject: Reply with quote

emerge --ask --depclean sys-power/suspend

And when you install it again, read and follow thr messages. Portage does it all for you.
Back to top
View user's profile Send private message
stardotstar
l33t
l33t


Joined: 10 Feb 2006
Posts: 887
Location: 2074/SYD/NSW/AU

PostPosted: Sat Jul 15, 2017 6:19 am    Post subject: Reply with quote

Ok, looking good, thanks Charles.
_________________
]8P
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2641

PostPosted: Sat Jul 15, 2017 6:31 am    Post subject: Reply with quote

P.S.: Make friends with etc-update or the likes.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum