Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Looking for Abiword 2.8 source code. [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3311
Location: Illinois, USA

PostPosted: Mon Jun 12, 2017 5:56 pm    Post subject: Looking for Abiword 2.8 source code. [SOLVED] Reply with quote

I have what seems to be a common problem with Abiword 3.0. When opened, the document throbs for a long time. Editting the document does the same thing.
see this bug https://bugs.gentoo.org/show_bug.cgi?id=601300

I run a Windows port of Abiword 2.8 on a dual boot machine and have no problems. I could try installing this on Wine, but would prefer to install it the proper Gentoo way.

I can retrieve 2.8.6-r2 from the portage attic, but then there are the patches and source code to find.

I installed Libreoffice-bin (too big to build!) as a workaround, but prefer the abiword interface if it didn't throb and flash!

Can anyone help me find the patches and source code? With them, I can try to update the ebuild from EAPI 4.


Last edited by Tony0945 on Tue Jun 13, 2017 4:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
R0b0t1
Apprentice
Apprentice


Joined: 05 Jun 2008
Posts: 255

PostPosted: Mon Jun 12, 2017 8:52 pm    Post subject: Reply with quote

The source is available here: https://www.abisource.com/downloads/abiword/. There isn't a link to that page on the website, I had to navigate up from the download link provided that went into the 3.0.2 directory.

The patches will be harder to find - check the ebuild and see if you can find something searchable or a reference to a mailing list posting. You might consider building whatever version of Abiword you desire outside of portage for testing.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10390
Location: Somewhere over Atlanta, Georgia

PostPosted: Mon Jun 12, 2017 8:55 pm    Post subject: Reply with quote

Patches should be in the attic as well, if they're that old, else in the git repository if they're recent.

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3311
Location: Illinois, USA

PostPosted: Tue Jun 13, 2017 4:10 pm    Post subject: Reply with quote

Thank you both! The patches were indeed in the attic.

EAPI=4 was still OK but I had to modify the ebuild to remove USE flags that no longer apply. Then the ebuild failed because I am using GCC 6.3.0

I had to create the file /etc/portage/env/app-office/abiword
Code:
X3 tony # cat /etc/portage/env/app-office/abiword
CFLAGS+=" -std=gnu++98"
CPPFLAGS+=" -std=gnu++98"

Actually from warning messages, I think the first line is not needed because its wrong.
I could do some more changes to maybe use MATE dependencies instead of GNOME but it built and does not have the flashing bug that 3.0.2 has.

EDIT:
The modified ebuild is here if anybody is interested:
https://paste.pound-python.org/show/PfvJ5115l9uujnKmMEXf/
Code:
 tony # cat /etc/portage/env/app-office/abiword
CFLAGS+=" -std=gnu++98"
CPPFLAGS+=" -std=gnu++98"


EDIT2:
As I suspected, only the second line is needed.
Code:
CASTI abiword #  cat /etc/portage/env/app-office/abiword
CPPFLAGS+=" -std=gnu++98"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum