Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
VirtualBox crashing after docker installation
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message

Joined: 22 Sep 2005
Posts: 11
Location: Berlin, Germany

PostPosted: Tue Jun 20, 2017 10:15 am    Post subject: VirtualBox crashing after docker installation Reply with quote


I ran VirtualBox on my Gentoo machine, and all worked fine until I installed Docker on the same host. Okay, I already read that Docker and VirtualBox are not working that easily together, and since I needed Docker on the guest system anyway, I removed it from my host system. Which means, I unmerged docker and all its dependencies via emerge --depclean, and of course I rebooted. The only thing I kept are the additional kernel modules mandatory for Docker, but they're only modules, and none of them is listed in /etc/conf.d/modules.

But VirtualBox still doesn't start. Or at least the GUI starts, but whenever I start some image, I get this error:


The virtual machine '' has terminated unexpectedly during startup because of signal 9.

Fehlercode:NS_ERROR_FAILURE (0x80004005)
Interface:IMachine {f30138d4-e5ea-4b3a-8858-a059de4c93fd}

Looking in dmesg, I find this interesting stuff:

[   14.171426] .....
[   25.367495] VBoxNetAdp: failed to set MAC address (dev->dev_addr == NULL)
[   26.637183] BUG: unable to handle kernel NULL pointer dereference at           (null)
[   26.637205] IP: [<ffffffff810e5b31>] from_kuid+0x1/0x70
[   26.637221] PGD 836bc7067
[   26.637227] PUD 836bc6067
[   26.637235] PMD 0

[   26.637244] Oops: 0000 [#1] SMP
[   26.637251] Modules linked in: nfsd rpcsec_gss_krb5 auth_rpcgss oid_registry nfsv4 nfs lockd grace sunrpc cfg80211 rfkill snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic input_leds led_class usbhid vboxpci(O) vboxnetadp(O) vboxnetflt(O) vboxdrv(O) x86_pkg_temp_thermal snd_hda_intel i915 coretemp snd_hda_codec intel_cstate snd_hwdep i2c_algo_bit snd_hda_core drm_kms_helper intel_rapl_perf snd_pcm e1000e syscopyarea snd_timer sysfillrect sysimgblt ptp snd fb_sys_fops pps_core drm xhci_pci cfbfillrect sr_mod xhci_hcd cfbimgblt cfbcopyarea cdrom mei_me intel_gtt usbcore mei agpgart usb_common video backlight
[   26.637408] CPU: 6 PID: 3314 Comm: VirtualBox Tainted: G           O    4.9.16-gentoo #2
[   26.637425] Hardware name: System manufacturer System Product Name/MAXIMUS VIII HERO, BIOS 1701 03/25/2016
[   26.637442] task: ffff88084f1d9b80 task.stack: ffffc90008bdc000
[   26.637455] RIP: 0010:[<ffffffff810e5b31>]  [<ffffffff810e5b31>] from_kuid+0x1/0x70
[   26.637475] RSP: 0018:ffffc90008bdfbd8  EFLAGS: 00010202
[   26.637486] RAX: ffff88084f1da180 RBX: 0000000000000001 RCX: 0000000000000004
[   26.637499] RDX: 0000000000000001 RSI: 0000000000000000 RDI: 0000000000000000
[   26.637513] RBP: ffffc90008bdfc08 R08: 0000000000000000 R09: 0000000000000000
[   26.637526] R10: 0000000000000000 R11: 0000000000000000 R12: ffff88084ef0b100
[   26.637540] R13: ffff88084ef0b100 R14: ffff88084bb09b48 R15: ffffffffa045f740
[   26.637553] FS:  00007f0dbd868700(0000) GS:ffff880873d80000(0000) knlGS:0000000000000000
[   26.637568] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[   26.637579] CR2: 0000000000000000 CR3: 0000000835b63000 CR4: 00000000003406e0
[   26.637592] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[   26.637605] DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
[   26.637618] Stack:
[   26.637628]  ffffc90008bdfc08 ffffffffa0426165 ffffffff8119f4dc 0000000000000000
[   26.637646]  000000000000003a ffff88084ef0b100 ffffc90008bdfc18 ffffffffa042623e
[   26.637663]  ffffc90008bdfc50 ffffffff813bf95c ffffffff81862140 ffff88084f989200
[   26.637680] Call Trace:
[   26.637688]  [<ffffffffa0426165>] ? SUPDrvLinuxIDC+0x145/0x220 [vboxdrv]
[   26.637702]  [<ffffffff8119f4dc>] ? exact_lock+0xc/0x20
[   26.637713]  [<ffffffffa042623e>] SUPDrvLinuxIDC+0x21e/0x220 [vboxdrv]
[   26.637727]  [<ffffffff813bf95c>] misc_open+0x13c/0x160
[   26.637738]  [<ffffffff8119fb82>] chrdev_open+0xa2/0x170
[   26.637751]  [<ffffffff81198813>] do_dentry_open+0x203/0x2f0
[   26.637762]  [<ffffffff8119fae0>] ? cdev_put+0x20/0x20
[   26.637773]  [<ffffffff81199af7>] vfs_open+0x47/0x70
[   26.637786]  [<ffffffff811a6746>] ? may_open+0x96/0x100
[   26.637796]  [<ffffffff811a95c0>] path_openat+0x2d0/0x1340
[   26.637808]  [<ffffffff811ab6e9>] do_filp_open+0x79/0xd0
[   26.637821]  [<ffffffff8118a453>] ? kmem_cache_alloc+0x133/0x1d0
[   26.637833]  [<ffffffff811aa7f1>] ? getname_flags+0x51/0x1f0
[   26.637847]  [<ffffffff81199ea6>] do_sys_open+0x116/0x1f0
[   26.637857]  [<ffffffff81199f99>] SyS_open+0x19/0x20
[   26.637868]  [<ffffffff81624fa0>] entry_SYSCALL_64_fastpath+0x13/0x94
[   26.637881] Code: 44 89 d2 83 ea 01 39 d6 77 dd 44 39 c6 72 d8 48 8d 04 49 03 74 87 08 89 f0 44 29 c0 5d c3 b8 ff ff ff ff 5d c3 31 c9 eb e6 90 55 <44> 8b 0f 48 89 e5 45 85 c9 b8 ff ff ff ff 74 51 44 8b 47 08 8b
[   26.637967] RIP  [<ffffffff810e5b31>] from_kuid+0x1/0x70
[   26.637979]  RSP <ffffc90008bdfbd8>
[   26.637991] CR2: 0000000000000000
[   26.643019] ---[ end trace 62a7b29a25f00546 ]---

Running modprobe -v vboxnetadp seems to work without problems.

This is from emerge --info:

emerge --info
Portage 2.3.6 (python 2.7.12-final-0, default/linux/amd64/13.0, gcc-5.4.0, glibc-2.23-r4, 4.9.16-gentoo x86_64)
System uname: Linux-4.9.16-gentoo-x86_64-Intel-R-_Core-TM-_i7-6700K_CPU_@_4.00GHz-with-gentoo-2.3
KiB Mem:    32830608 total,  28702316 free
KiB Swap:   33554428 total,  33554428 free
Timestamp of repository gentoo: Tue, 20 Jun 2017 07:00:01 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.28 p1.2) 2.28
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1-r2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.26.3::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.28-r2::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r4::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.3/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="3dnow X acl alsa amd64 berkdb btrfs bzip2 cli cracklib crypt cxx dbus dri flac fortran gdbm gif iconv idn intel ipv6 java jpeg jpeg2k jpg mmap mmx modules mp3 multilib ncurses nls nptl ogg opengl openmp pam pcre png readline sdl seccomp session sse sse2 ssl ssse3 svg tcpd tiff truetype unicode vim-syntax vorbis xattr xvmc zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" L10N="de en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de de_DE de_DE.UTF-8 en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python3_4 python2_7" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="intel i965 i915 fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Any help is appreciated!


[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message

Joined: 23 Dec 2013
Posts: 344
Location: Brisbane, Australia

PostPosted: Wed Jun 21, 2017 1:44 am    Post subject: Reply with quote

I use this methodology to fix "difficult" problems with host side VirtualBox and other applications:


1.) unmerge VirtualBox and everything that may cause problems.

2.) emerge --sync

3.) emerge --update --deep --with-bdeps=y --newuse --backtrack=300 --changed-deps=y --keep-going=y @world -va

4.) if required answer "No" and fix use flags, keywords, masks etc.

5.) again emerge --update --deep --with-bdeps=y --newuse --backtrack=300 --changed-deps=y --keep-going=y @world -va

6.) if OK, answer "Yes"

7.) when done, run emerge --depclean followed by

8.) revdep-rebuild

9.) perl-cleaner

10.) emerge -av app-emulation/virtualbox app-emulation/virtualbox-additions app-emulation/virtualbox-extpack-oracle app-emulation/virtualbox-modules

11.) verify that /etc/conf.d/modules contains the line: modules="vboxdrv vboxnetflt vboxnetadp vboxpci"

Back to top
View user's profile Send private message

Joined: 22 Sep 2005
Posts: 11
Location: Berlin, Germany

PostPosted: Wed Jun 21, 2017 6:46 am    Post subject: Reply with quote

Thank you for your help. I unmerged virtualbox, rebooted, emerged it again together with virtualbox-modules (just to see if there are warnings, but there were none), and now it works.

Hard to tell why, there were no warnings, no errors.

Anyway, it's working at least. Thanks again!
Back to top
View user's profile Send private message

Joined: 21 Nov 2019
Posts: 1

PostPosted: Thu Nov 21, 2019 7:59 am    Post subject: Reply with quote

I had the same problem after installing docker. Reemerging virtualbox and modules solved it for me too.

This thread was the only solution I could find... thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum