Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bebob befuddled [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6313
Location: /usr/lib64/lv2

PostPosted: Thu Jun 22, 2017 12:04 am    Post subject: Bebob befuddled [SOLVED] Reply with quote

Any idea how to fix this?
Code:

src/bebob/bebob_dl_mgr.cpp: In member function 'bool BeBoB::BootloaderManager::downloadFirmware(std::__cxx11::string)':
src/bebob/bebob_dl_mgr.cpp:244:5: error: 'ffado_smartptr' was not declared in this scope
     ffado_smartptr<BCD> bcd = ffado_smartptr<BCD>( new BCD( filename ) );
     ^
src/bebob/bebob_dl_mgr.cpp:244:23: error: expected primary-expression before '>' token
     ffado_smartptr<BCD> bcd = ffado_smartptr<BCD>( new BCD( filename ) );
                       ^
src/bebob/bebob_dl_mgr.cpp:244:25: error: 'bcd' was not declared in this scope
     ffado_smartptr<BCD> bcd = ffado_smartptr<BCD>( new BCD( filename ) );
                         ^
src/bebob/bebob_dl_mgr.cpp:244:49: error: expected primary-expression before '>' token
     ffado_smartptr<BCD> bcd = ffado_smartptr<BCD>( new BCD( filename ) );
                                                 ^
src/bebob/bebob_dl_mgr.cpp: In member function 'bool BeBoB::BootloaderManager::downloadCnE(std::__cxx11::string)':
src/bebob/bebob_dl_mgr.cpp:307:5: error: 'ffado_smartptr' was not declared in this scope
     ffado_smartptr<BCD> bcd = ffado_smartptr<BCD>( new BCD( filename ) );
     ^
src/bebob/bebob_dl_mgr.cpp:307:23: error: expected primary-expression before '>' token
     ffado_smartptr<BCD> bcd = ffado_smartptr<BCD>( new BCD( filename ) );
                       ^
src/bebob/bebob_dl_mgr.cpp:307:25: error: 'bcd' was not declared in this scope
     ffado_smartptr<BCD> bcd = ffado_smartptr<BCD>( new BCD( filename ) );
                         ^
src/bebob/bebob_dl_mgr.cpp:307:49: error: expected primary-expression before '>' token
     ffado_smartptr<BCD> bcd = ffado_smartptr<BCD>( new BCD( filename ) );
                                                 ^
x86_64-pc-linux-gnu-g++ -m32 -o src/libavc/ccm/avc_signal_source.os -c -march=native -O2 -pipe -std=gnu++11 -fPIC -DDEBUG_MESSAGES -DENABLE_BEBOB -DENABLE_FIREWORKS -DENABLE_OXFORD -DENABLE_MOTU -DENABLE_DICE -DENABLE_RME -DENABLE_GENERICAVC -I. -Isrc -I/usr/include/libxml++-3.0 -I/usr/lib32/libxml++-3.0/include -I/usr/include/libxml2 -I/usr/include/glibmm-2.4 -I/usr/lib32/glibmm-2.4/include -I/usr/include/glib-2.0 -I/usr/lib32/glib-2.0/include -I/usr/include/sigc++-2.0 -I/usr/lib32/sigc++-2.0/include src/libavc/ccm/avc_signal_source.cpp
scons: *** [src/bebob/bebob_dl_mgr.os] Error 1
x86_64-pc-linux-gnu-g++ -m32 -o src/fireworks/efc/efc_cmds_mixer.os -c -march=native -O2 -pipe -std=gnu++11 -fPIC -DDEBUG_MESSAGES -DENABLE_BEBOB -DENABLE_FIREWORKS -DENABLE_OXFORD -DENABLE_MOTU -DENABLE_DICE -DENABLE_RME -DENABLE_GENERICAVC -I. -Isrc -I/usr/include/libxml++-3.0 -I/usr/lib32/libxml++-3.0/include -I/usr/include/libxml2 -I/usr/include/glibmm-2.4 -I/usr/lib32/glibmm-2.4/include -I/usr/include/glib-2.0 -I/usr/lib32/glib-2.0/include -I/usr/include/sigc++-2.0 -I/usr/lib32/sigc++-2.0/include src/fireworks/efc/efc_cmds_mixer.cpp
scons: building terminated because of errors.
 * ERROR: media-libs/libffado-9999::x-portage failed (compile phase):
 *   escons failed.
 *
 * Call stack:
 *     ebuild.sh, line  115:  Called src_compile
 *   environment, line 3774:  Called multilib-minimal_src_compile
 *   environment, line 2188:  Called multilib_foreach_abi 'multilib-minimal_abi_src_compile'
 *   environment, line 2419:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_compile'
 *   environment, line 2054:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_compile'
 *   environment, line 2052:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_compile'
 *   environment, line  430:  Called multilib-minimal_abi_src_compile
 *   environment, line 2182:  Called multilib_src_compile
 *   environment, line 2640:  Called myescons
 *   environment, line 2697:  Called escons
 *   environment, line 1180:  Called die
 * The specific snippet of code:
 *                   die "escons failed."

_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.


Last edited by audiodef on Thu Jun 22, 2017 4:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21712
Location: here

PostPosted: Thu Jun 22, 2017 6:05 am    Post subject: Reply with quote

Use this patch
ffado_smartptr-error.patch:
diff -Naur libffado-9999.orig/src/bebob/bebob_dl_mgr.cpp libffado-9999/src/bebob/bebob_dl_mgr.cpp
--- libffado-9999.orig/src/bebob/bebob_dl_mgr.cpp       2017-06-22 08:01:05.569976242 +0200
+++ libffado-9999/src/bebob/bebob_dl_mgr.cpp    2017-06-22 08:01:46.939975838 +0200
@@ -32,6 +32,7 @@
 #include "libutil/Time.h"
 
 #include "libutil/ByteSwap.h"
+#include "ffadodevice.h"   // Needed for ffado_smartptr
 
 #include <cstdio>
 #include <cstring>

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6313
Location: /usr/lib64/lv2

PostPosted: Thu Jun 22, 2017 3:06 pm    Post subject: Reply with quote

Thanks! Now I'm a getting failed patch/can't find file to patch error. Added a patches line to the ebuild:
Code:

# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI="5"

PYTHON_COMPAT=( python2_7 )
[[ "${PV}" = "9999" ]] && inherit subversion
inherit eutils python-single-r1 scons-utils toolchain-funcs udev multilib-minimal

DESCRIPTION="Successor for freebob: Library for accessing BeBoB IEEE1394 devices"
HOMEPAGE="http://www.ffado.org"

RESTRICT="mirror"
if [ "${PV}" = "9999" ]; then
   ESVN_REPO_URI="http://subversion.ffado.org/ffado/trunk/${PN}"
   SRC_URI=""
   KEYWORDS=""
else
   SRC_URI="http://www.ffado.org/files/${P}.tgz"
   KEYWORDS="~amd64 ~ppc ~x86"
fi

LICENSE="GPL-2"
SLOT="0"
IUSE="debug qt4 +test-programs"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="dev-cpp/libxmlpp[${MULTILIB_USEDEP}]
   dev-libs/dbus-c++
   dev-libs/libconfig[cxx,${MULTILIB_USEDEP}]
   media-libs/alsa-lib
   media-libs/libiec61883[${MULTILIB_USEDEP}]
   sys-apps/dbus
   sys-libs/libraw1394[${MULTILIB_USEDEP}]
   sys-libs/libavc1394[${MULTILIB_USEDEP}]
   ${PYTHON_DEPS}
   qt4? (
      dev-python/PyQt4[dbus,${PYTHON_USEDEP}]
      dev-python/dbus-python[${PYTHON_USEDEP}]
      x11-misc/xdg-utils
   )"
DEPEND="${RDEPEND}
   virtual/pkgconfig"

PATCHES=(
        "${FILESDIR}"/ffado_smartptr-error.patch
)

multilib_native_use_scons() {
   if multilib_is_native_abi; then
      use_scons "${@}"
   else
      echo "${2:-${1}}=${4:-${USE_SCONS_FALSE}}"
   fi
}

myescons() {
   myesconsargs=(
      PREFIX="${EPREFIX}/usr"
      LIBDIR="${EPREFIX}/usr/$(get_libdir)"
      MANDIR="${EPREFIX}/usr/share/man"
      UDEVDIR="$(get_udevdir)/rules.d"
      CUSTOM_ENV=True
      DETECT_USERSPACE_ENV=False
      $(use_scons debug DEBUG)
      $(multilib_native_use_scons qt4 BUILD_MIXER true false)
      $(multilib_native_use_scons test-programs BUILD_TESTS)
      # ENABLE_OPTIMIZATIONS detects cpu type and sets flags accordingly
      # -fomit-frame-pointer is added also which can cripple debugging.
      # we set flags from portage instead
      ENABLE_OPTIMIZATIONS=False
   )
   escons "${@}"
}

src_unpack() {
   if [ "${PV}" = "9999" ]; then
      subversion_src_unpack
   else
      default
   fi
}

src_prepare() {
   [[ ${PATCHES[@]} ]] && epatch "${PATCHES[@]}"
   multilib_copy_sources
}

multilib_src_configure() {
   : # no-op
}

multilib_src_compile () {
   tc-export CC CXX
   myescons
}

multilib_src_install () {
   myescons DESTDIR="${D}" WILL_DEAL_WITH_XDG_MYSELF="True" install
}

multilib_src_install_all() {
   einstalldocs

   python_fix_shebang "${D}"
   python_optimize "${D}"

   if use qt4; then
      newicon "support/xdg/hi64-apps-ffado.png" "ffado.png"
      newmenu "support/xdg/ffado.org-ffadomixer.desktop" "ffado-mixer.desktop"
   fi
}


What version is this patch intended for?
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.


Last edited by audiodef on Thu Jun 22, 2017 3:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21712
Location: here

PostPosted: Thu Jun 22, 2017 3:09 pm    Post subject: Reply with quote

You can post exact error?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1740
Location: Here and Away Again

PostPosted: Thu Jun 22, 2017 3:17 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software, since 'media-libs/libffado' is not available via Portage at this time.
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6313
Location: /usr/lib64/lv2

PostPosted: Thu Jun 22, 2017 3:22 pm    Post subject: Reply with quote

fedeliallalinea wrote:
You can post exact error?


Sure, here it is: https://pastebin.com/RQWPqHMF
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21712
Location: here

PostPosted: Thu Jun 22, 2017 3:27 pm    Post subject: Reply with quote

Maybe a wrong copy/paste of patch? Try to download from here
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6313
Location: /usr/lib64/lv2

PostPosted: Thu Jun 22, 2017 4:02 pm    Post subject: Reply with quote

That worked. Thank you. I will include this in Gentoo Studio. :)
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum